BLACK SCREEN at the reboot after install nVidia driver 375.26 Geforce GT630 Ubuntu 16.04 64bit...

Hi there,
I’m having Black Screen at the reboot after install nVidia driver 375.26. My card is Zotac Geforce GT630 4Gb. My operational system is Ubuntu 16.04 64bits. My PC is Pentium Dual Core CPU E5300 @ 2.60GHz × 2, and the Ram memory is 4Gb. I’m using BIOS, not UEFI. My Setup have UEFI, but not have Secure Boot. I’m not using UEFI anyway. My monitor is LG FLATRON W2053TQ and the native resolution is 1600x900. The bug-report is attached. I can not get into the graphical interface. Help me, please.
nvidia-bug-report.log.gz (67.1 KB)

I’ve already tried inserting nomodeset in grub, but it’s useless.

You should have installed the nVidia driver version recommended by Ubuntu 16.04.x. Newer drivers usually add nothing but new problems to older cards.

The next time you boot your PC, hold down the key. Doing so should expose the GRUB and allow you to boot into recovery mode (do a search).

A tip for Linux Mint (or Ubuntu) users who find it desirable or necessary to change from one nVidia driver version to another:

  • Via Driver Manager (or in Ubuntu, ubuntu-software) install xserver-xorg-video-nouveau

  • Reboot

  • Then install the desired version of the nVidia binary driver

  • Reboot

BTW:

In Ubuntu install unity-tweak-tool and you will be able to adjust the font sizes (along with other aspects of Unity’s behaviour). And while you’re at it, also install compizconfig-settings-manager and then turn off Animations and Fading Windows. Doing so will make Unity less sluggish.

As well, consider switching to Ubuntu 14.04.x-based Linux Mint 17.3 MATE (not Linux Mint 18.1, it’s bloated and buggy) as it will run a lot faster on that older machine.

Linux Mint 17.3 “Rosa” - MATE (64-bit) - Linux Mint
https://linuxmint.com/edition.php?id=206

Click the first link in my forum signature and scroll down to: ‘HOW TO PARTITION A LINUX MINT HDD’.

Nouveau has to be blacklisted. If you’re installing the binary nvidia drivers manually, you have to also blacklist manually, see:
http://askubuntu.com/questions/481414/install-nvidia-driver-instead-nouveau

I used Ubuntu 14.04 with the nVidia driver 352.63, recommended by Ubuntu. The black screen issues started when Ubuntu updated the driver to version 361. On Ubuntu 16.04 I also tried to use the recommended version (367 nVidia driver) and also had black screen. Nomodeset on grub did not work. So I tried the ppa:graphics-drivers/ppa, but I still have black screen.
The performance of Ubuntu 16.04 on my PC is as good as or better than Ubuntu 14.04. The problem is only the nVidia drivers.
I had already tried switching the driver the way you succeded, installing before the nouveau, etc., but it also did not work.
But in Windows 10, the latest version of the nVidia driver, 378.49, works good. In Ubuntu, the latest version of the nVidia driver for linux should also work, right?

I’m using the ppa:graphics-drivers/ppa. I thought using that PPA, the nouveu blaklist was automatic. I am wrong?

If you’re using the ppa you should be fine, it installs a blacklist file.

The way I used to install nVidia driver 375.26 was PPA and the result was the black screen after reboot, as I said at the beginning.

From what I am reporting (including my nvidia-bug-report.log.gz file), can I expect some compatibility improvement with my GT630 card in the next version of the nVidia driver?

That info was good and necessary:

  • Does still work in Windows 10 (So no hardware issue)
  • Used to work with driver 352.63 on Ubuntu 14.04
  • Stopped working when updated to 361 on Unbuntu 14.04
  • Does still not work after upgrade to 375 on Ubuntu 16.10
    Is this correct?
    One thing that changed is that the nvidia-uvm module (just needed for cuda) is automatically loaded in newer (ubuntu) drivers. Can you blacklist that one? And check after reboot using sudo lsmod if it really not loaded.

Everything is correct, with the following correction:

  • Does still not work on Ubuntu 16.04 using any driver after 361. Example: 361, 367, 370, 375, 378.

Are you asking me to blacklist the nvidia-uvm module after install 375.26? How do I do to blacklist that?

The 361 driver also does not work on Ubuntu 16.04.

Having 375 installed. Can’t really tell you for sure since I don’t use ubuntu but try:
sudo echo -e “blacklist nvidia-uvm \nblacklist nvidia_375_uvm” > /etc/modprobe.d/00-nvidia-uvm.conf
sudo update-initramfs -u
reboot

run nvidia-bug-report.sh again after that.

The following will give you access to nVidia drivers that pre-date ver. 361.x but which will have to be downloaded and manually installed. Just search for drivers that are specific to the GT-630.

NVIDIA Driver Downloads - Advanced Search
https://www.nvidia.com/Download/Find.aspx?lang=en-us

If I were in your situation I’d try ver. 340.101 (but first search through the available driver versions and then make your own determination):

Version: 340.101
Release Date: 2016.12.14
Operating System: Linux 64-bit
Language: English (US)
File Size: 66.8 MB

NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver
http://www.nvidia.com/download/driverResults.aspx/112998/en-us

EDIT: I just searched for nvidia in Synaptic Package Manager and there are plenty of nVidia driver versions listed which are older than 361.x.

As a side note: In conjunction with primarily AMD-based Asus motherboards running Ubuntu 9.0.4 - 10.04.x and later on Linux Mint 13 - 17.3 MATE, over the years I’ve used an EVGA GeForce 6200, a GIGABYTE GV-N520SL-1GI, an ASUS GT640-DCSL-2GD3, an Asus GTX750-DCSL-2GD5 and currently an Asus STRIX-GTX960-DC2OC-4GD5 and I’ve never experienced anything like the major nVidia driver issues I see described on this site.

After installing nVidia 375.26, I tried to do what you said about blacklist and the result was “Permissão negada”, which means permission denied. Here is the result of the terminal:

adriano@adriano-desktop:~ sudo echo -e "blacklist nvidia-uvm \nblacklist nvidia_375_uvm" > /etc/modprobe.d/00-nvidia-uvm.conf bash: /etc/modprobe.d/00-nvidia-uvm.conf: Permissão negada adriano@adriano-desktop:~

I try this after and before reboot and the result was the same.

I installed the nVidia 375.26 driver by PPA. At the terminal I typed “sudo su” before the commands you suggested and then your blacklist commands worked. But, when I rebooted the PC, the black screen continues.

The nvidia-bug-report-log file is attached. Does this bug-report help?

Should I delete the /etc/modprobe.d/00-nvidia-uvm.conf file?
nvidia-bug-report.log.gz (67.5 KB)

Sorry for the wrong syntax but you figured it out correctly by yourself. The nvidia-uvm module doesn’t get loaded.
Most noteworthy is that the errors changed from XID 31 to XID 32
https://docs.nvidia.com/deploy/xid-errors/#topic_5_2
Since your system works under Windows 10 this more and more looks like some incompatibility in the gpu - mainboard - kernel - nvidia-driver chain. Can you please give detailed info on your mainboard (brand/model)? When you updated to the 361 driver in the first place maybe also the kernel got upgraded introducing some pci-e changes. Or could you downgrade to 352 back then?
For further debugging this, you can reduce your setup even more

  1. disable nvidia-persistenced: as root move/rename /usr/lib/systemd/system/nvidia-persistenced.service
  2. to get rid of the vga console warning add video=vesa:off vga=normal to kernel parameters
    Then run nvidia-bug-report.sh again

My motherboard is an Intel dg41ty. Here is detailed info:
http://ark.intel.com/products/37164/Intel-Desktop-Board-DG41TY
Where should I type “video=vesa:off vga=normal to kernel parameters”? Should the text “to kernel parameters” be entered too? Should I simply open the terminal and type these things?

In your second post you mentioned that you were adding nomodeset to grub. That meant you were adding it to kernel parameters/commandline.
So in your words, add
video=vesa:off vga=normal
to grub.

to disable/rename the persistenced service:
sudo mv /usr/lib/systemd/system/nvidia-persistenced.service /usr/lib/systemd/system/nvidia-persistenced.service.old