Black screen after prime-select nvidia and log out using v346.35 drivers

System: Razer Blade 14" 2015
OS: Ubuntu 14.10

When I

sudo prime-select nvidia

and then log out, my screen goes black. If I close my laptop until it sleeps and open the lid, the screen comes back and I can log in. If I reboot with nvidia graphics selected, I get a black screen after boot and must do the same process (close lid, wait for sleep, open lid, log in). If I switch to intel graphic or boot with intel graphics, behavior is normal.

Otherwise, everything seems to work fine. I installed the drivers as described here

https://insider.razerzone.com/index.php?threads/linux-on-a-new-blade.4115/#post-123099

I have generated nvidia-bug-report.log.gz with verbose logging enabled.
nvidia-bug-report.log.gz (63.1 KB)

Hello,

I am experiencing the exact same symptoms with my optimus laptop (Acer ASPIRE V Nitro VN7-791G-71R3 with a Nvidia GF GTX 860M) since upgrading to driver version 346.35.

The laptop is running with ubuntu 14.10 with xorg and nvidia drivers packaged by the xorg-edgers ppa (https://launchpad.net/~xorg-edgers/+archive/ubuntu/ppa)

If with prime I switch to or boot with nvidia gpu then the screen stays black.
Or it won’t refresh when I switch from a tty console.

But if I close the lid and then resume from sleep, the display is working fine.

nvidia-bug-report.log.gz (149 KB)

I’m experiencing the same issue running Xubuntu 14.10 on a Dell Latitude E6430 with a Nvidia NVS5200M.

When i install Nvidia 346.35, after a reboot the display turns black upon starting (just before the login screen should appear). When i switch to the Intel HD 4000 Graphics the display works, but when switching to the NVS 5200M the display turns black.

I’ve installed driver 346.35 via “sudo apt-get install nvidia-346” got it from xorg-edgers ppa.

Nvidia driver version 340.76 does not exhibit this problem.

I’ve ran nvidia-bug-report.sh and collected a log file, but i can for the life of me figure out how to attach it to my post. If someone is willing to point out how i can attach the log that would be great.

I’ve added the Nvidia bug report / logfile here:
http://paste.ubuntu.com/10295551/

Still i would like to now how i can upload a bug report directly to this forum…

I had the same problem to start :) Once you’ve posted, if you hover over the post, you should see a paperclip icon. Click it and you can upload your file.

Thanks a lot Ramsey i’ve just uploaded the bug report properly :)

hi, i have the same problem. The user of linux need best Nvidia support. Thanks.

Just a note for those interested: I updated to 346.47 and this behavior is unchanged.

same problem here with xubuntu & ubuntu 14.10 64bit.

but 14.04.2 works fine…

The strange thing is that i’ve installed NVIDIA driver version 346.47 via the xorg-edgers repository yesterday night, and the problem is gone.
I can now use my notebook without running into Nvidia-related black-screen problems. Switching between the IGP and the discrete-gpu works fine. I’m still running Xubuntu 14.10 x86_64.

I have to add though that i made some configuration changes in terms of installed packages: i’ve upgraded the xorg-server-core and xserver-common packages to version (2:)1.16.1.901, among other things.

I’ve added a link to part of my apt-log so you can compare any packages and perhaps try some different packages:
http://paste.ubuntu.com/10434474/

I updated to 346.47 and the problem is still present.

For info xorg is already at version 2:1.16.1.901-1ubuntu1~utopic1

same here same xorg- same drivers same bug…

Well i’ve also upgraded the Intel Libdrm package to version 2.4.59:
Upgrade: libdrm-intel1:amd64 (2.4.56-1, 2.4.59+git20150125.0c5aaeef-0ubuntu0ricotz~utopic)

Now that i think of it: after upgrading the xserver-xorg-video-intel to version 2.99.917 the black-screen appeared again (at the time i was still using 340.76) after downgrading it to the default version (2.99.914-1) the problem disappeared.

Well i’m off to bed I’ll check back tomorrow

Did somebody try version 349 ? Is there any progress ?

no at today same story same bug… ridicoulous…

Solved the issue. I am using the following setup: Laptop with GTX 970m. Optimus. Ubuntu 14.04 LTS. CUDA 7.0.

There seems to be an issue with the xorg-edgers repo. When installing the latest version I start with a black screen. After closing the lid and opening it again, I can log in. Annoying. Here is my solution.

  1. remove anything from xorg-edgers
    1.1) sudo apt-get install ppa-purge
    1.2) sudo ppa-purge xorg-edgers
    1.3) suod apt-get remove nvidia-*

  2. install the latest properitary driver from NVIDIA (I am using 3.46.59
    2.1) http://www.nvidia.com/download/driverResults.aspx/83686/en-us
    2.2) run the install file
    2.3) sudo apt-get install nvidia-prime

now restart. This will result in a login screen which is fine. If you lock in, you might get a empty desktop and Unity does not start. So log in to a console and set up the xorg.conf

3.1) sudo stop lightdm
3.2) edit /etc/X11/xorg.conf and fill it with

=============================
Section “ServerLayout”
Identifier “layout”
Screen 0 “nvidia”
Inactive “intel”
EndSection

Section “Device”
Identifier “intel”
Driver “modesetting”
EndSection

Section “Screen”
Identifier “intel”
Device “intel”
EndSection

Section “Device”
Identifier “nvidia”
Driver “nvidia”
BusID “PCI:1:0:0”
EndSection

Section “Screen”
Identifier “nvidia”
Device “nvidia”
Option “UseDisplayDevice” “None”
EndSection

============================

3.3) sudo start lightdm

If you want to use cuda sdk

4.) get and install CUDA 7.0 from NVIDIA.
4.1.) run install file and select “DO NOT INSTALL DRIVER”

5.) Have fun

you have hybrid graphic card and you are disabling intel ? did you get any performance after theese settings better than nvdia-prime or bumbleblee ?

can you tell :

sudo apt-get install mesa-utils
lspci | egrep "VGA|3D|Display"
glxinfo | grep render
xrandr

Tesgane, that actually helped! Now I can run CUDA and I don’t get the black screen at login. What I can’t do now is use:

sudo prime-select nvidia

I keep getting this:

Info: the current alternatives in use are: ['mesa', None]
Error: the installed packages do not support PRIME
Error: nvidia mode can't be enabled

Hello everybody!

As many others users, I get a black screen when I try to switch on the nvidia card.
I am just a user, therefore I just give my feedback.

I use nvidia-prime and the nvidia drivers coming from the ppa xorg-edgers ppa.
I use also prime-indicator for quickly switch between the nvidia (GTX880M) and the intel card and my login manager is lightdm.

First comment, for me the black screen issue doesn’t comes from the driver but of nvidia-prime.

My first suggestion to solve the black screen. Using the the root privilege edit the file /sbin/prime-offload and just replace the first line #!/bin/sh by #!/bin/bash.

Now, you can use the command: prime-select nvidia (or intel) and reboot your laptop. Normally, now you can switch between the two cards but the quick switch of “prime-indicator” doesn’t work.

For the next step, I don’t have a real solution but just a workaround:
With the root privilege edit the files /usr/lib/primeindicator/igpuon and /usr/lib/primeindicator/dgpuon and just before “sync” insert this line:
service lightdm restart

So you get this for the file igpuon:
prime-select intel
service lightdm restart
sync

And you get this for the file dgpuon:
prime-select nvidia
service lightdm restart
sync

I hope that this feed-back will be helpful to other people.
++ Kirby

I summarize what works for me:

For a good starting point:
sudo apt-get install ppa-purge
sudo apt-get remove --purge nvidia-*
sudo ppa-purge ppa:xorg-edgers/ppa

If you don’t know which driver to use, I suggest to go to the NVIDIA website: http://www.nvidia.fr/Download/index.aspx?lang=en select your graphic card (and Linux) and push the search button.
For me, I have a GTX880M and I get the driver “Version: 346.72”.
Therefore I use the driver nvidia-346 coming from the ppa xorg-edgers

And now (of course replace the number 346 with the number you get from the NVIDIA website):
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-346 nvidia-346-uvm nvidia-settings nvidia-prime

About the black-screen issue:
Using the the root privilege edit the file /sbin/prime-offload:
sudo gedit /sbin/prime-offload

Just replace the first line #!/bin/sh by #!/bin/bash

If you want to use the prime-indicator widget:
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install prime-indicator

I use lightdm as login manager, and for me, prime-indicator doesn’t work properly. I have fix the issue with this workaround:

With the root privilege edit the files /usr/lib/primeindicator/igpuon and /usr/lib/primeindicator/dgpuon and just before “sync” insert this line: service lightdm restart

So you get this for the file igpuon:
prime-select intel
service lightdm restart
sync

And you get this for the file dgpuon:
prime-select nvidia
service lightdm restart
sync