nVidia on Ubuntu 14.04.1 64bit black(blank) login screen (not freeze)

Recently I installed STEAM on my Lenovo IdeaPad Y510p (core i7 + nVidia 750m) laptop running Ubuntu 14.04.1. I want to use nVidia for sessions when I play games and Intel for everything else. Therefore I installed nVidia drivers (tried several times, binnary from nVidia site and from Ubuntu repo but never from PPA).

Lightdm never manage to display login screen when nVidia is selected (using primus or nVidia prime indicator applet or nvidia-settings). Screen is black(blank), no mouse arrow and system does not freeze, I can hear drum start-up sound and I can switch to console by pressing ctrl+alt+f1 and logon successfully in terminal (I use this session to switch back to intel using terminal).

I checked brightness setup while using terminal, changed them both (acpi and intel) to max and it didn’t help (brightness is reflected terminal sesion but switching to lightdm with ctrl+altf7 or restart lightdm is the same black/blank). Connecting external TV on HDMI also didnt help (same “picture” is shown on both diplays: when on intel it’s ok and when on nVidia both is black/blank). in BIOS I have no options related to GPUs…

I’m under impression that issue is not with driver - but on lightdm side or x side - like they cannot pick the right connector to send picture to display… Both next commands works, but I can only see black display when switching to nvidia

sudo prime-switch nvidia
sudo prime-switch intel

Any help is appreciated! I already tried everything else from web but it dint helped My laptop never freezes and because of that I think the issue is not the same…

One remark: In the past I used to have proprietary drivers works perfectly in SLI mode (this laptop support secong nVidia in ultrabay). Then I pull out ultrabay grpahics card because I aimed for longer battery life. With empty ultabay system work ok using integrated GPU. Now I want to use discreete GPU (still with empty ultrabay - not in SLI mode).

can you post the contents of /var/log/Xorg.0.log to pastebin and link us? there’s a command called pastebinit which auto uploads the contents of a file to ubuntu’s pastebin website. so you could install it if it’s not installed already

sudo apt-get install pastebinit

then issue

pastebinit /var/log/Xorg.0.log

and also this

pastebinit /var/log/lightdm.log

I think that’s the name for lightdm’s log file or it may be in a sub-folder. Also note I think i recently ran into this issue but i didn’t have a laptop so i doubt it was the same issue. Laptop’s with both iGPU (intel) and an Nvidia gpu can be tricky. You said you set your system up according to all the guides out there for using this type of system? One last thing, have you tried editing your grub boot line to include something for screen brightness like the following? http://askubuntu.com/questions/409378/changing-brightness-at-startup

UPDATE: not sure what this does but i found it on the nvidia driver arch wiki: If you have installed an update of Nvidia and you screen stay black after launching Xorg. You have to use the rcutree.rcu_idle_gp_delay=1 kernel parameter.

I did, I read all available pages on web on this topic… This one I tried again today, just before I paste log files: http://xmodulo.com/install-configure-nvidia-optimus-driver-ubuntu.html
It means (at the moment) I’m not using nvidia binary from website but from Ubuntu repo (I’m almost sure same thing I experienced with binary from nvidia - that is what I have tried for the first time and it didn’t work in a same way).

Yes, I’m become quite an expert on brightness issue and ways to manage it. Funny thing, brightness level changed from terminal are remembered when i perform sudo service lightdm start - I only do not see picture - brightness is there!

This unfortunately makes no difference.

Here are requested pastebins:
/var/log/Xorg.0.log - http://paste.ubuntu.com/9079055/
/var/log/lightdm.log - http://paste.ubuntu.com/9079082/

I also pasted NVIDIA bug report log file output here:
http://paste.ubuntu.com/9079160/

I found this interesting remark The X server does not automatically enable displays attached to the non-NVIDIA graphics device in this configuration on this link http://us.download.nvidia.com/XFree86/Linux-x86/319.17/README/randr14.html which fit my guts feeling (it does seems my system didnt freeze - it only does not know correct way to send picture to laptop display… But I’m getting number of error when running xrandr (mostly cannot connect to display, even when I force it with DISPLAY:=0 xrandr. When run the same under intel, I got this response:

$ sudo DISPLAY:=0 xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
   1920x1080      59.9*+
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Frustrating part is that I still do not know how my laptop display is wired to GPUs. I’m just assuming it’s muxless design since I have no option to mess up with GPU in BIOS. But I might be wrong with that since this laptop have ultrabay where I can put another nvidia card and to have both discreete GPUs in SLI mode (intel in such scenario becomes “invisible” to system). Optimus or SLI - both works just fine under Windows…

Cmon NVIDIA guys, this is a gaming laptop! I just want to play few games on STEAM under Linux (not yet in SLI setup - just OPTIMUS)…

Help meeeeeeeeeee!!!

I confirm this bug! My nvidia driver version is 346, Geforce 860M GTX on Lenovo Y50. When I’ve installed them it was all fine, but then I choose to use “Intel (power saving mode)” option from Nvidia-settings and I can’t switch back to my Geforce because of the black screen!

My only way to get my laptop working again is typing this after going in textual mode with CTRL+ALT+F1:

sudo prime-switch intel

Same here. I had it working for about a week. now for the past week it has been broken. No way to get any nvidia driver working. Asus G771JM (GT860M) I have to remove all nvidia drivers and run on intel to get any graphical environment. tried open source 330, 340, 346, 349. all the same. prime bumblebee nothing works, by any recipe.

main goal is to play CS:GO. It was working fine until one of the security updates hit, then broken.

I’m seeing the same problem with Ubuntu 15.10 (kernel 4.2.0-11-generic), nvidia-355, and nvidia-prime.

If I prime-select intel, I can see lightdm fine.

When I prime-select nvidia, lightdm doesn’t show up. However lightdm is running; if I type the password blindly after I hear the lightdm drumming, I can log into my desktop and the nvidia drivers are working fine.

I don’t use the quiet or splash boot parameters, so I’m not at a black screen when I’m typing my password: I still see all of my boot text on the screen. Therefore, the problem doesn’t have anything to do with brightness - lightdm just isn’t rendering anything.

07:59:07 evil@clevo [~]> glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 670MX/PCIe/SSE2
OpenGL core profile version string: 4.4.0 NVIDIA 355.11
OpenGL core profile shading language version string: 4.40 NVIDIA via Cg compiler
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.0 NVIDIA 355.11
OpenGL shading language version string: 4.50 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 NVIDIA 355.11
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions: