Ubuntu 20.04 GUI failed with RTX3070 Laptop (Asus TUF Gaming A15) and NIVIDIA 460.39 driver

I am using the 2021 ASUS TUF Gaming A15 laptop, with AMD R7 5800H CPU and GeForce RTX 3070 Laptop GPU, the system I am using is Ubuntu 20.04.2 LTS.

After I installed the NVIDIA driver (460.39), I tried graphical installation and command-line installation, both installation methods end up in a black screen when reboot with an error message saying

usci_acpi USBC000:00: PPM init failed (-110)

I can get into the command-line interface with “CTRL+ATL+F2” at this point. And in the command-line interface, I can see that the driver is successfully installed, and I do have a proper output using command " nvidia-smi ".

I did some research on why the " usci_acpi " error happened and it looks like it is because the USB-C port on my laptop and has some compatibility problem.

Here are some things I tried to solve this error:

  1. Although NVIDIA official website says the only compatible driver for RTX 3070 laptio GPU is 460.39, I still tried my luck to install an earlier version of the NVIDIA driver 455.35. After installation, the reboot doesn’t have any problem but I get the error No device found when calling " nvidia-smi " in the terminal, which is expected.
  2. I tried to update the Ubuntu kernel from 5.8 to 5.10 and the most recent 5.11. In 5.10, the error remains, I still can’t get into the GUI, but the command-line interface works. In 5.11, the system goes to black screen directly after reboot, can’t even try to install the NVIDIA driver.
  3. I also tried the Ubuntu 18.04 LTS, the error remains.

Any idea how can I solve this " usci_acpi " problem? Any way to get around the USB-C port or I have to wait for the release of the newer nvidia driver or ubuntu kernel?

This rather sounds like you created an /etc/X11/xorg.conf, please delete it if that’s the case.
Otherwise, to have 20.04 support your AMD/Nvidia combo, you’ll have to update to the latest hwe
https://wiki.ubuntu.com/Kernel/LTSEnablementStack
so you get kernel 5.8 and then do asystem update to get the latest spplemetal packages.
If that doesn’t help, please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Hi! Thanks for the reply! I check the folder X11 and there isn’t any “xorg.conf” file. So I go with the second advice.

I followed the commands in the link provided, which seems like to have me downgrade to kernel 5.4. Now after all the commands executed and rebooted in kernel 5.4 using advanced reboot options. I ended up with a completely black screen with a blinking cursor. I ran the nvidia-bug-report.sh as suggested, and here is the resulting file.nvidia-bug-report.log.gz (411.2 KB)

Also, I tried to reboot in kernel 5.8, it got into the GUI and says nvidia-driver-460 is already installed. But when I ran nvidia-smi. It shows

NVIDIA-SMI has failed because it couldn’t communicate with NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Please boot into the 5.8 kernel and create a new nvidia-bug-report.log

Hi, here is the resulting file from kernel 5.8nvidia-bug-report.log.gz (112.8 KB)

Ok, now it gets tricky. The AMD gpu you have is brand new, only supported by kernel 5.10+ so you will have to install it manually:
You will need 4 packages
linux-headers-XX
linux-headers-XX-generic
linux-image-unsigned-XX-generic
linux-modules-XX-generic
from https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.10.14/
You will also have to download all firmware files that begin with “renoir” from here
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/amdgpu
and put them into
/lib/firmware/amdgpu

My two cents…

This is just a suggestion from a random that has nothing to do with nVidia professional.

Im going to assume that this isnt a dual boot, vm, docker, gpu pass through or some other.

Im going to assume this is a native metal full install.

1. Use kDE Neon. Download kDE neon. Check and verify the ISO. Image the ISO using ETCHER only.

Image the USB on a freskly formated USB. USB <4Gig. Ext2/Mbr then Fat32/MBR.

If < 4G use GPT and NTFs instead of fat32.

Note:!!! Keep the system Air Gapped.

NO INTERNET CONNECTION

2. Before install. default the BIOS to its lowest power default default. Save settings reboot back into the bios.

Now flash the Bios THREE times in a row with the Bios update that came out Jan 22. on a prepped USB.

3. Now reload windows. You can get an ISO from microsoft it will auto validate.

But you shouldnt need to go onto internet.

4. Disable secureboot from inside a running Windows installation.

* Disabling Secure Boot | Microsoft Docs.

5. Now disable. [ secureboot ] [ csm ] [ fastboot ] csm= compatability support module.

6. Install kDE- Neon. LVM system wide guided install. DO NOT update or install 3rd party drivers and codecs.

7. reboot. if you have a GUI Great! if not too bad. no worry

8. Open terminal or access virtual terminal with [ctl] [atl] [f2].

Login in and type [ sudo service sddm stop && sudo telinit 3 && init 3 ] Yes. overkill. I dont care.

9.a You most likely have to [ctl] [atl] [f2] and login again. Now create root account password. [ sudo su ]

Follow prompts. write it down.

9b.# ENABLE i386 / 32Bit SUPPORT.

dpkg --add-architecture i386

10. Make Dir. and Config.

Arch Linux # Location

sudo mkdir /etc/X11/xorg.conf.d &&

DE-k_Neon # Location

sudo mkdir /usr/share/X11/xorg.conf.d

Z note:!!! use [ lspci | grep VGA ] to find your bus ID and #uncomment.

example: 01:00.0 VGA compatible controller: nVidia

In terminal. Add everything below ____________ and above the bottom of conf.

sudo nano /usr/share/X11/xorg.conf.d/10-nvidia.conf


* " /etc/X11/xorg.conf.d/20-nvidia.conf

Section “Device”

* "

Identifier “Nvidia Card”

* "

Driver “nvidia”

* "

VendorName “NVIDIA Corporation”

* "

BoardName “GeForce GTX 1050 Ti”

* "

BusID “PCI:1:0:0” # [ see Znote above!!! ]

* "

Option “NoLogo” “1”

* "

Option “ConnectedMonitor” “DFP”

* "

Option “RegistryDwords” “EnableBrightnessControl=1”

* "

EndSection


[ctl] to save and exit.

11.

sudo mkdir /usr/lib/sddm/sddm.conf.d

Make the directory but investigate the links later. font dpi.

SDDM - ArchWiki

SDDM - ArchWiki

12. PREPARE THE SYSTEM:

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo apt update && sudo apt full-upgrade -y "

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo apt update && sudo apt --fix-missing install "

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo apt update && sudo apt --fix-broken install "

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo apt update && sudo dpkg --configure -a "

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo apt update && sudo apt -f install "

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo apt update && sudo apt install -f "

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo apt update && sudo apt autoremove "

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo apt update && sudo apt autoclean "

Update-Upgrade-Find-Fix-Remove-Clean

* " sudo update-grub && sudo update-initramfs -c -k all "

12.

Append resolution as appropriate for your Hardware.

use x24 or x 30 only.

sudo nano /etc/default/grub
#_________________________

GRUB_DEFAULT=_

GRUB_TIMEOUT_STYLE=menu

GRUB_TIMEOUT=1

GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian

GRUB_CMDLINE_LINUX_DEFAULT=“amdgpu.modeset=0 nouveau.modeset=0 nvidia-drm.modeset=1 iommu=memaper noplymouth nosplash nogpumanager”

GRUB_CMDLINE_LINUX=""

GRUB_TERMINAL=console

GRUB_GFXMODE=1920x1080x30,auto

GRUB_GFXPAYLOAD_LINUX=keep

#___________________________

Exit: nano / grub.conf:

* " [ ctl ] [ x ] " to save

#_________________________

BLACKLIST

modprobe -r nouveau

nano /etc/modprobe.d/blacklist.conf

13. Blacklist the nouveau driver by appending the .conf with:

blacklist nouveau

14. Run the commands below.

update-initramfs -c -k all

15. Open the blacklist.conf:

nano /etc/modprobe.d/blacklist.conf

16. Add the lines below to the BOTTOM of the blacklist.conf.

#_________________________

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

#____________________________

17. Open the blacklist-nouveau.conf:

nano /etc/modprobe.d/blacklist-nouveau.conf

18. Add the lines below to the BOTTOM of the blacklist-nouveau.conf.

#_________________________________________

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

#_____________________________________________

19. Now run the following:

echo 'blacklist amdgpu | sudo tee -a /etc/modprobe.d/blacklist.conf &&
echo ‘blacklist amd76x_edac’ | sudo tee -a /etc/modprobe.d/blacklist.conf &&
echo ‘blacklist vga16fb’ | sudo tee -a /etc/modprobe.d/blacklist.conf &&
echo ‘blacklist rivafb’ | sudo tee -a /etc/modprobe.d/blacklist.conf &&
echo ‘blacklist rivatv’ | sudo tee -a /etc/modprobe.d/blacklist.conf &&
echo ‘blacklist nvidiafb’ | sudo tee -a /etc/modprobe.d/blacklist.conf &&
echo ‘blacklist nouveau’ | sudo tee -a /etc/modprobe.d/blacklist.conf &&
echo “blacklist nouveau” | sudo tee /etc/modprobe.d/disable-nouveau.conf &&
echo “options nouveau modeset=0” | sudo tee -a /etc/modprobe.d/disable-nouveau.conf &&
echo “blacklist nouveau” | sudo tee /etc/modprobe.d/blacklist-nouveau.conf &&
echo “options nouveau modeset=0” | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf &&

20. Now disable the Nouveau Kernel Modeset this way :

sudo echo options nouveau modeset=0 | # tee -a /etc/modprobe.d/nouveau-kms.conf &&
sudo update-initramfs -u "

21.The Purge. I run 1 command at at time.

apt remove --purgei965-va-driver &&
apt remove --purgeintel-media-va-driver &&
apt remove --purgeintel-media-va-driver-non-free &&
apt remove --purge xserver-xorg-video-all &&
apt remove --purge xserver-xorg-video-amdgpu &&
apt remove --purge xserver-xorg-video-ati &&
apt remove --purge xserver-xorg-video-dummy &&
apt remove --purge xserver-xorg-video-fbdev &&
apt remove --purge xserver-xorg-video-intel &&
apt remove --purge xserver-xorg-video-nouveau &&
apt remove --purge xserver-xorg-video-qxl &&
apt remove --purge xserver-xorg-video-radeon &&

Leave vesa for now.

apt remove --purge xserver-xorg-video-vmware &&
apt remove --purge xserver-xorg-video-intel-arbiter &&
apt remove --purge xserver-xorg-video-intel-native-modesetting &&

. Purge_Mesa3d X11 must still be KILLed.This is critica !!!

apt remove --purge mesa-va-drivers mesa-va-drivers:i386 mesa-vdpau-drivers

31. DO NOT INSTALL LM-SENSORS ON A LAPTOP ESPECIALLY AN ASUS LAPTOP!!!

apt install --install-recommends build-essential extra-cmake-modules pciutils fwupd &&
apt install --install-recommends ubuntu-minimal ubuntu-standard &&
apt install --install-recommends python3-all python3-all-dev &&
apt install --install-recommends ubuntu-drivers-common &&
apt install --install-recommends curl &&
apt install --install-recommends wget &&
apt install --install-recommends kubuntu-restricted-addons &&
apt install --install-recommends kubuntu-restricted-extras &&
apt install --install-recommends kubuntu-driver-manager &&
apt install --install-recommends libsdl2-2.0-0 &&
apt install --install-recommends libsdl2-gfx-1.0-0 &&
apt install --install-recommends libsdl2-image-2.0-0 &&
apt install --install-recommends libsdl2-mixer-2.0-0 &&
apt install --install-recommends libsdl2-net-2.0-0 &&
apt install --install-recommends libsdl2-ttf-2.0-0 &&
apt install --install-recommends libsdl-kitchensink-dev &&
apt install --install-recommends libsdl-kitchensink0 &&
apt install --install-recommends python-sdl2 &&
apt install --install-recommends python3-sdl2 &&

Add Repository.

sudo add-apt-repository ppa:graphics-drivers/ppa &&
sudo apt-get update &&

install order example.

linux-headers-5.7.0-xxxxxx_all.deb

linux-headers-5.7.0-xxx-generic(/lowlatency)_xxx_amd64.deb

linux-modules-5.7.0-xxx-generic(/lowlatency)_xxx_amd64.deb

linux-image-xxx-5.7.0-xxx-generic(/lowlatency)_xxx_amd64.deb

$ Ubuntu mainline kernel 5.10.14. Youll need this for support.

Run in terminal/

cd /tmp/

wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/amd64/linux-headers-5.10.14-051014-generic_5.10.14-051014.202102071532_amd64.deb

wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/amd64/linux-headers-5.10.14-051014_5.10.14-051014.202102071532_all.deb

wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/amd64/linux-image-unsigned-5.10.14-051014-generic_5.10.14-051014.202102071532_amd64.deb

wget -c https://kernel.ubuntu.com/~kernel-ppa/mainline/md64/linux-modules-5.10.14-051014-generic_5.10.14-051014.202102071532_amd64.deb

update-initramfs -c -k all && update-grub && sudo shutdown

Once installed, restart your computer an INSTALL NVIDIA!!!

#############################
################################

If uninstalling then follow but other wise move on to install nvidia driver.

Uninstall Linux Kernel

Restart your machine and select boot with the previous kernel

in boot menu ‘Grub2 → Advanced Option for Ubuntu’.

Then run command to remove Linux Kernel

sudo dpkg --purge linux-image-unsigned-

#####################################
#####################################

run pci id update first youll need a newer library;

but run it any way and firmware update lvfs then install nvidia.

After reboot. KILL X SERVER!!!

update-initramfs -c -k all && update-grub && apt update && sudo apt full-upgrade -y

nVidia 460 Graphics Driver

apt install --reinstall --install-recommends xserver-xorg-core libc6 nvidia-dkms-460 nvidia-kernel-source-460 nvidia-kernel-common-460 libnvidia-compute-460 libnvidia-compute-460:i386

nVidia 460 Graphics Driver

apt install --reinstall --install-recommends libnvidia-decode-460 libnvidia-decode-460:i386 libnvidia-encode-460 libnvidia-encode-460:i386

nVidia 460 Graphics Driver

apt install --reinstall --install-recommends libnvidia-ifr1-460 libnvidia-ifr1-460:i386 libnvidia-fbc1-460 libnvidia-fbc1-460:i386

nVidia 460 Graphics Driver

apt install --reinstall --install-recommends libnvidia-gl-460 libnvidia-gl-460:i386 libnvidia-cfg1-460 libnvidia-extra-460

nVidia 460 Graphics Driver
apt install --reinstall --install-recommends xserver-xorg-video-nvidia-460 nvidia-prime nvidia-settings nvidia-utils-460 nvidia-compute-utils-460 nvidia-driver-460

nVidia 460 Graphics Driver
update-grub && update-initramfs -u

###############################
Im so late for work. That should give you an idea

Here’s the complete procedure to get your notebook running:
https://forums.developer.nvidia.com/t/ubuntu-mate-20-04-with-rtx-3070-on-ryzen-5900-black-screen-after-boot/167681/30?u=generix

Thank you!