Ubuntu 20.04 with Kernel 5.13.0-30-generic doesn't recognize RTX 3080 ti Laptop GPU

I have a new MSI RAIDER GE66 gaming laptop which has a RTX3080ti Laptop GPU. I want to use that laptop with Ubuntu 20.04. I tried to download nvidia driver but all the time I have problem with nvidia-smi or black screen issue. You can see some outputs below. I have disabled Fast and secure boot. Does anyone know the solution?

sudo lshw -C display output

  *-display UNCLAIMED       
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: iomemory:600-5ff iomemory:640-63f memory:83000000-83ffffff memory:6000000000-63ffffffff memory:6400000000-6401ffffff ioport:5000(size=128) memory:84000000-8407ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 0c
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: iomemory:640-63f iomemory:400-3ff memory:642c000000-642cffffff memory:4000000000-400fffffff ioport:6000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff


NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make 
sure that the latest NVIDIA driver is installed and running.

ubuntu-drivers devices

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00002420sv00001462sd00001320bc03sc00i00
vendor   : NVIDIA Corporation
driver   : nvidia-driver-510 - third-party non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

sudo lspci output

00:00.0 Host bridge: Intel Corporation Device 4641 (rev 02)
00:01.0 PCI bridge: Intel Corporation Device 460d (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Device 46a6 (rev 0c)
00:04.0 Signal processing controller: Intel Corporation Device 461d (rev 02)
00:06.0 PCI bridge: Intel Corporation Device 464d (rev 02)
00:07.0 PCI bridge: Intel Corporation Device 466e (rev 02)
00:08.0 System peripheral: Intel Corporation Device 464f (rev 02)
00:0d.0 USB controller: Intel Corporation Device 461e (rev 02)
00:0d.2 USB controller: Intel Corporation Device 463e (rev 02)
00:14.0 USB controller: Intel Corporation Device 51ed (rev 01)
00:14.2 RAM memory: Intel Corporation Device 51ef (rev 01)
00:14.3 Network controller: Intel Corporation Device 51f0 (rev 01)
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 51e8 (rev 01)
00:16.0 Communication controller: Intel Corporation Device 51e0 (rev 01)
00:1c.0 PCI bridge: Intel Corporation Device 51b8 (rev 01)
00:1c.4 PCI bridge: Intel Corporation Device 51bc (rev 01)
00:1c.7 PCI bridge: Intel Corporation Device 51bf (rev 01)
00:1f.0 ISA bridge: Intel Corporation Device 5182 (rev 01)
00:1f.3 Multimedia audio controller: Intel Corporation Device 51c8 (rev 01)
00:1f.4 SMBus: Intel Corporation Device 51a3 (rev 01)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 51a4 (rev 01)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 2420 (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 2288 (rev a1)
02:00.0 Non-Volatile memory controller: Micron Technology Inc Device 5407
2e:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5261 (rev 01)
2f:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. Device 3000 (rev 06)

dkms status

backport-iwlwifi, 8324: added
nvidia, 510.54, 5.13.0-30-generic, x86_64: installed

dpkg -l nvidia

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                             Version                     Architecture Description
un  libgldispatch0-nvidia            <none>                      <none>       (no description available)
ii  libnvidia-cfg1-510:amd64         510.54-0ubuntu0.20.04.1     amd64        NVIDIA binary OpenGL/GLX configuration library
un  libnvidia-cfg1-any               <none>                      <none>       (no description available)
un  libnvidia-common                 <none>                      <none>       (no description available)
ii  libnvidia-common-510             510.54-0ubuntu0.20.04.1     all          Shared files used by the NVIDIA libraries
un  libnvidia-compute                <none>                      <none>       (no description available)
rc  libnvidia-compute-470:amd64      470.103.01-0ubuntu0.20.04.1 amd64        NVIDIA libcompute package
ii  libnvidia-compute-510:amd64      510.54-0ubuntu0.20.04.1     amd64        NVIDIA libcompute package
ii  libnvidia-compute-510:i386       510.54-0ubuntu0.20.04.1     i386         NVIDIA libcompute package
un  libnvidia-decode                 <none>                      <none>       (no description available)
ii  libnvidia-decode-510:amd64       510.54-0ubuntu0.20.04.1     amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-510:i386        510.54-0ubuntu0.20.04.1     i386         NVIDIA Video Decoding runtime libraries
un  libnvidia-encode                 <none>                      <none>       (no description available)
ii  libnvidia-encode-510:amd64       510.54-0ubuntu0.20.04.1     amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-510:i386        510.54-0ubuntu0.20.04.1     i386         NVENC Video Encoding runtime library
un  libnvidia-extra                  <none>                      <none>       (no description available)
ii  libnvidia-extra-510:amd64        510.54-0ubuntu0.20.04.1     amd64        Extra libraries for the NVIDIA driver
un  libnvidia-fbc1                   <none>                      <none>       (no description available)
ii  libnvidia-fbc1-510:amd64         510.54-0ubuntu0.20.04.1     amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-510:i386          510.54-0ubuntu0.20.04.1     i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
un  libnvidia-gl                     <none>                      <none>       (no description available)
ii  libnvidia-gl-510:amd64           510.54-0ubuntu0.20.04.1     amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-510:i386            510.54-0ubuntu0.20.04.1     i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
un  libnvidia-ml1                    <none>                      <none>       (no description available)
un  nvidia-384                       <none>                      <none>       (no description available)
un  nvidia-390                       <none>                      <none>       (no description available)
un  nvidia-common                    <none>                      <none>       (no description available)
un  nvidia-compute-utils             <none>                      <none>       (no description available)
ii  nvidia-compute-utils-510         510.54-0ubuntu0.20.04.1     amd64        NVIDIA compute utilities
ii  nvidia-dkms-510                  510.54-0ubuntu0.20.04.1     amd64        NVIDIA DKMS package
un  nvidia-dkms-kernel               <none>                      <none>       (no description available)
ii  nvidia-driver-510                510.54-0ubuntu0.20.04.1     amd64        NVIDIA driver metapackage
un  nvidia-driver-binary             <none>                      <none>       (no description available)
un  nvidia-kernel-common             <none>                      <none>       (no description available)
ii  nvidia-kernel-common-510         510.54-0ubuntu0.20.04.1     amd64        Shared files used with the kernel module
un  nvidia-kernel-source             <none>                      <none>       (no description available)
ii  nvidia-kernel-source-510         510.54-0ubuntu0.20.04.1     amd64        NVIDIA kernel source package
un  nvidia-legacy-304xx-vdpau-driver <none>                      <none>       (no description available)
un  nvidia-legacy-340xx-vdpau-driver <none>                      <none>       (no description available)
un  nvidia-libopencl1-dev            <none>                      <none>       (no description available)
un  nvidia-opencl-icd                <none>                      <none>       (no description available)
un  nvidia-persistenced              <none>                      <none>       (no description available)
ii  nvidia-prime                     0.8.16~            all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                  470.57.01-0ubuntu0.20.04.3  amd64        Tool for configuring the NVIDIA graphics driver
un  nvidia-settings-binary           <none>                      <none>       (no description available)
un  nvidia-smi                       <none>                      <none>       (no description available)
un  nvidia-utils                     <none>                      <none>       (no description available)
ii  nvidia-utils-510                 510.54-0ubuntu0.20.04.1     amd64        NVIDIA driver support binaries
un  nvidia-vdpau-driver              <none>                      <none>       (no description available)
ii  xserver-xorg-video-nvidia-510    510.54-0ubuntu0.20.04.1     amd64        NVIDIA binary Xorg driver

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (165.6 KB)
First of all thanks for your help. Here is the attachment

The real problem is your 12th gen intel igpu, the 20.04 kernel is too old to support it.
Unfortunately, in order to fix it, you tried to install all kinds of nvidia drivers over another, so I don’t know which state that has. Please remove the/any nvidia driver using the Software&Updates application, run the runfile installer with --uninstall option to get a clean system, then upgrade the kernel using the liquorix ppa:
Afterwards, install the latest driver using Software&Updates
(or install ubuntu 21.10/22.04beta)

1 Like

first, I installed ubuntu 21.10 and I can get output. Now I have another problem with CUDA when I am trying to install CUDA 11.2, an below error occurs

 Failed to verify gcc version. See log at /var/log/cuda-installer.log for details.

When I open that file, input as below

[INFO]: Driver installation detected by command: apt list --installed | grep -e nvidia-driver-[0-9][0-9][0-9] -e nvidia-[0-9][0-9][0-9]
[INFO]: Cleaning up window
[INFO]: Complete
[INFO]: Checking compiler version...
[INFO]: gcc location: /usr/bin/gcc

[INFO]: gcc version: gcc version 11.2.0 (Ubuntu 11.2.0-7ubuntu2) 

[ERROR]: unsupported compiler version: 11.2.0. Use --override to override this check.

If you have any idea about that, could you share, please?

Are you installing cuda using runfile or .deb packages?

Yes, I tried to install CUDA using runfile

Cuda 11.2 supports gcc 9 maximum, so you’ll have to install the package gcc-9 to be able to compile code with it.
NB: you need to learn how to use deban’s update-alternatives to switch between versions, otherwise it might happen that a nvidia driver update fails in the future.
When installing from runfile, it’s important to skip driver installation when asked, otherwise the already installed driver will break.

1 Like

Thank you so much for your help. It worked but unfortunately TensorFlow throw and an error while testing GPU.
kernel version 510.47.3 does not match DSO version 470.103.1 -- cannot find working devices in this configuration

You still have leftovers from one of your driver installs, likely libcuda.