RTX 2080 not read by ubuntu 18.04.1

Hi Team,

My configuration is:

Ubuntu 18.04.1
NVIDIA graphics card: RTX 2080

Problem is that the system doesn’t recognizes the drivers.
When i run

  1. Ubuntu-drivers devices – It return nothing
  2. lspci | grep -i NVIDIA – 01:00.0 VGA compatible controller: NVIDIA Corporation Device 1e87 (rev a1)

Please help out. Which Ubuntu version to be installed and how

For the RTX, you need a version 410 driver which not yet in the ubuntu driver ppa due to being beta. So you can either download the .run installer and use that (not recommended) or simply download the cuda 10 .deb for ubuntu 18.04 and install that, it comes with the 410 driver in .deb format.
https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1804

Hi Team,

I downloaded 410 driver and installed and then cuda and cudnn also as per the requirement i.e 10 .
But even after that when i run nvidia-smi the drivers seem to be off.

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

I’m having the same problem, actually with a KFA2 RTX2080 EX under Ubuntu 18.04, using the .deb files from Nvidia:

# modinfo nv*
filename:       /lib/modules/4.15.0-43-generic/kernel/drivers/video/nvidia.ko
alias:          char-major-195-*
version:        415.25
...
name:           nvidia
vermagic:       4.15.0-43-generic SMP mod_unload
...

# lspci | grep -i NVIDIA
01:00.0 VGA compatible controller: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP102 HDMI Audio Controller (rev a1)
...
07:00.0 VGA compatible controller: NVIDIA Corporation Device 1e82 (rev a1)
07:00.1 Audio device: NVIDIA Corporation Device 10f8 (rev a1)
07:00.2 USB controller: NVIDIA Corporation Device 1ad8 (rev a1)
07:00.3 Serial bus controller [0c80]: NVIDIA Corporation Device 1ad9 (rev a1)

The box also contains some other Nvidia cards that work just fine (like the 1080 Ti shown above).

lspci -d “10de:*” -v -xxx gives:

...
07:00.0 VGA compatible controller: NVIDIA Corporation Device 1e82 (rev a1) (prog-if 00 [VGA controller])
        Subsystem: NVIDIA Corporation Device 12b0
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at d4000000 (32-bit, non-prefetchable) 
        Memory at 2f50000000 (64-bit, prefetchable) 
        Memory at 2f60000000 (64-bit, prefetchable) 
        I/O ports at 8000 
        [virtual] Expansion ROM at d5000000 [disabled] 
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [250] Latency Tolerance Reporting
        Capabilities: [258] L1 PM Substates
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [420] Advanced Error Reporting
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Capabilities: [900] #00
        Capabilities: [bb0] #15
        Kernel driver in use: nvidia
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

The card is recognized just fine under Windows 10. And ideas?

Thanks and regards, S

.

Kernel driver in use: nvidia

The device is detected, the driver is loaded, what doesn’t work?

Yes, the driver is running, and it sees all other cards (1080 Ti, 1080, 1070, Titan) fine, but the 2080 is only seen as “Device 1e82” (or “Device 1ad8” for the audio part).

$ nvidia-smi --query | fgrep 'Product Name'
    Product Name                    : GeForce GTX 1080 Ti
    Product Name                    : GeForce GTX 1080 Ti
    Product Name                    : GeForce GTX 1080
    Product Name                    : GeForce GTX 1070
    Product Name                    : GeForce GTX TITAN

These are all correct, but the 2080 is missing… And, as I said, I did not just use the ppa from the standard distribution. I downloaded the Nvidia .deb file (yes, they seem to disitrubute .deb’s…) from https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1804 and after it did not work, I also tried the run file from https://www.geforce.com/drivers/results/141448. Also, hashcat is not using the card at all. According to https://devicehunt.com/view/type/pci/vendor/10DE/device/1E82, device 1e82 should be mapped to RTX 2080, but the driver does not seem to do this. Maybe it only maps 1e87, which also seems to be rtx 2080 (https://download.nvidia.com/XFree86/Linux-x86_64/410.57/README/supportedchips.html)?
nvidia-bug-report.log.gz (2.27 MB)

That only

NVIDIA Corporation Device 1e82

is displayed doesn’t matter, this comes from the pci id db which isn’t updated with the RTX name yet. nvidia-smi should display it, though.
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

done in post above… what I also see in it:

journalctl -b -0:
Dec 22 21:27:35 xyz ureadahead[393]: ureadahead:/lib/systemd/system/nvidia-persistenced.service: No such file or directory
Dec 22 21:27:35 xyz ureadahead[393]: ureadahead:/lib/modules/4.15.0-43-generic/updates/dkms/nvidia-uvm.ko: No such file or directory
Dec 22 21:27:36 xyz kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 240
Dec 22 21:27:36 xyz kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  415.25  Wed Dec 12 10:22:08 CST 2018 (using threaded interrupts)
Dec 22 21:27:36 xyz kernel: nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  415.25  Wed Dec 12 10:02:42 CST 2018
Dec 22 21:27:36 xyz kernel: [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
Dec 22 21:27:36 xyz kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
Dec 22 21:27:36 xyz kernel: [drm] [nvidia-drm] [GPU ID 0x00000200] Loading driver
Dec 22 21:27:36 xyz kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:02:00.0 on minor 2
Dec 22 21:27:36 xyz kernel: [drm] [nvidia-drm] [GPU ID 0x00000400] Loading driver
Dec 22 21:27:36 xyz kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:04:00.0 on minor 3
Dec 22 21:27:36 xyz kernel: [drm] [nvidia-drm] [GPU ID 0x00000500] Loading driver
Dec 22 21:27:36 xyz kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:05:00.0 on minor 4
Dec 22 21:27:36 xyz kernel: [drm] [nvidia-drm] [GPU ID 0x00000600] Loading driver
Dec 22 21:27:36 xyz kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:06:00.0 on minor 5
Dec 22 21:27:36 xyz kernel: [drm] [nvidia-drm] [GPU ID 0x00000700] Loading driver
Dec 22 21:27:36 xyz kernel: [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:07:00.0 on minor 6
Dec 23 08:46:33 xyz kernel: NVRM: GPU at PCI:0000:07:00: GPU-dbfdc874-a5f0-876f-50c4-baf8f5d8879e
Dec 23 08:46:33 xyz kernel: NVRM: GPU Board Serial Number: 
Dec 23 08:46:33 xyz kernel: NVRM: Xid (PCI:0000:07:00): 61, 0c06(2f88) 00000000 00000000
Dec 23 08:46:57 xyz kernel: NVRM: RmInitAdapter failed! (0x53:0x65:1914)
Dec 23 08:46:57 xyz kernel: NVRM: rm_init_adapter failed for device bearing minor number 5

Yes, that’s the reason

Dec 23 08:46:33 xyz kernel: NVRM: GPU at PCI:0000:07:00: GPU-dbfdc874-a5f0-876f-50c4-baf8f5d8879e
Dec 23 08:46:33 xyz kernel: NVRM: GPU Board Serial Number: 
Dec 23 08:46:33 xyz kernel: NVRM: Xid (PCI:0000:07:00): 61, 0c06(2f88) 00000000 00000000
Dec 23 08:46:57 xyz kernel: NVRM: RmInitAdapter failed! (0x53:0x65:1914)
Dec 23 08:46:57 xyz kernel: NVRM: rm_init_adapter failed for device bearing minor number 5

Looks like a driver bug, the RTX can’t be initialized. Things to do to narrow it down:

  • run the nvidia persistenced on startup (should be done in any case since you’ve no X running)
  • downgrade the driver to 410.x
  • check with the RTX as only card in the system, also in another slot
    You should also mail the log with a description of the problem to linux-bugs[at]nvidia.com

Hi having similar issues here.

Running dual RTX 2080 on Ubuntu 18.04 and having driver issues, cannot change resolution from 800x600, X Server won’t load (just brings up empty box or does nothing).

Have installed cuda 10-1 local deb file, bug report attached.

I’m dual boot with windows 10. Please advise, thanks.

The driver that comes bundled with cuda 10.1 seems to be broken, see:
https://devtalk.nvidia.com/default/topic/1048019/linux/black-screen-after-install-cuda-10-1-on-ubuntu-18-04/

Hi @greg.chance,

I also faced similar issue while installing cuda 10 along with ubuntu 18.04.
Because NVIDIA-drivers are yet not available with ubuntu-18.04.

Check compatible NVIDIA-driver install that with nvidia-toolkit and then reboot your system. It worked for me.

Hey @akanshaayt
I’ve tried installing the 418.43 driver separately using

sudo apt-get purge nvidia*
sudo bash NVIDIA-Linux-x86_64-418.43.run

“…pre-installation script failed…” - OK
“Register kernel with DKMS” - no(?)
“Install without signing” - no (yes fails)
“This certificate must be must be added to a key database…” - OK
"The signed key module failed to load because the kernel does not trust any key…“install the the signed key anyway?” - OK
“Install 32bit compatability?” - OK
“Install nvidia-config utility?” - Yes
“Successfully updated…”
“ERROR: the kernel module failed to load… not signed by a key…”

reboot
nvidia-smi

“…failed to communicate with driver…”

Have tried with 418.30 driver with same results - which did you use?

Hi @greg.chance,

My linux nvidia driver is 410.48 try with this once.

Do you mean 410.78 - I don’t see a 410.48?
Also people seem to be saying that you can install the cuda 10-1 without drivers, is there a command line to trigger this as there is nothing on the GUI installer???

If you’re using the cuda .deb, you can install cuda without the driver using
sudo apt-get install cuda-toolkit-10-1
You can’t use the 410 driver with cuda 10.1 anyway since the bundled driver (418.39) is always the minimum version that works. So you can only upgrade to 418.39.
Do you have secure boot enabled? If so, disable it in bios so you can install and use an unsigned driver.

Secure boot enabled but it installed ok. It just asked for an additional password.
I tried switching off secure boot and now the PC won’t post - d’oh
Is this an issue with windows 10 dual boot?

Might be a dual boot issue.
If you already created and enrolled a signing key on Ubuntu install, you can try to use it to sign the modules with the .run installer.
The Ubuntu keys should be

/var/lib/shim-signed/mok/MOK.priv
/var/lib/shim-signed/mok/MOK.der

https://wiki.ubuntu.com/UEFI/SecureBoot/Signing
You should be able to use those according to
http://us.download.nvidia.com/XFree86/Linux-x86/361.45.11/README/installdriver.html#modulesigning

sh ./NVIDIA-Linux-<version>.run -s \
--module-signing-secret-key=/var/lib/shim-signed/mok/MOK.priv \
--module-signing-public-key=/var/lib/shim-signed/mok/MOK.der

I did not try this, also don’t know if this works with the --dkms option. Use -A option to get advanced options displayed.