Ubuntu MATE 20.04 with RTX 3070 on Ryzen 5900 - black screen after boot

Attaching the nvidia bug report also. Not sure if it will help
nvidia-bug-report.log.gz (95.3 KB)

Here is also the output of the commands:

$ dpkg -l |grep nvidia-prime
ii  nvidia-prime                                0.8.15.3~0.20.04.1                    all          Tools to enable NVIDIA's Prime
$ dpkg -l |grep ubuntu-drivers-common
ii  ubuntu-drivers-common                       1:0.8.6.5~0.20.04.1                   amd64        Detect and install additional Ubuntu driver packages

If I run the install again it finishes without errors, but after restart the system shows that the driver is not installed and it uses “AMD RENOIR (DRM 3.40.0, 5.10.14-051014-generic, LLVM 11.0.1)”

Here is also new kernel log:
kernel_4.txt (119.9 KB)

Oh joy, seems the Ubuntu kernel packages have a bug keeping mudules from building. Please check if this workaround helps:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1906131/comments/8
Of course, the path has to be correctly set to the 5.10.14 kernel sources.

1 Like

@generix
OK, looks like that worked. The OS says that now it uses “GeForce RTX 3070 Laptop GPU/PCIe/SSE2”

Here is the output of the above commands:

$ sudo dpkg -l |grep nvidia-prime
ii  nvidia-prime                                0.8.15.3~0.20.04.1                    all          Tools to enable NVIDIA's Prime
$ sudo dpkg -l |grep ubuntu-drivers-common
ii  ubuntu-drivers-common                       1:0.8.6.5~0.20.04.1                   amd64        Detect and install additional Ubuntu driver packages

Versions are correct, looks like everything is fine now.

OK, I have to give you a huge kudos!!! Thanks you very much for your time, you were amazing!!!
To sum it up for all with the same issue:

  1. Get the latest Kernel. Currently it is 5.10.14

  2. Download all files from this URL
    https://people.freedesktop.org/~agd5f/radeon_ucode/gs/
    and copy them to
    /lib/firmware/amdgpu
    Make sure they all have the same owner and permissions like the other files in the same folder.

  3. run
    sudo wget https://raw.githubusercontent.com/torvalds/linux/master/scripts/module.lds.S -O /usr/src/linux-headers-5.10.2-051002-generic/scripts/module.lds
    and then
    sudo sed -i '$ d' /usr/src/linux-headers-5.10.2-051002-generic/scripts/module.lds

Make sure you put the correct kernel version instead of "5.10.2-051002"

  1. run
    sudo update-initramfs -u

  2. Add the drivers repo
    sudo add-apt-repository ppa:graphics-drivers/ppa

  3. Reboot and install the NVIDIA driver from “System → Preferences → Hardware → Additional Drivers”

  4. Buy a big beer to @generix :-)

@sano1982 That should work for you too.

Thanks

3 Likes

Please change the thread title to include Ryzen 5900 and mark your last post as solution so other users have an easier time finding it.

Hm, I cant find a way to change the thread title. It looks like I cant even edit my older posts, just the recent ones.

@predte4a @generix thanks to you both a lot. You saved my month.
It works with 5.10.15 like a charm.

Please subscribe:
https://bugzilla.kernel.org/show_bug.cgi?id=211729
Likely, they’re telling to go over to freedesktop.org but their gitlab is a complete mess.

2 Likes

That works for me:
ASUS ROG Strix Scare G733QS.311.
GPU: RTX 3080 Laptop 16gb
CPU: amd Ryzen7 5800H

Kernel 5.11.0-051100

With previous kernel versions (5.10.15, 5.10.16) I had a problem with Asus built-in keyboard (ASUS N-KEY) - it didn’t work properly and sometimes it was causing system crash.

With kernel 5.11.0 I only obtained another problem - my computer is not able to turn off so I need to help him by power button. But keyboard is working properly (at least that properly as it is able on linux). So for this moment I have to choose which from above’s problems is less painful (i prefer working keyboard ;) ) and live with hope that shutdown will be fixed in next releases.

The most important conclusion - Nvidia GPU works fine!

@predte4a and @generix
Thank you so much for this solution. I have same problem with ASUS gaming A15 TUF FA506QR, Ryzen 7 5800H, RTX 3070 that I bought three weeks ago. I am following your solution, but I have not executed the point 3:

as I am a bit confused as to where to put the kernel version that am using “5.10.14-051014”. Should reflect in the both link that I am downloading from and folder to save output to?
I read that the output folder should be: “/usr/src/linux-headers-5.10.14-051014-generic” for my own kernel. Please see attached result of kernel.txt.kernel.txt (138.3 KB)

You’ll just have to replace " 5.10.2-051002" with “5.10.14-051014” in both commands.

1 Like

Hi! I’m the hacker responsible for the kernel driver for those ASUS ROG/Strix keyboards. The patch to enable it was included in kernel 5.11.x, and kernels prior to that require a dkms module to be built from here.

As you are using ASUS gaming laptop you might also want this to help enable a few more things for you in an easy to manage way.

2 Likes

Hi, can I use kernel version 5.11.x for ASUS TUF A15 gaming, Ryzen 7 5800H? I installed kernel version 5.10.14-051014 but after booting on, I got an error that linux-header unsigned not properly installed and nvidia-smi not loaded. Nvidia gpu not seen.

I did same but I still get an error and nvidia-smi does not load.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

1 Like

After I replied your post with nvidia-bug-report.log.gz, I rebooted my system and everything works fine. Thanks you so much for the help.
Now, I feel so strong flowing with Linux OS after so much longing of getting off windows.

I think I have somthing simillar but can’t resolve this issue. I have a ryzenn 5800 and laptop rtx 3070. with kernel 5.11.0 or 5.10.x, if I start withour the nomodeset option, the system can’t boot, freezing on a black screen (impossible to switch to another console ctrl+alt+F2 …). I tried different drivers, ie, 460.59 but without success… and followed each step in the solution. Now I can boot the system without the nomodeset option in grub, but, “NVIDIA-SMI has failed because it couldn’t communicate”. The drivers 460.39 are installed since the beginning… nvidia-bug-report.log.gz (76.5 KB) Do you have an idea ?

Please delete /etc/X11/xorg.conf, it disables the internal screen. Then you installed the driver using the runfile and without dkms so it only built for kernel 5.11. Please uninstall the runfile driver and reinstall the repo driver again.