Nvidia graphic driver works in only external display on Ubuntu18.04


I’ve tried to use double monitor with my laptop(dell ailienware X15 R1), but it works like this (Only works in external display not in laptop display)

I already tried many methods below, but it still doesn’t work.

Method#1 link
Method#2 link
Method#3 link

This is my laptop information.

idim@idim:~$ lspci -nn |grep 'VGA'
0000:00:02.0 VGA compatible controller [0300]: Intel Corporation TigerLake-H GT1 [UHD Graphics] [8086:9a60] (rev 01)
0000:01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA104M [GeForce RTX 3070 Mobile / Max-Q] [10de:24dd] (rev a1)

I really want to use my laptop display with my GPU.

Thank you !

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (325.8 KB)

I attached the file.

Thank you !

Your kernel ist too old for the intel igpu. Please either upgrade to 20.04 or install a recent kernel:


I have to launch my software which only can run in Ubuntu18.04, so I installed a recent kernel as you commented.

Install site link

However my ubuntu OS doesn’t work after installation of new kernel.

I run ‘sudo reboot’ after installation, and the system stuck on this screen.

So I turned off the power and rebooted it, and the system stuck on this screen.

I reboot it again, and the system stuck on this screen.

Finally, I tried entering through ‘recovery mode’, but it also didn’t work with this messeage.

How can I fix this issue.

Again, I should keep Ubuntu 18.04 version.

Thank you !

Do you still have the external monitor connected, does it show anything?

The external monitor is connected but it doesn’t show anything.

Sometimes I log in to the Ubuntu screen, but the loading speed is very slow and then stops.

Is this issure related to network ?

Network should have no influence on this.
Please reboot into the 5.4 kernel in grub menu, then create a log from the previous boot
sudo journalctl -b-1 >journal.txt

I attached the log file made by the previous kernel.

journal.txt (271.8 KB)

There now is a lot of firmware files missing as the 18.04 firmware package was last updated a year ago. Please check if this ppa helps:

Thank you for your advice.

I update my firmware on the previous and new kernel.

When I logged in to the new kernel this message occurred,

ucsi-acpi PPM init failed

so I disconnected to the external display, it worked.

Howerver, the system stops with this error :

switching to i915 from EFI VGA

Sometimes, I can enter the main screen, but it stops soon.

I attached the log file again.

journal.txt (118.2 KB)

I really hope that I can solve this problem.

Thank you !

Looks like the firmware wasn’t added to the initrd. Please run
sudo update-initramfs -u -k 5.16.0-8.2-liquorix-amd64
and post any errors.

I run it at the new kernel

sudo update-initramfs -u -k 5.16.0-8.2-liquorix-amd64

but the system works very slow or stops.

This is the log file.

journal.txt (117.6 KB)

When I used liquorix image, the screen was frozen until /dev/nvme0XXX: clean xx/xxxx files, xxxx/xxxx blocks
Alt+F2 didn’t work to open ttyl. Only ctrl+alt+del rebooting works.