418.56, GTX 1050 TI mobile, Dell XPS, 4.19.34-1-lts, RmInitAdapter failed!

I am trying to launch a program via optirum. The same error happens using nvidia-smi. GPU is not working even after a fresh laptop start.

I am using Dell XPS 9570 with Arch Linux. I did everything to make GPU work already:

  • Blacklist in TLP
  • Using LTS both kernel and Nvidia driver
  • Using the only bumblebee without bbswitch.

Actually, GPU had been working for a while and stopped working after some kernel + driver update. I don’t remember details, because I was expecting another update will solve the problem. It doesn’t happen yet.

Some additional info.

[ 1321.722194] NVRM: RmInitAdapter failed! (0x26:0xffff:1106)
[ 1321.722239] NVRM: rm_init_adapter failed for device bearing minor number 0

Missing information?

➜  tmp git:(master) ✗ cat /proc/driver/nvidia/gpus/0000\:01\:00.0/information
Model:           Unknown
IRQ:             16
GPU UUID:        GPU-????????-????-????-????-????????????
Video BIOS:      ??.??.??.??.??
Bus Type:        PCIe
DMA Size:        47 bits
DMA Mask:        0x7fffffffffff
Bus Location:    0000:01:00.0
Device Minor:    0
Blacklisted:     No

This error looks suspicious to me, but I don’t know what it means:

[   396.458] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[   396.459] (--) PCI:*(1@0:0:0) 10de:1c8c:1028:087c rev 161, Mem @ 0xec000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288

nvidia-bug-report.log.gz (570 KB)

This rather looks like it’s broken. The previous boot, the gpu wasn’t even responding at all. You can try installing Windows to confirm but you should prepare to have it repaired.

I tried windows, and Nvidia GPU was working. To my surprise, I can use Nvidia in Linux again. It looks like GPU was stuck due to some instructions. Hope problem never recurs.

Unfortunately, Nvidia has been stopped to work after a restart of Linux. In order to run GPU again in Linux, I have to boot up into windows first. Maybe someone has an idea how to fix it?

Now that’s very odd. Did you look for a bios update already?

After a couple of restarts GPU stars working again. Maybe some ACPI messages race-conditions happens or something.

Might very well be, your dmesg is full of ACPI errors, the bios does not seem to be of high quality.

The following script enables GPU in such cases:

# Remove NVIDIA card (currently in power/control = auto)
echo -n 1 > /sys/bus/pci/devices/0000\:01\:00.0/remove
sleep 1
# change PCIe power control
echo -n on > /sys/bus/pci/devices/0000\:00\:01.0/power/control
sleep 1
# rescan for NVIDIA card (defaults to power/control = on)
echo -n 1 > /sys/bus/pci/rescan
# someone said that modprobe nvidia is needed also to load nvidia, to check
# modprobe nvidia

It is a part of https://wiki.archlinux.org/index.php/Dell_XPS_15_9570#NVIDIA_Optimus

My problem seems solved (at least I am able to enable GPU manually).