455.45.01 - GPU Throttles to 139 MHz on Optimus laptop

nvidia-bug-report.log.gz (832.9 KB)

When launching any application after a few seconds, the GPU clock throttle to 139 MHZ with associated drops in FPS. This is reported both by “nvidia-settings” and “nvtop”. I have tried adding and removing the 80-rules suggested in the manual and adjusting modprobe parameters. Currently, I am on “NVreg_DynamicPowerManagement=0x00” but I have tried 0x01 and 0x02 to no help. It does not matter which performance profile I set in nvidia-settings. Stopping and disabling tlp makes no difference.

However, if I turn off the internal intel graphics card and go discrete only, everything works flawlessly. In windows 10 it works perfect regardless of whether it is discrete or optimus.

The laptop model is a Lenovo X1 Extreme Gen. 1 running on kernel 5.9.10 (I have tried multiple, 5.4, 5.8, and 5.9). These issues started after upgrading from 430.14 (so after reverse prime was enabled if that gives any hints) OS is ArchLinux running Cinnamon on lightdm if that is of any help…

Any help in solving this is GREATLY appreciated. The alternative would be to stop using linux as I depend on GPU performance in day-to-day tasks…

Hi, you can do a clean installation of the stable driver 430.14, delete your old drivers using DDU. This problem is caused to improper updating of drivers.

@henriker , this looks like you’re running Xorg autoconfigured with the intel driver instead of modesetting, is that intentional? Therefore, the nvidia gpu is running in render offload mode, did you explicitly start application on it? Otherwise, the applications would run on the intel gpu and the nvidia gpu stays at minimum clocks since it’s not used at all.