455.xx - screen becomes completely frozen at random moments

Distro: Arch
Wm: i3
Kernel: 5.8.14
Card: gtx770

After upgrading to 455.23 || 455.28 driver I’m experiencing constant screen freezes at random time. Everything works fine right after system boot, but after some random period of time my screen suddenly becomes completely frozen, everything just hangs, mouse cursor stops moving, videos stop playing, although I can still hear the sound. When it happens, I am still able to open/close windows, applications or browser tabs with keybindings or blindly with mouse, but the screen output remains frozen until I switch to another tty and then back to GUI(tty 7). After that GUI becomes alive again, but the problem comes back after a while. Downgrading to 440.xx solves the problem.

The attached log was created right after the issue happened.
nvidia-bug-report.log.gz (342.9 KB)

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Yes, it looks very similar. People there say that the issue more likely to happen with high filesystem IO activity. Don’t know if it is related, but I always have torrent client seeding hundreds of torrents at the background when it happens to me.

Please merge with Bug report: 455.23.04 - Kernel Panic due to NULL pointer dereference

Why merge with that thread, though? There’s this thread with the same error reported in here. It looks like a different issue, e.g. nobody with null pointer dereference pointing out high i/o like the people with the page allocation failure are.

Having the same issue.
Using Kubuntu 20.04 with GTX 650 ti.
At the moment, only the 390 driver is working. I tried 440 and 450 (including server) and the results are always the same:

  1. Freeze while loading the session, not even starting it.
  2. Freezing after a few seconds the session start. When this happens i can move the mouse pointer around but i can’t do anything else. I can’t interact with anything using keyboard or mouse

In both cases, i am forced to do a hard reset

Update:

to me, this issue started around 4 days ago. I don’t know if it was some update but here is what i am thinking: It’s not exactly the updated in the nvidia drivers that is causing the bug. If this was true i would have the bug only in the most recent updated and not in drivers like 440. So, maybe, something else that is affected by the drivers and would affect a clean install is causing it. But, at the same time, i know that 390 driver it’s not causing any issue. One thing that i can see is that, at least in proton. 390 don’t have directx 11 support. But this is something wine related and i can get this bug in any clean install

Update 2:
I have several of those lines in my journalctl, filtered with journalctl -p emerg…emerg
kernel: Initramfs unpacking failed: Decoding failed

nvidia-bug-report.log.gz (260.9 KB)

Update 3:
prevboot.txt (651.2 KB)
This is the journalctl -b-1 after the crash

lspci.txt (12.1 KB)

Update 4 (more logs):
dmesg.txt (76.1 KB) lspci.txt (12.1 KB) prevboot.txt (176 KB) varlogNvidia.txt (26.9 KB)