465.24.02 page fault

Same problem here:
Distro: Debian Sid
Kernel: 5.12.8
Mobo: Gigabyte X470 AORUS ULTRA GAMING-CF
Graphics: GeForce RTX 2060 SUPER
Monitor: BenQ EL2870U, 27.9" (9H.LGTLB.QSE)
Connection: DP via KVM ATEN CS1924
Resolution: 3840x2160~60Hz

We were able to reproduce issue locally and actively debugging it.
Will keep updated and let you know once fix is available.

18 Likes

We were able to reproduce issue locally and actively debugging it.

Thank you guys, looking forward to that.

And BTW, happy to hear that at least you were finally able to get a spare RTX on the market for testing, in these hard times ;-)

(c)

1 Like

At last I found this post after searching all day! So I’m not mad after all! It took me some time before I got the idea that it might come from the displayport. It is working with HDMI here as well, but not DP. RTX 3080, same symptoms on 460.80 and 465.27. Last working version was 460.73. Is there an easy way to downgrade to 460.73 using Ubuntu repos ?

2 Likes

Can confirm 460.73 fixed issue for me. This is download link I’ve used NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver

1 Like

Can confirm 460.73 fixed it for me too. Also tried the new driver 460.84 from nvidia official NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver but it did not install everything right, cuda was not usable for instance (using Ubuntu 21.04)

Same issue here after upgrading from 460.73 to 460.80, and same behavior on 465.27. RTX 2080, Ubuntu 20.04, kernels 5.8.0-55 and 5.4.0-74, two DP + one HDMI displays.

1 Like

I have the same problem on my Ubuntu 20.04 which I updated but didn’t expected things to happen - it’s a stable distro supposedly, why I get broken Nvidia drivers?

I am using Display Port Dell monitors with RTX2080Super. Trying to roll to a driver version that doesn’t break my system.

Edit: Ended up switching the cable to a HDMI and then using the graphical UI to switch drivers.

I have the same problem on my Ubuntu 20.04 which I updated but didn’t expected things to happen - it’s a stable distro supposedly, why I get broken Nvidia drivers?

you’re welcome to blame canonical for that…

1 Like

Sharing my logs from this issue.

1 Like

Hello,

Same issue here.

I am using a GTX1070 and an Acer VG270UP when using HDMI no issues but as soon as a DP cable is plugged in X does not start or the system crashes as soon as the DP cable is plugged in.

I had hopes with 465.31 but problem still exists. No more 144hz and dual screen for me.

linux 5.12.9.arch1-1
nvidia 465.31-7

Are the any driver options to disable displayport features/behavior that might allow a workaround?

Hey, is there any way to configure something that avoids this? My RTX2080 only has 1 HDMI port.

I tried many things, the only solution I found was to install an older (nvidia official) version of the drivers NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver. I could not find a way to force install a previous version from ubuntu repositories. I’m actually amazed that this has not been rolled back by canonical, at least on 20.04 LTS which is supposed to be stable and well tested

You might want to check the Ubuntu Community Forums in that respect.
https://ubuntuforums.org/forumdisplay.php?f=332

They might have the experience to help you with this specific distro.

Other than that, I guess we’ll just have to sit tight and pray to the green gods to produce a working driver.

Same issue. I have an AMD 3800X, 64 gb ram, rtx 2080 super, fresh install of Ubuntu 20.04 kernel 5.8.0-55.

Of three 4K monitors, one shows up fine (hooked up to rtx 2080 super via hdmi), while the other two (connected to display port on rtx 2080 super via hdmi adapter from monitors) show up at low resolution. The proper resolution doesn’t show up on the system monitor settings or nvidia-settings window. Nouveau drivers seem to run the displays at full resolution and everything was working on previously installed Ubuntu 19.

Nvidia-smi seems to detect the card with driver versions 460.80, 450.119.04, and 465.19.01, (cuda 11.3), but the two monitors connected via display port show only show 1080p and lower resolution options instead of 4K.

I have the same issue but removing my DP doesn’t help.

I have reverted to kernel 5.8.0-53 with NVidia drivers 460.73.01 > This set up works for me

When Ubuntu upgraded it installed new NVidia drivers and kernel 5.8.0-55 which won’t boot on my system.

Card: GTX 750 Ti
OS: Ubuntu 20.04-2 (5.8.0-55)
Monitors: Samsung 4k (DP) & ViewSync VP2770 WQHD (HDMI)

I’m stuck being unable to update anything at the moment as as soon as Ubuntu upgrades itself it updates all the NVidia drivers and the system won’t boot.

You can try to apt-mark hold the nvidia driver package.
See: https://www.cyberciti.biz/faq/apt-get-hold-back-packages-command/ for more info.

Or you can install the working drivers manually after having downloaded them from nvidia website. The only drawback is that you have to uninstall them prior to any kernel update and reinstall them afterwards. However, I’d be interested to know if the apt-mark way works

Can I hold a previous version with apt? Whenever I install, apt always install the latest.