DPMS not working with DisplayPort monitor

I’ve seen several old threads with this issue that lost activity because apparently issue got fixed for people (in the past).
DPMS with Display Port monitor does not work for me, and haven’t ever.
I have 980 with several monitors (DVI,HDMI,DP) and only for DP monitor powersave does not work.
Symptoms: “sleep 1; xset dpms force off” will cause monitor to turn off for a split second then it turns on again. If I have X blanking enabled, it will turn on to display a black screen and mouse cursor :)
“xset dpms force {off|stanby|suspend}” all have the same effect.

Monitor: Samsung S27D850T
Monitor: Dell UP2716D
Current driver: 370.28
DP: 1.2
Desktop environment: doesn’t matter, Plasma, GNOME, i3, all the same.

But with nouveau DPMS works, so it is not a hardware issue.

EDIT: seems fixed in 381.09.
nvidia-bug-report.log.gz (260 KB)

I also have this problem on a Dell U3415W and has not been resolved. Hooking up via HDMI or DVI makes this work as expected.

375.10 still nonfunctional DPMS.

There is a Dell UP2716D that settled in on my desktop. Also connected via Display Port and also doesn’t have functional DPMS with Nvidia linux driver. 375.20 by the way.

Could we get a fix for the driver, or a workaround so our monitors would save power?

Another me too, this has not been working for a long time. I have a GTX980 with two (daisy-chained) Dell U2414H monitors connected via DisplayPort. Currently on driver 375.20. Nvidia blames the monitor firmware, but they fixed it in a few beta drivers long ago (I don’t remember the exact working driver versions, but they were a year, maybe more ago). Then broke it again when they released the non-beta version of the driver and seem like they are ignoring any further posts about the issue.
nvidia-bug-report.log.gz (283 KB)

Well, in my case its 100% of DP monitors, also two different vendors, and it works with Mesa driver. As far as I’m concerned NVidia is to blame here.

That’s good (and bad :P), maybe it will get them to look into it (again). And yeah, it works for me in Windows, and with the nouveau driver. Just the fact that they released a driver where DPMS worked, then it stopped working again the next driver says to me it is most likely a nvidia issue, but that is really just speculation. I just wanted to let you know not to get your hopes up.

I have verified the following so far:

Card: MSI 980TI 6G connected via DisplayPort

Monitors:

  1. DELL U3415w
  2. Asus PB278Q

Distros:

  1. Ubuntu 14.04
  2. Ubuntu 16.04
  3. Ubuntu 16.10
  4. Arch Linux - Rolling Release for over a year

Nvidia: All drives from 330 - 375

DPMS works with Nouveau and Windows. Same cables, monitors, and settings.

Same problem here.

Dell U3417W <- DP <- Nvidia 1080GTX

Driver version 367.57 (Fedora 24 / rpmfusion).

“xset dpms force off” causes screen to blank properly (no backlight) for about 1 second before
backlight comes back on.

This sounds like it might be a different issue. Or maybe it is just a different symptom of the same issue. For me, my screen never turns off. If I issue xset dpms force off, my screens just go black (the backlight never turns off).

Same problem here :(

375.20 drivers, GTX 1060

1 AOC DP monitor, won’t turn off
and 1 HDMI Monitor, turns off perfectly.

What is the exact model of the AOC monitor? Could you add your output from nvidia-bug-report.sh

I’m hoping if we can get more bug reports, they might be more likely to look into this (again).

AOC Agon AG271QX

nvidia-bug-report.log.gz (144 KB)

I have found interesting bit of information on accident. If Dell is the only active output (as in only one enabled in xrandr, not physically) then DPMS works, next if I enable any other output additionally (for example HDMI-0) then DMPS for Dell monitor stops working.

For Samsung monitor DPMS never works though, even if its a single active output.

Same issue here.

DPMS will not turn off the monitor.

The only way the monitor can be shut off is to manually force it off by disabling the entire port with xrandr --output DP-X --off.

Am running a GTX 1080 founders edition (nvidia’s own card) and 2x ASUS PB278Q monitors connected via displayport.

nvidia-bug-report.log.gz (143 KB)

Nearly six months later and this still appears to be a problem. Primary monitor on DP, secondary on DVI, the secondary blanks correctly, the primary doesn’t regardless of whether the secondary is connected, or even if the secondary wasn’t connected when the system booted. It will go out momentarily as if switching modes, then come back to the mouse cursor on top a black screen. Lock screen appears on mouse/keyboard activity and system remains perfectly usable.

(Where’s the attachment button?..nvm, found it)
nvidia-bug-report.log.gz (147 KB)

I hate to say this, but I purchased a AMD R9 Fury and with the open source drivers the DisplayPort DPMS blanking works perfectly.

Just updated to drivers 378.13 and the problem is still there :(

GeForce 1050Ti, 378.13, Dell p2317h - the same problem here.

Same issue here.

DPMS works on Windows just by rebooting into the OS.

Linux still has broken DPMS support for displayport monitors using the Nvidia driver.

GTX 1080 Founders edition + 2x ASUS PB278Q.

Using latest driver.