DP1.2 connected monitor cannot be turned on again with DPMS

Hello,

I have the problem that every time when I lock my desktop environment and the monitor is turned off it is not activated again by moving the mouse or pressing any key. Only by switching tty (ctrl+alt+f7) the monitor is turned on again.

The problem can easily be reproduced on my pc by connecting from another device per ssh with the following commands:

export DISPLAY=:1
xset dpms force off

using afterwards

xset dpms force on

has no effect.

I tried the following driver version: 340.96, 361.42 (both official repository), 358.16, 364.19 (from graphics-drivers ppa)

The problem is not occurring when using nouveau and not on Windows 10.

The problem only occurs if the monitor is connect per displayport. (I need displayport for getting 4k@60hz)

I could reproduce the problem on the live version of ubuntu (only installed the nvidia driver 361).
Moreover I m using ubuntu gnome and could reproduce the problem with gdm3 and lightdm.

A probably different issue that occurs after the monitor is restored by using switching tty (ctrl+alt+f7) is that the desktop looks “corrupted”: color of the background on gnome and icons, buttons in unity are messed up (I attach two screen shots of this).

My settings:

  • ubuntu 16.04,
  • geforce 670 gtx
  • Samsung U28E590D

Thanks for reading!
nvidia-bug-report.log.gz (196 KB)


Hello,

I have a nVidia ASUS STRIX GTX970 graphics connected to my DELL U3415W (21:9 ultrawide) via mDP. Having similar issues to the above poster. Running Arch Linux x86_64 with proprietary nVidia drivers 364.19-3 from the official repository.

When my monitor goes to sleep, if it is within a short duration it will wake-up immediately. However, if it is off for about 15 minutes, it will not turn back on my moving mouse, pressing keys. Only by switching to a tty like the above user.

I’ve attached the bug report, but I believe there is nothing in it that indicates there is a problem.
nvidia-bug-report.log.gz (204 KB)

https://onedrive.live.com/redir?resid=8C16C0F9FE654EC4!533&authkey=!AIIfwRhpaUX1GSE&ithint=file%2Cgz

  • bug report, for some reason site won’t upload. Keep seeing this on website:

Attachments

[SCANNING… PLEASE WAIT] nvidia-bug-report.log.gz

Hi All, Please test with latest 364.19 and 367.18 and share results.

Update:

I installed the latest beta driver, 367.18, and still have the issue. I did some investigating and screen blanking works i.e. black screen after inactivity and moving mouse to wake up the screen.

The main issue is that when the monitor is turned off and then turned back on, the GFX card will not detect the monitor.

In order to resolve the problem, I need to press CTRL+ALT+F6, switching to TTY6, and then KILL THE XORG SERVER. After this happens, my system detects XOrg isn’t working and restarts the display - at which point the monitor starts working again.

I’ll investigate the issue further and post my bug reports, when I get more time.

I think the problem lies somewhere with XOrg and nVidia drivers.

Thank you for reading.

We are tracking this issue under 200202601

Hello,
i also tested 367.18 and the problem is still present. However the corrupted desktop after restoring the monitor with ctrl-alt-f7 seems to be gone.

Thanks

Looks this issue is very specific to Samsung U28E590D and DELL U3415W which are not available with us. We are not able to repro this issue with other displays like HP spectre 32 - HSTND-5001-A , Dell UP2414Qt , Acer XB281HK , Asus PQ32 and Dell UP321Qt .

The ASUS PB278Q also has this issue if you have the ability to test with this monitor.

Still occurs with 367.27. What could i provide to identify this problem? Would an ssh access help? I could switch my hdd and do a fresh ubuntu 16.04 install.

in the meantime while waiting for a response… i also tested debian jessie with 340.96 where the issue is also reproducible! However when using the legacy driver 304.131 the issue did not occur but 4k resolution is not possible with this driver so not a real solution.

Moreover i noticed that sometimes in ubuntu 16.04 the monitor-wakeup works once but fails at the second time.

Attempted test with Monitor ASUS PB278Q + Geforce GTX 670 + vBIOS 80.04.19.00.21 + Driver 340.96 + 364.19 (from graphics-drivers ppa) + Ubuntu 16.04 ) --> No Repro.
Resolution set to 4k@60hz and DP Stream from monitor settings set to :- DP 1.2
Performed command " xset dpms force off " then waited for 10 mins, 15 mins, 30 mins and moved mouse, observed no black screen able to resume the display.

After keeping system in dpms off overnight still not able to repro in black display .

Is this repro steps straight forward ? Don’t know why we are not hitting this issue? We have testing on fresh OS and Unity desktop. Is there any specific repro sequence to trigger this issue?

Hello,

Try testing with those monitors but with a GTX 1080. Try and do anything DPMS related when they are connected via DisplayPort.

Hello,
i also tested 367.35 and its still present.

To reproduce the problem i perform the following steps:

  • install a fresh system ( i tested normal ubuntu 16.04, ubuntu gnome 16.04 or debian jessie 8.5)
    or use the ubuntu live media version with persistence
  • i update all packages but this can be omitted
  • install the nvidia-driver (4k@60Hz by default)
  • at this point dpms is working since the system still uses nouveau
  • i perform a reboot so that the nvidia driver is active
  • i type: xset dpms force off -> screen becomes black and after 2-3s the monitor goes in standby
    by moving the mouse or pressing a key the monitor turns on again.
  • i repeat this: xset dpms force off -> screen becomes black and after 2-3s the monitor goes in standby
    now the monitor isn’t turned on again (doesn’t matter if i wait here or not!) until pressing ctrl+alt+f7

I can still provide ssh access and moreover a skype video session with my laptop so that you could see the monitor.
Would a video where i start from a live session until the problem occurs help you to further understand the problem? (i mean a real video showing the monitor not a screen recored)

checked with new fresh install ubuntu 16.04 + GTX 1080 + HP Spectre 32 ( 4k@60 Hz )
attempted 30 time xset dpms force off, still not able to repro, will check for similar monitor ASUS PB278Q
Also Tested with ASUS PB278Q , EFI mode ubuntu 16.04 , same config not able to repro.

I’m experiencing exactly the same issue as stated by ret_ in the initial post and I’m using exactly the same workaround (CTRL-ALT-F1 then CTRL-ALT-F7) to wake the monitor up.

I did upgrade my graphics card today from a MSI GTX 960 Gaming 2G (GM206, 2GB) to the new TITAN X (Pascal) in the hope that it would make the problem go away. The reason I thought it would make a difference is that I did not see this problem on the GTX 960 as long as I was using a 1080p monitor via DVI. It only started the moment I switched to the Eizo FlexScan EV3237W which is running at 3840x2160, connecting via DP 1.2. So my assumption was that the GTX 960 is “too weak” for that monitor and maybe has not enough VRAM.

Sadly, the Titan X exhibits the same behavior and I have to do the CTRL-ALT-F* dance to get it to wake up again. After that, the Gnome unlock screen looks all strange (black lines all over the place) but allows me to log in. My desktop background image is mostly black now and only shows some artifacts of what is supposed to be shown. I’ve attached a screenshot.

I’m using:
Ubuntu Gnome 16.04, 64bit
Nvidia Driver Version: 367.44
Motherboard: Asus X99-E WS, BIOS 3201
RAM: 32GB
CPU: Core i7 5960X
Connection to monitor: DFP-2

@ret_: Which motherboard do you have? I wonder if that has anything to do with it.

Hi mss5, Can I get nvidia bug report of your system as soon as issue reproduce ? How long it will take to repro the issue. Is screen saver, screen lock, display sleep, system sleep/suspend enabled on your system? Do you have other DP.1.2 display where you hit this issue?

Is the issue repro with below commands :
xset dpms force off
xset dpms force on

Hi sandipt,

I’ve attached the envidia bug report after running into the issue. Using the first repro command, the monitor turns off immediatly and xset -q confirms that the monitor is off. After running the second command, xset -q tells me that the “Monitor is On” but it clearly is not, it is still sleeping.
I am not using a screen saver, the monitor is being sent to sleep directly. I do not have another DP1.2 display I could verify this behavoir with.

I did read on some forum that this might be related to EDID detection so I tried this option:
Option “CustomEDID” “GPU-0.DFP-2:/home/mschmitt/.eizo-edid.txt”
but it did not make a difference.

I also found users who claimed that turning off DDC/DI on their monitor fixed the problem. I can’t find a way to turn this off on my Eizo monitor, though.

Thanks.
nvidia-bug-report.log.gz (137 KB)

Hi mss5, Please blacklist Nouveau driver and check issue still occurs.

You can add Nouveau Driver in /etc/modprobe.d/blacklist.conf file. OR create file like /etc/modprobe.d/disable-nouveau.conf with below entries

blacklist nouveau
options nouveau modeset=0

And add kernel parameter : vga=0 rdblacklist=nouveau nouveau.modeset=0
Reboot

I am having what seems to be the same problem.

HP ZBook 15 G3 Laptop
Ubuntu 16.04.1 64Bit
NVIDIA Quadro M600M
NVIDIA Driver 320.23
Noveau driver has been blacklisted and inactive.

3 Monitor setup:

1 Laptop Primary Display
2 Dell 23" Monitors attached to HP Thunderbolt 3 Dock via Display Ports

When I lock my machine all screens shutdown. When I log back in only the primary Laptop display turns on.
Although running xrandr --verbose indicates that both DP-6.1 and DP-6.2 are connected, they remain black and off. The same Ctrl+Alt+F1 then Ctrl+Alt+F7 trick wakes the externals back up.

nvidia-bug-report.log.gz (195 KB)