White noise/static with Quadro T2000 mobile and external monitor

I have a Lenovo Thinkpad P1 (2nd gen) with a Quadro T2000 mobile nvidia gpu, driver version 450.66. I’m connecting a DELL 2560x1440 external monitor via mDP and a Thunderbolt Thinkpad Lenovo docking station. The docking station is attached to my laptop via Lenovo’s proprietary thunderbolt system, I believe (it has the lightning symbol next to the port on the laptop and on the plug).

I’m running ubuntu 20.04 with kernel 5.4.0-48-generic.
xfce4.14 with 2x display scaling enabled.

Since upgrading to the driver version 450.51 (the newest version shipped in ubuntu 20.04’s repositories), every once in a while, I get static/white noise coming from the bottom of my external monitor. Sometimes it covers the entire screen, sometimes it moves up and down, flickers. It usually disappears if I change windows or click my mouse somewhere. Then it may come back again. It is very disruptive occasionally.

I tried

  • manually installing the newer 450.66 driver, that didn’t help. (nvidia-smi and cuda work fine, even with the “older” apt packages).
  • cannot find anything weird or relevant in dmesg/kern.log and x.log
  • unchecking the “allow flipping” option in nvidia x server settings -> openGL settings
  • checking the “force composition pipeline” option in nvidia x server settings -> X server Display Configuration -> advanced (read on some posts that this prevents screen tearing)

Note that I’m almost certain this must be a nvidia driver issue because the static only appears on the external monitor, NEVER on the actual laptop screen. There’s also no issues when I switch to the intel integrated graphics (but I can’t test those on the external monitor because Lenovo P1’s are somehow hardware configured such that external graphical output can only be handled by the nvidia GPU).

I’ve been googling this regularly for the last two weeks and can’t find anything. I’m happy to provide further info of course, and am attaching a picture (which I had to take with my phone, as a screenshot of the screen does not show the static at all !)

I’ve got a Lenovo P53 with the same graphics card and a Lenovo dock running Fedora 32 and I have the same issue with 450.66-1 driver. I have 2 external monitors and it only happens on one of them. The one it happens on is connected by Displayport. It seems to happen a lot while I’m using the Firefox browser on that monitor. The search results from duckduckgo.com in Friefox seems to be a sure way to trigger the problem for me. I do have it happen at other times as well though including during some screen savers. It has to be related to a particular thing that those and some web pages in firefox are using.

1 Like

I’ve been trying out some more things. I’m also using an mDP connection and the static issues also mostly show up on full-screen firefox. If I use hdmi via the docking station, I don’t get static anymore, but sometimes the external monitor randomly shuts off and then turns back on again after a few seconds. When I connect hdmi directly to the laptop I have no issues whatsoever (unfortunately the lenovo P1 doesn’t have a micro display port so can’t try connecting mDP directly).

Conclusion: this leads me to think the issue is with the thunderbolt docking station firmware and not with the nvidia driver. Re lenovo firmware: I have still not figured out how to update the firmware for linux. On fwupdmgr I get “no updatable devices”, though it regonizes the lenovo components. And I also still don’t understand whether upgrading firmware on windows using the system update tool actually helps on linux or not (I believe it’s possible some firmware may be directly installed on the docking station?).

This thread’s a bit old, I know, but I found it while diagnosing the same issue I’m encountering.

I have a Dell Precision 7540 with nVidia Quadro T2000 Mobile / Max-Q and am using a Dell WD19DC dock. I have two monitors attached to the dock via DisplayPort. I’m trying to run both monitors at 1440 and 144hz, and it’s very finicky.

My secondary monitor (Dell S2716DG) typically works just fine, but my primary (Samsung Odyssey G7) suffers this exact issue. Sometimes the full display is distorted with a purple hue, and I have to restart it til it works.

Other times I get this exact issue you’re seeing here. Scrolling Reddit is my go-to trigger, but it happens elsewhere too. Currently running nVidia 460 drivers. I’ve updated my dock’s firmware and everything, but I haven’t tried the mDP connection on the back of the laptop yet due to lack of a mDP cable.

I am also experiencing this issue. Lenovo P53 / ThinkPad Thunderbolt 3 Workstation Dock Gen 2

I am also experiencing the issue with colour noise on my external monitor connected via Thunderbolt dock.

Notebook: Thinkpad P1 Gen2 with Nvidia T2000
Docking Station: Thinkpad Thunderbolt Workstation dock Gen2
external Monitor: Thinkvision P27u running at 4K resolution

The problem appeared with the Nvidia driver 450.51 Beta driver.

Using the older 440.100 driver, the problem is gone.
So probably it has something to do with changes from 440.100 to 450.51 driver version
Connecting the external monitor directly to the notebook via USB type C I have no problem at all.

I also checked “Allow flipping” and tried to disable UBB. Both settings had no effect.
(Which is no wonder, since the note to disable UBB and Allow flipping holds also true for 440 drivers. But with 440 driver the problem does not appear. So it is to assume that UBB and Flipping is not the reason for this issue.)

It also does not matter whether I am running Fedora 32/33 or Ubuntu.
What seems interesting is the fact, that always one half of the screen is affected when running the monitor in native 4K resolution. Changing the resolution to Full HD the full width is affected.

The size of the rectangular noise changes depending on what is shown. Firefox is not a requirement for this issue to appear, it also happens without firefox running.
The pattern of the noise changes depending on mouse movement and position.

Since the issue only appears when the Thunderbolt dock (no other dock tested yet) is connected, it may have something to do with MST Support in the Nvidia driver.
MST stands for Multi Stream Transport. The Thunderbolt Dock makes use of such a MST hub to drive several monitors on one single USB type C port.

So it would be interesting if it works with a regular USB C Hub. If someone has such a regular USB C hub, could you please try and give feedback whether it works or not?

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Dear @generix
please find attached the nvidia-bug-report.log.gz
nvidia-bug-report.log.gz (1.1 MB)

Should you require additional information, please let me know.

@generix
I am limited to maximum 3 replys in this topic because I am a new user. Thus, I try to edit this one to reply to your posts.
Is there the option of private messages?
Why users a limited to 3 replys per topic? With such a limitation, problem solving is almost impossible :(

now my reply:
I have selected the nvidia gpu as the primary gpu, so the intel gpu should be disabled.
It also looks like prime-select is not installed

But since I have the exact same settings with 440 driver and there the issue does not appear, I assume it is not a prime issue.

Lokks like you’re running the nvidia in output sink mode, does this also happen in the full nvidia mode, i.e. running
sudo prime-select nvidia

The Output Sink feature was added with 450, so your config changed without you noticing.

@generix
I have configured the nvidia card as primary card in /etc/X11/xord.conf.d/nvidia.conf
Nevertheless, I tried the following written here:
Using the NVIDIA Driver as an RandR 1.4 Output Source or Output Sink Provider

here is my nvidia.conf in /etc/X11/xorg.conf.d/

Section "OutputClass"
        Identifier "nvidia"
        MatchDriver "nvidia-drm"
        Driver "nvidia"
        Option "AllowEmptyInitialConfiguration"
        Option "SLI" "Auto"
        Option "BaseMosaic" "on"
        Option "PrimaryGPU" "yes"
EndSection

Section "ServerLayout"
        Identifier "layout"
        Option "AllowNVIDIAGPUScreens"
        Screen 0 "nvidia"
        Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

and here my Xsetup:

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

Still the same issues.
So from what I have tried, I assume it does not correlate with Reverse Prime

Find attached again the nvidia-bug-report.log.gz
nvidia-bug-report.log.gz (883.8 KB)

Yes, your system is now running in prime output mode so since the distortion is still there, it has nothing to do with the output sink being added in 450.
Please check if this is an issue with memory clocking by setting PowerMizer to “Maximum Performance” in nvidia-settings.

I’ve changed the powermizer settings to “Prefer Maximum Performance”.
Then I run glxgears, still the same issue, no change.

Is there any possibility to check if the issue lies in MST handling or Direct To Display? As far as I know there was also a change in 450.

By the way: in addition to the noise, the monitor goes off and on sporadicly (also in powermizers Auto or Consistent Performance Mode). This is an issue I have already read several times.

What the driver does in the display engine is unfortunately not debuggable for us users.

I almost presumed this.

I still think this is buffer related, since the noise depends on the content displayed. The pattern of the noise changes and also the size of the rectangle noise changes. For example when scrolling the size of the rectangle changes. When moving the mouse cursor the pattern changes. Just before I saw the pattern alternates with the type cursor blinking.

Do you see any other thing we could try?
Maybe a Nvidia driver developer can join the thread?

In any case, the docking station cannot be used as it is currently. And I am quite sure we are not the only one.

Currently using a Dell Precision 7540 with Quadro T2000 Max-Q on Arch Linux running nvidia drivers 460.32.03. I am docked using a Dell WD19DC, which isn’t Thunderbolt but 2x USB-C. Connected to the dock’s DisplayPorts are two 1440p monitors, both running at 144hz – one is a Samsung Odyssey G7 and the other a Dell S2716DG. The laptop’s display is off and switchable graphics is turned off in the bios.

Interestingly, only one monitor seems to suffer issues, the Samsung Odyssey G7. I’m not sure if it’s possibly related but the Samsung monitor is DisplayPort 1.4 while the Dell monitor is DisplayPort 1.2. I have the same exact square static as shown in @fhortner’s images that resize and change position. It happens a lot in Chromium.

I also had issues with the monitor establishing connection. Sometimes the entire screen was distorted and I’d have to reconnect, reboot, or shut down my machine multiple times until it connected without distortion. I eventually found that turning off modesetting (nvidia-drm.modeset=0 nomodeset kernel parameters set] seemed to alleviate this particular issue.

If there’s anything I can provide to help diagnosing this issue, please let me know.

nvidia-bug-report.log.gz (310.0 KB)

(Edit: I realized after the fact that I had already responded to this thread, but this post has more information)

Dd you try swapping connectors to check if it only appears on the Samsung?
fhortner’s Thinkvision only has DP 1.2.

Yeah, I’ve tried different connections on the dock itself, swapping cables used on each monitor. I’ve also tried the HDMI port on the dock instead of the display port and still has the same issue only on the Samsung.

Edit: and with this response, I’ve hit my 3 reply limit on this thread…

I’m a bit late to the party, but here are the logs the bug report tool has generated.
nvidia-bug-report.log.gz (96.9 KB)