[530.41.03] External monitor stays frozen until I move my mouse

I tried all the different nvidia variants (dkms, vanilla, lts), and all had this same behaviour.
When logged in, the external screen stays black. I’ve to move my mouse on it so it refreshes, then it will refresh everytime I move my mouse on the screen; it won’t (ever) otherwise.

Downgrading every single NVIDIA package (to 525.89.02-2) did the trick.

Lenovo Legion 5 (RTX 3060), on EndeavourOS with Cinnamon.

nvidia-bug-report.log.gz (1.1 MB)


Please embed the amdgpu module into the initrd and create an new nvidia-bug-report.log.

nvidia-bug-report.log.gz (974.2 KB)

I upgraded back to 530.x and checked a few things.
I’m using optimus-manager to control the GPU profiles. When setting it to nvidia only, the freeze is gone, but performance are terrible.

The logs look better with amdgpu starting early but this obviously wasn’t the reason. 530.41 seems to introduce a lot of bugs, another user reported the same issue.

I’m getting this also. This makes my setup impossible to use.

And when I tried to see if the bug with orientation was resolved with this new version, I found that’s gotten even worse! It takes many seconds to change and locks up everything and only the mouse pointer moves on the internal screen, I can’t select or do anything, I have to reset.

Every driver release in the last like 9 or so months has made my situation bad. (Not being able to use an external monitor without the internal one turned on, apparently random external monitor freezes, rotation not working properly.)

I thought the “Linux support from Nvidia is bad” trope was overexaggerated, but this is all so insufferable that I am now seriously thinking of selling my Thinkpad P50 :(

Edit: the aur/downgrade workaround below worked (after I also ran mkinitcpio -P)

1 Like

arch linux user here, downgrading to the previous version fixed this issue.

sudo downgrade 'nvidia<=530.41.03-1' nvidia-utils nvidia-lts
warning: downgrading package nvidia-lts (1:530.41.03-1 => 1:525.89.02-11)
warning: downgrading package nvidia-utils (530.41.03-1 => 525.89.02-2)
warning: downgrading package nvidia (530.41.03-1 => 525.89.02-12)
1 Like

this goes above “bad support”, it’s more like sabotage towards linux users at this point :/

time for another

Same issue here.
Not nice for programming or writing.

@mxmilkiib @florian.castellane @simon.klemenc
could you guys please post debug logs? looks like devs only reply when a moderate ammount of people do post them…

nvidia-bug-report.log.gz (274.6 KB)

Same error here with arch linux.

After downgrading, the HDMI no longer works (not recognised). Trying to find which package is responsible.

nvidia-bug-report.log.gz (603.3 KB)

With each update, a new issue appears with my external monitor on my laptop. (External monitor is run by dedicated GPU)
This is another one that occurred with the latest update.
Truly amazing Nvidia.
nvidia-bug-report.log.gz (288.8 KB)

FYI this only seems to happen on Xorg for me. On Wayland this problem does not occur
but personally, I can’t use Wayland since it comes with its own set of issues

I have filed a bug 4074722 internally for original post, shall try for local repro and update.
If required, shall request more information.
Thanks in advance.


I downgraded, but the previous few releases I can downgrade to all eventually freeze the external screen solid, requiring it to be disabled then re-enabled (only to freeze again later), like I reported in my original post on this forum.

I’ve gone back to 530. and I can’t reproduce the mouse moving freeze problem, but the external monitor now full on freezes in roughly a matter of minutes (e.g. the first time I fullscreen or unfullscreen mpv) rather than roughly in tens of minutes.

P.S. And I need to disable then enable my third monitor for it to be displayed on, because it’s black after login.

P.P.S. Linux regression testing - what’s the issue in Nvidia practicing this?

you downgraded all the packages?
my ignorelist:
lib32-nvidia-utils: ignoring package upgrade (525.89.02-1 => 530.41.03-1)
libxnvctrl: ignoring package upgrade (525.89.02-1 => 530.41.03-1)
nvidia-dkms: ignoring package upgrade (525.89.02-2 => 530.41.03-1)
nvidia-settings: ignoring package upgrade (525.89.02-1 => 530.41.03-1)
nvidia-utils: ignoring package upgrade (525.89.02-2 => 530.41.03-1)

1 Like

I tried to reproduce mouse lag/freeze issue but no luck so far on below setup.
I am using prime render offload configuration.
Lenovo + Fedora 37 + kernel 6.0.7-301.fc37.x86_64 + Quadro T1000 with Max-Q Design + Driver 530.41.03 + Xfce Version 4.16 + External Display GBT AORUS FI27Q-P with resolution “3840x2160” and refresh rate as 60 Hz

Can you please share nvidia bug report and reliable repro steps so that I can try the same on my setup and attempt for local repro again.

1 Like

Can you please confirm the consistency of repro. Is it every time you login and external screen stays black until you move mouse on external display.
How are you connecting external display with notebook, is it via dock or direct HDMI/DP connection ?

As stated in a previous post, I’m using optimus-manager as I have a hybrid gpu setup (amd apu - 5600H + RTX 3060). When it’s set to hybrid mode, the second screen will be black, then freeze every single time untill I move my mouse on the display (situation in OP).
When it’s set to NVIDIA mode only, the second screen won’t freeze, but the performences are extremely poor (1-2 FPS, buggy video playback etc).

It’s connected with HDMI to a TV.

I shared a report on Xorg slowness, freezing and crashing with external monitor, Thinkpad w/ Optimus (GM107GLM [Quadro M2000M]) - #9 by mxmilkiib but I’ll add another one just now.

I’ve also put more detail about my varient of external screen freeze problem as it’s more similar to the original post I made for an earlier driver than this 530.x “needs the mouse to move to update the image” issue.