Display port over USB-C with docking station - only one display works even two displays are recognized

Hi,

My set up is:

Hardware

  1. Two external displays Dell S2721DGFA nanoIPS HDR
  2. Docking station i-tec USB-C/Thunderbolt 3 Triple PD 85W
  3. Laptop Asus 2021 TUF A15 with RTX3060.

So i-tec docking station is connected over USB-C to the laptop. And the two monitors (displays) are connected to the docking station over Display Port cables.

Software:

  1. Fedora 34 with Driver version 465.31 (GNOME 40)
  2. Windows 10 (standard stuff with latest driver installed).

Problem in Linux:
There is no signal in one of the monitors even though they are recognized and visible in the Gnome settings. Please see the screenshot (you can see that all three monitors are detected and available - two DELLs and the laptop internal display).
Unfortunately one of the displays is blank. It says that there is no signal and it goes into standby mode. This is strange because as you can see in the screenshot there are all three wallpapers available. I can’t figure out how to make it work.
All updates are installed (newest kernel, drivers).

What’s more let me just say that in Windows everything works and there are is no any problem - all three monitors have signal (eh!)

Here is the nvidia-bug stuff and the screenshot:
nvidia-bug-report.log.gz (139.4 KB)

I’m adding a photo how it looks from my perspective (the display on the left is blank)

Additional information:

When I boot with nvidia-drm.modset=1 - the computer freezes during boot. So In order to boot I need to set nvidia-drm.modset=0.

As the nvidia-drm.modse=1 is the default setting after the driver installation, this is even more strange.

I am using a Thinkpad P1 Gen2 with the following HW-config:
Nvidia Quadro T2000
Thinkvision P27u connected via DisplayPort on Thinkpad Thunderbolt Dock Gen2 (FW 3.1.69) which itself is connected via Thunderbolt 3 to the Thinkpad P1 Gen2
System: Fedora 34 KDE

in principle the screen is working after boot up. But as soon as I suspend the notebook, the screen does not come up again. Also the screen is not recognized. Only after disconnecting and reconnecting the monitor from the dock, the screen is recognized again.

kernel parameter is still nvidia-drm.modset=1

Are you experienceing this every single time you boot up your system, or is it also related to suspend/sleep mode?

Hi,

But as soon as I suspend the notebook, the screen does not come up again. Also the screen is not recognized. Only after disconnecting and reconnecting the monitor from the dock, the screen is recognized again.

Yes. Same effect here.

Another try: I installed Ubuntu 21.04 (fresh install) - driver 460. After plugging in the USB-C cable to the laptop the two monitors are having signal!
But look at the the following artifacts (monitor on the right). Apart from that notice how the colors are different! (left monitor very bright comparing it to the one on the right)

So I tried to upgrade to the newest drivers and no MORE TWO MONITORS - only one.

This is very disappointing.

@gietki.social:
So when you booting up your system normally both external screens are detected and working and only after suspend the one external screen is not detected anymore, right?

Yes, this is a known effect that we already discussed here:

Bug should be fixes with 460.80 or 465.27

well 460.80 still has the bug. Someone reported 465.27 doesn’t have 2nd monitor working?

This is the Lenovo P53 so both monitors are in the dock. It is curious the corruption appears on the desktop but not the screen capture - suggests the “painting” of the capture buffer is independent…

@philathome I have tried 460.80 and the static noise issue appeared resolved.
could you try to upgrade your kernel?

@fhortner Probably. which version consistent with the (k)ubuntu?
a bit concerned about regressions for all this funky hardware!!

I have 5.6.0-oem in the repo which I think might be the redhat/lenovo kernel
Also there is 5.8.0
.
Anyone else using P53 have a new kernel that’s ok with 2 monitors and the TB docker, wlan etc…?

I am running the P1 Gen2 with 5.12 Kernel.
The only issues I am currently facing seem to correlate with sleep/suspend

Because of the white noise crap, I upgraded the driver from 460 (default in Ubuntu 21.04 after clean install) to 465. After that only one monitor had signal (like in Fedora 34).

This is really disappointing, because it seems like regression and lack of tests on Nvidia side. To be honest, those RTX cards are expensive so it’s like giving end user the middle finger. Ask yourselves why does it work in Windows and it is so lame in Linux. Taking into account how large company nvidia is that’s disappointing.

@gietki.social
The important information of the driver is not the branche (460, 465, …) but the version/subversion like 24, 27, 31 for 465 branche

@fhortner is it really? I think that the most important thing, is that the driver is updated to the latest version. There shouldn’t be any regression in drivers! Come on! This is not a crappy website portal which can have rolling updates, we’re talking here about DRIVERS! IMO Nvidia just prefers Windows over Linux and doesn’t pay enough attention or money to its developers.

To answer your question, you can see in my first report from Fedora that the driver version is 465.31. In Ubuntu (clean install) there was 460 driver installed by default and after enabling ‘development’ repo, there was the latest driver available and installed as well.

To make things clear, it is not me you want to complain about.

Either you find the information about driver branches 460 (currently as Nvidia recommended) and 465 (New Feature Branche) useful or not. Thats your choise.

So if you expect suggestions and help to get the problems solved you are facing, it is important to share detailed information about which driver exyctly you are using (in this case with Ubuntu 21.04) - for Fedora 34 you already did.
Running 460.39 makes a difference compared to running 460.80.

In any case, sowing aggression here will not lead to the desired result - which is to get bugs fixed which are eventually there.

@fhortner you asked, I answered. I don’t complain to you about it (I don’t know you and I don’t care about you). It is Nvidia forum. They should care about their customers. But they obviously don’t. It is 21st century and writing drivers with the resources that this company posses should be as simple as buying groceries. And please stop accusing me of aggression as I’m not aggressive - I’m only pissed at Nvidia that for the money I paid for their hardware they don’t deliver proper drivers. Shocking!

sleep/suspend less of an issue. When I next get a reboot update, I’ll try a newer kernel.

I am not a fan of a random walk reboot cycle, too many other things to break!!

NVIDIA, do we have an actual cause for this problem that we can know is fixed in the driver, not a specific kernel?

We have filed a bug 200745843 internally for tracking purpose.

I tried duplicating issue on few setups locally with Dell Docking station ( WD 15 K17 A) and used 4k monitors Dell U2715Hc and UP3214Qt using DP port via dock but no luck so far.

I will look for i-tec dock or Thinkpad Thunderbolt Dock Gen2 and reattempt to duplicate issue very soon.