[470.57.02] Nvidia 30-series HDMI audio stops working when switching from 60Hz to 120Hz

When my RTX 3090 is connected to my LG C1, it defaults to 3840x2160@60Hz (VRR). With this setup, HDMI audio works fine out of the box. However, when changing the refresh rate to 120Hz (VRR) or 100Hz (VRR), there is no sound anymore (despite the ALSA devices still being detected). Switching to a lower refresh rate consistently brings back the sound output.

To reproduce:

  1. Ensure nothing is playing audio
  2. Switch to 60Hz (VRR)
  3. Attempt to play audio (eg. Youtube in Firefox) → Audio works
  4. Ensure nothing is playing audio
  5. Switch to 120Hz (VRR)
  6. Attempt to play audio again → No sound

1st log archive after performing the steps above: nvidia-bug-report_broken.log.gz (395.9 KB)

However, while testing, I noticed something strange: if I leave out step 4 above (ie. leave audio playing when switching from 60Hz to 120Hz), then HDMI audio will continue to function. (The audio freezes, but it will work fine after pause/unpause.) It stays working until the next reboot or resolution/refresh rate change.

2nd log archive (leaving audio running when switching refresh rates): nvidia-bug-report_working.log.gz (470.6 KB)

To confirm that this is not a hardware issue, I tested the same setup in Windows 10 21H1 and could not reproduce the problem there. Is this a known issue with the Linux driver?


Hardware:

  • GPU: Nvidia RTX 3090 (EVGA FTW3)
  • Monitor: LG C1 48" (connected via HDMI 2.1 cable)

Software:

  • OS: Arch Linux (also reproduced in Fedora 34)
  • Kernel: 5.13.4
  • Nvidia driver: 470.57.02
  • Xorg: 1.20.12
  • Desktop: KDE Plasma 5.22.3
2 Likes

It seems like this issue is not related to VRR. I can reproduce the exact same issue on KDE Plasma Wayland with 60Hz vs 120Hz fixed frame rates.

Same issue over here. 3090 + LG C9, no audio with 100 or 120Hz even If I skip step 4, I get no audio

Can confirm the same. Any refresh rate, higher than 60 Hz, causes audio over HDMI to stop working.
HW: 3080 + LG C9.

I have filed a bug 200761422 internally for tracking purpose.
Shall try to duplicate issue locally which helps in debugging issue quickly.

3 Likes

i got the same issue both on my 3080 and 3080ti
actually i can fix this on 3080 by installing old driver
but i installed the oldest driver for 3080ti on nvidia website, issue still exist
TV:Sony X90h

I also have the same issue.

I’d really love to be able to use the 120hz feature. It is one of the reasons this display was so expensive.

issue still exist with latest driver 472.12
is nvidia gonna ignore it?

Seams to be fixed with 470.74 but g-sync no longer works… c’mon…

EDIT: And nope… back to 465. I have audio drop outs.

Hi All,
Please try with latest driver release 470.74 and share test results.

With 470.74 we lose gync. Audio “works”, i say in quotes because over here I have audio drop outs. I had to go back to latest driver 465.

Thanks for the reply. With 470.74, I had to disable gsync on my LG C1 to be able to get visual output in X11, but it seems that the audio behavior remains unchanged.

Hi, same problems here… tried to install latest drivers (472.12), play in 4K/120hz Gsync activated on a LG CX with a 3080Ti and sound drop out after 5-15 minutes of gaming… Try to switch on 100Hz on nvidia control panel, back to the game, sound came back but game crash after 2-3 minutes…
(I’ve sound on my receiver with cloning screen on it)
Thanks

Sorry, didn’t read the categories but i’m on Windows 10…

I’d like to report that I’m experiencing the same issue with 470.63 on Manjaro. With a 60 Hz refresh rate, audio works via HDMI. But as soon as I change the refresh rate to 120Hz and/or enable G-Sync, I lose HDMI audio. Note that the HDMI audio device still appears as an audio device. It just doesn’t play any audio.

Using 470.74 in Fedora 34. Works if I boot with kernel version 5.13.19-200. Doesn’t if a boot with 5.14.9-200. With the later version, GNOME shows no audio devices internal to my laptop; in or out. I have my display running at 60Hz.

Audio is fine in both cases for my Bluetooth headsets.

Same issue: Upon boot, no audio out on HDMI.

Driver Version: 470.74
Resolution: 3840x2160 - 120Hz

FIX:
I target HDMI as my default audio out. Drop my Refresh Rate to 60hz. HDMI audio kicks in. I then change my refresh rate back to 120hz.
If it does not work, I sometimes have to set default audio out so something else and then back to HDMI again. Then repeat the refresh rate change.

496.13 driver issue exist

beta driver 495.29.05 seams to be working ok, audio and g-sync.

EDIT: Unfortunately audio not working consistently. Sometimes it works, others it doesn’t. Have to change to 60hz and back to 120hz…
EDIT2: And nope… back to 465. I have audio drop outs.

(Please fix this) ^ 2…

No luck for me on 459.29.05 unfortunately. Same setup as original post: 3090 + LG C1.

Logs:

Under windows I also have audio drop outs funny enough at 60hz, 120hz seam ok with these latest drivers. Downgrading hdaudio to version 1.3.38.40 from 465.89 fixes them. Any way to only downgrade audio driver under linux ?

EDIT: The no audio issue at 120hz also exist under windows. My audio drop outs under linux seam to go away with kernel paramenter “pcie_port_pm=off”. Only issue now is the 60Hz to 120Hz no audio