Audio problems with the 415.18 drivers

Customer support said I should come here for help.

When upgrading from 410.73 to 415.18 my previous audio issue returned, audio over HDMI doesn’t work with the new drivers.

Currently writing the current post on the “undetected monitor”, so it obviously works, hence the driver bug. Fedora 29.

Monitor and adapter:

  1. Samsung T27A550, nvidia x server settings reports SMT27A550
  2. It goes through a “38-6399 VE724” displayport to hdmi adapter.

Relevant threads in the support system:
181125-000153
170913-000108
170727-000137
nvidia-bug-report.log.gz (71.3 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Uploaded the packed log file, and added it to the first post

Please check if you’re suffering from the same bug and the same workaround works as here:
https://devtalk.nvidia.com/default/topic/1036976/linux/kernel-4-17-2-alsa-issue-hdmi-audio-dead/

Workaround doesn’t work

Forgot, please install acpid and check.

Check what? Acpid -d doesn’t return anything, acpid -f just stalls forever.

Lol, sorry, the nvidia driver was complaining about a missing acpid so you should just install it, reboot and then check if audio is detected.

Already tried that with no result.

Any other ideas? Don’t really want to wait several months again to get my audio back.

Not really.
Which was the last driver where audio worked, does that still work?
Why are you using that DP2HDMI dongle, does audio work if you connect it to an HDMI output or does that card not have an HDMI out?

Card doesn’t have any HDMI outputs, only displayports and DVI. 410.73 worked, just seems like it got removed from the repository, so downgrading with the package manager doesn’t seems like an alternative :-(

You could check if the kernel parameter

nvidia-drm.modeset=1

helps.

sudo cat /sys/module/nvidia_drm/parameters/modeset

should return ‘Y’ after reboot if done right. Might make GDM freak out.

Tried enabling that, removes the plymouth bootscreen, no effect on the audio. I find it rather amusing that the computer claims that the screen I’m viewing on is unplugged.

Exactly same symptoms for me as well. No audio. No ELD information.
Worked for me at 4.18 + 39X (could not remember now). Does not work on 4.19.5 + 415.22

I’m using nvhda module to activate PCIe function for audio.

Could found this suspicious log in the dmesg:
[ 41.202159] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 0

nvidia-bug-report.log.gz (1.03 MB)

There is the same issue with 415.25. No sound passing through HDMI. This was working with 410.78 version of the drivers.

Same problem for me since 415.x, 410.x works fine. Too bad, Kernel 4.20.x needs 415.x. Pavucontrol sees all of my HDMI audio outputs but states them all as “unplugged”. This seems to be the problem.

cat /proc/asound/card0/eld* 
monitor_present		0
eld_valid		0
monitor_present		0
eld_valid		0

and

cat /proc/asound/card1/eld* 
monitor_present		0
eld_valid		0
monitor_present		0
eld_valid		0
monitor_present		0
eld_valid		0
monitor_present		0
eld_valid		0

in dmesg:

snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 0
snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 0

Nvidia 415.27 with kernel 4.20.3 on Fedora 29, same problem.

Same as #17 on 4.20.3-1-MANJARO NVIDIA-SMI 415.27. Can’t route audio through HDMI, as output is considered “unavailable”.

Same problem with 4.20.11-arch2-1-ARCH, nvidia 418.43. Used to work with driver 390, but after updating it just goes to a blank screen now.