For at least the 3rd linux my audio stopped working after upgrading my nvidia drivers

This is getting absolutely ridiculous.
I have an Intel integrated GPU which runs my Dell monitor with built in speakers.
I also have a 4090 which I only use for AI. It does not and should not touch my monitory or audio.
When an Ubuntu version change appeared 5.17->5.19 I had to reinstall my NVidia drivers.

And, once again my monitor is displaying my desktop but I have no audio. The Ubuntu settings do show that the HDMI device is selected for the Audio but no sounds occur when I click test. So the audio device is being seen but I have no sound. I have checked every source of mute that might be in play, monitory mute, ubuntu system mute, and browser mute.

inxi -A
Device-1: Intel driver: snd_hda_intel
Device-2: NVIDIA driver: snd_hda_intel
Sound Server-1: ALSA v: k5.19.0-41-generic running: yes
Sound Server-2: PulseAudio v: 15.99.1 running: yes
Sound Server-3: PipeWire v: 0.3.48 running: yes

How can I fix this?

Can you please run sudo and attach the bug report log? I’m also curious to see what the output of

grep . /proc/asound/card*/id /proc/asound/card*/eld*

is. The driver doesn’t really know much about the sound system. It just forwards information about which display devices are active to the hardware and then the audio driver forwards that information to Pulseaudio (or whatever other audio system you’re using if you disabled Pulse).

When you say HDMI is selected for audio, are you sure it’s the one on the Intel GPU and not a fake output that’s enabled on the NVIDIA GPU?

I appreciate any help. You might need a little patience with me as things even got worse after I tried to fix the problem and couldn’t even boot my 5.19 kernel and although my 5.17 kernel boots I get a driver/tools mismatch with it. I was busy all day chatting about ChatGPT and other technical things but without my 4090 working I couldn’t experiment with code.

I tried to clean up my apt fix-broken mess due to the fact I kept getting ‘apt update’ errors related to nvidia stuff. After that I discovered when I rebooted that my system didn’t come up. However, it might be a problem I’ve seen before where if NVIDIA tries to take over the graphics your screen goes black because the monitor is plugged into my Intel integrated GPU. IMO, if I ask to install the NVidia drivers to give me access to the GPU it should ONLY do that by default and leave my display setup alone. If I make the decision to configure my 4090 for my display I’ll do that. I think that I have to pass “–no-opengl” to prevent it from just installing drivers and perhaps tools.
However, if I go back into 5.19 standalone diagnostic boot and try to reinstall the driver again and making sure I say no-opengl files the install fails saying “unable to load nvidia-drm” and telling me to see /var/log/nvidia-installer.log and what does it say there: Please see /var/log/nvidia-installer.log. How absurd.

I think I’ve seen the drm problem before and it gives the same dumb error message which “could” but doesn’t say what the obvious problem is. But I can’t remember that the “really” error is. It just says it can’t load the module named “off” when trying to load nvidia_drm. Bingo! I remember. It is the silly “alias nvidia-drm off” preventing the module from loading.
Why on earth don’t you use “alias nvidia-drm ‘nvidia-drm blacklisted. Please do xxx to enable’”. The existing error is useless.

I would need to go offline to run the bug report on single user 5.19. However here is the hardware info:
grep . /proc/asound/card*/id /proc/asound/card*/eld*
/proc/asound/card1/eld#0.0:monitor_present 0
/proc/asound/card1/eld#0.0:eld_valid 0
/proc/asound/card1/eld#0.1:monitor_present 0
/proc/asound/card1/eld#0.1:eld_valid 0
/proc/asound/card1/eld#0.2:monitor_present 0
/proc/asound/card1/eld#0.2:eld_valid 0
/proc/asound/card1/eld#0.3:monitor_present 0
/proc/asound/card1/eld#0.3:eld_valid 0

Sorry for the long reply.

Please help. Just got back from vacation and still no hdmi audio. My Ubuntu sound setting show that the hdmi output is selected.

If I google I find so many people reporting audio problems associated with upgrading nvidia drivers.

I have one theory but don’t know how to fix it.
lspci -v | grep -A7 -i “audio”
shows both of these
00:1f.3 Audio device: Intel Corporation Device 7a50 (rev 11)
DeviceName: Intel HD Audio
01:00.1 Audio device: NVIDIA Corporation Device 22ba (rev a1)
Subsystem: PNY Device 13ad

Both of them have “Kernel driver in use: snd_hda_intel”

Is it possible that the fact that both audio devices exist and are using the same intel kernel driver causing the nvidia 01:00.1 device hiding the Intel device where the actual cable connect to the monitor/speakers?

Can I disable 01:00.1 if it is purely an Audio device which isn’t in use?

Also, if it helps:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: Generic Analog [Generic Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: Generic Digital [Generic Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0


Never mind. I got my audio back after hours and days of trying. I’m about 80% sure that the following change to /etc/modprobe.d/alsa-base.conf
fixed the problem. I found that the last line of this file was:

options snd-hda-intel model=generic

There are two audio devices that snd-hda-intel can use: idx=0(intel) and idx=1(Nvidia)
If I change that line to:

options snd-hda-intel index=0

and reboot my audio works. Given that this was the last line in this file of 45 lines makes me wonder if this was appended as the last change to the file and it was the nvidia driver install that did that. I’d have to do another driver install just to confirm.

My 4090 is a “GPU”. The fact is independent from the fact that it “can” also run a monitor and audio. I installed a “GPU DRIVER”. Why it thinks it has a right to steal away the audio from my intel onboard integrated GPU is suspect and annoying if this turns out to be the case. There was an NVidia driver before that I had configured as I wanted. Replacing it with a newer NVidia should not break my setup. No where did I ask for this. Consider this a “conditional complaint” depending on whether this really was the cause or some low probability thing just happened at about the same time. Considering this happened the last time makes me wonder. Even though I’m not being paid I almost feel like taking the risk to confirm just so I can really complain. But I can now listen to music while experimenting with AI now so all is good.

The .run package installer doesn’t touch that file, or really do anything related to audio. Your earlier reply with the eld* files shows that none of them are reported as connected, so they should have been ignored by your audio system.

I’m not sure what model=generic does exactly in snd-hda-intel but it sounds like a workaround for some other problem. Setting index=0 sounds like it will just disable audio on the NVIDIA device completely. It sounds like that’s fine for your use case but I’m kind of curious whether just removing the options snd-hda-intel line completely would make both audio devices work properly.

I also don’t know what model=generic means. I haven’t tried deleting the line. The audio isn’t needed for the NVidia because there is nothing plugged into the GPU. It is purely for AI.

Somewhere I saw a post on ask ubuntu or stackoverflow about audio not working and a comment said there were something like 500 posts about the audio getting broken. I’m sure I’ve seen a number of other complains over years which relate them to NVidia driver install. I don’t know how many of the 500 are about that. Without drilling down further when I Google “ubuntu on board audio stopped working after nvidia driver update” I see some hits that seem to directly blame NVidia driver upgrade/install.

But all is good for me now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.