Upgrade driver, audio stops working AGAIN

I have no idea if this is the right category. There are too many.

My monitor is plugged into my Intel GPU Integrated with the CPU. My 4090 is for doing inference and learning. Today when upgrading my cuda to 12 and my driver to 525.60.13 and rebooting my audio stopped working. My NVidia is to be used for AI. There is NOTHING plugged into it. Why does it keep thinking it owns the display and audio? This has happened twice to me. At least it didn’t mess with my screen this time and make it go black. Perhaps telling it no-opengl helped???

One is either playing games THROUGH the nvidia, doing AI or both. I am ONLY doing AI. Why do these tools keep messing up the rest of my system which have nothing to do with it?

I did the install with: sudo sh cuda_12.0.0_525.60.13_linux.run
and deselected the drm and opengl stuff.

I just tried “sudo prime-select intel” which I saw somewhere and that didn’t fix the problem.

After this before sleeping I rebooted and the audio worked.
Got to sleep and boot in morning and now:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Rebooted and it didn’t help. Why can’t I get a stable setup with NVidia?

Egads, prime-select appears to have blacklisted the nvidia driver. Would someone explain why telling the system to use my Intel GPU (FOR THE GRAPHICS) has anything to do with using the NVIDIA 4090 for OTHER purposes?

Saying to use the Intel to drive my monitor has absolutely nothing to do with whether I want to do AI or not.

Hi @hexexpert5 ,
I believe Linux - NVIDIA Developer Forums should be the right forum to get better support.


1 Like