no HDMI sound / no nVidia sound card found

(Arch Linux, nVidia 378.13-5, Kernel 4.10.9-1)

I’ve been having problems getting sound to play through HDMI.

I’ve got the proprietary nVidia drivers installed from the Arch repos.

I’m also using pulseaudio for my sound. I’ve tried to load the kernel module snd_hda_codec_hdmi however it fails to actually load the module with the error “systemd-modules-load[285]: libkmod: kmod_config_parse: /lib/modprobe.d/nvidia.conf line 2: ignoring bad line starting with ‘snd_hda_codec_hdmi’”

Looking at the device manager in Windows it shows a graphics driver and a virtual audio device driver for nVidia but I don’t know how to load or see the virtual device (if this is even possible in linux)

Thanks for any help and/or direction.

the following are outputs of what I see on my system.

lspci -k | grep -A 2 -E "(VGA|3D)"
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060] (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device 1580
	Kernel driver in use: nvidia
cat /proc/asound/cards                                                                                
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xda128000 irq 124
aplay -L 
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
    HDA Intel PCH, ALC255 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC255 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

nvidia-bug-report.log.gz (110 KB)

It seems we might be having the same issue. Did you ever find a solution for it? https://devtalk.nvidia.com/default/topic/1024022/linux/gtx-1060-no-audio-over-hdmi-only-hda-intel-detected-azalia/

No, I actually haven’t found a solution to this. Nvidia did release a couple of new updates in between now and then and that has fixes a lot of the other issues I was having like my fn keys not working, the keyboard backlight not working, and screen brightness. but as for the hdmi sound… I’m still showing the same results as above.

One thing I had to do to get my other issues working is in my bootloader I had to add an option for nvidia to use vga1 instead of vga0. My bootloader conf options looks like this: (acpi_backlight=video sets nvidia on vga1)

nvidia-drm.modeset=1 acpi_backlight=video idle=nomwait

but I haven’t tried anything else for the hdmi since their updates have been pushed out.

have you found a solution?

This bug has been around really long, as a reference:
https://devtalk.nvidia.com/default/topic/609790/linux/no-hdmi-sound-w-optimus-in-linux/1
https://bugs.freedesktop.org/show_bug.cgi?id=75985

Does in your case the audio device show up when you use
lspci -H1
Does a suspend/resume cycle make the audio device show up?

In my situation, there is no new audio device showing when the HDMI cable is connected. I tried probing for hardware changes and then lspci -H1 but that doesn’t show any other audio devices as mentioned in the link.

Thanks for the reply generix

but the lspci -H1 doesn’t show any new audio devices. The only one that I can see is

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)

which I’m guessing is for the 3.5mm headphone jack. the only thing related to the graphics card is for VGA

I still haven’t been able to find an answer for this. Still on the look out though haha!

Thank you guys!

You missed the workaround:
https://devtalk.nvidia.com/default/topic/1024022/linux/gtx-1060-no-audio-over-hdmi-only-hda-intel-detected-azalia/post/5211273/#5211273

dude!!! that took some tinkering to get to work on my system

I’m able to see all the hdmi sound outputs!

unfortunately I’m not able to route sound through them but at least its a step in the right direction!

Thank you SOOO much generix!

I guess i have a quite Similar Probelem, i can see the NVIDIA Device but it tells me in pavucontrol that the Monitor is not Plugged in but it is:

marc@debian:~/nvhda$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 0/1
Subdevice #0: subdevice #0

I have A Predator Helios 300 with a GTX 1050 Ti.

With kind regards
Marc

Ubuntu 18.04
Linux debian 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:44:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux