[515.48.07] gamescope window freezes in fullscreen

When I run gamescope in fullscreen or make it fullscreen after I launch it in window mode, it freezes the whole screen and I have to kill it. The second screen is not affected. Unfortunately there is no error message by gamescope nor a kernel error from the driver.

I’m able to reproduce it on Cinnamon and Plasma.

This is how it looks for me:

OS: Arch Linux
GPU: GTX 1080
Driver: 515.48.07
gamescope: current git ( b1c3859)
nvidia-bug-report.log.gz (1.6 MB)

2 Likes

As a temporary workaround you have to start the application in fullscreen mode, but then you won’t be able to go back to windowed so yeah… Furthermore I notice weird frame fluctuation on some games using gamescope.

I can not start it in fullscreen, as described in my initial post. It shows the exact same behaviour. The only way I can use it at the moment is either in window or borderless.

This issue still occurs with 515.57.

Can confirm that this issue does affect Cinnamon, for Plasma on both Xorg and Wayland I am unable to reproduce it.

Hi All,
Can you please try with older driver version to confirm if this is indeed a driver regression.
Also just wanted to check if freeze issue happens with Cinnamon or any other desktop environment also ?

Older driver versions are no option, as gamescope only started to work with 515.48.07 on Nvidia. I’ve tried all stable versions since then, including the latest Beta 525.53, and it happens with all of them.

I have no other DE installed at the moment.

From my testing it happens only with Cinnamon so far(others I’ve tried are KDE Plasma under Xorg and Wayland, as well as Gnome Wayland). It seems to not be driver affected from all 515.48.07 till the beta 525.53 including.

kde wayland? with nvidia? how? for me fails initialization (log later, 'im now in xorg)

Works ootb, never had issues with it though I moved on to cinnamon due to kde specific quirks.

No CAP_SYS_NICE, falling back to regular-priority compute and threads.
Performance will be affected.
wlserver: [backend/headless/backend.c:82] Creating headless backend
vulkan: selecting physical device 'NVIDIA GeForce GTX 1070 Ti': queue family 2
vulkan: physical device supports DRM format modifiers
vulkan: vkGetPhysicalDeviceFormatProperties2 returned zero modifiers for DRM format 0x3231564E (VkResult: 0)
vulkan: supported DRM formats for sampling usage:
vulkan:   0x34325241
vulkan:   0x34325258
vulkan: physical device queue doesn't support presenting on our surface
vulkan_make_output failed
Violación de segmento (`core' generado)

this is my output in my kde over wayland, launched with this command:

└───╼  cat /usr/bin/startwayland 
#! /usr/bin/bash
KWIN_DRM_USE_MODIFIERS=1 \
SDL_VIDEODRIVER=wayland \
QT_QPA_PLATFORM=wayland \
XDG_SESSION_TYPE=wayland \
__GLX_VENDOR_LIBRARY_NAME=nvidia \
MOZ_ENABLE_WAYLAND=1 \
MOZ_X11_EGL=1 \
WLR_RENDERER=gles2 \
/usr/lib/plasma-dbus-run-session-if-needed /usr/bin/startplasma-wayland

gamescope 3.11.48 and 3.11.48.r11.g2791466