[515.48.07] gamescope window freezes in fullscreen

When I run gamescope in fullscreen or make it fullscreen after I launch it in window mode, it freezes the whole screen and I have to kill it. The second screen is not affected. Unfortunately there is no error message by gamescope nor a kernel error from the driver.

I’m able to reproduce it on Cinnamon and Plasma.

This is how it looks for me:

OS: Arch Linux
GPU: GTX 1080
Driver: 515.48.07
gamescope: current git ( b1c3859)
nvidia-bug-report.log.gz (1.6 MB)


As a temporary workaround you have to start the application in fullscreen mode, but then you won’t be able to go back to windowed so yeah… Furthermore I notice weird frame fluctuation on some games using gamescope.

I can not start it in fullscreen, as described in my initial post. It shows the exact same behaviour. The only way I can use it at the moment is either in window or borderless.

This issue still occurs with 515.57.

Can confirm that this issue does affect Cinnamon, for Plasma on both Xorg and Wayland I am unable to reproduce it.

Hi All,
Can you please try with older driver version to confirm if this is indeed a driver regression.
Also just wanted to check if freeze issue happens with Cinnamon or any other desktop environment also ?

Older driver versions are no option, as gamescope only started to work with 515.48.07 on Nvidia. I’ve tried all stable versions since then, including the latest Beta 525.53, and it happens with all of them.

I have no other DE installed at the moment.

From my testing it happens only with Cinnamon so far(others I’ve tried are KDE Plasma under Xorg and Wayland, as well as Gnome Wayland). It seems to not be driver affected from all 515.48.07 till the beta 525.53 including.

kde wayland? with nvidia? how? for me fails initialization (log later, 'im now in xorg)

Works ootb, never had issues with it though I moved on to cinnamon due to kde specific quirks.

No CAP_SYS_NICE, falling back to regular-priority compute and threads.
Performance will be affected.
wlserver: [backend/headless/backend.c:82] Creating headless backend
vulkan: selecting physical device 'NVIDIA GeForce GTX 1070 Ti': queue family 2
vulkan: physical device supports DRM format modifiers
vulkan: vkGetPhysicalDeviceFormatProperties2 returned zero modifiers for DRM format 0x3231564E (VkResult: 0)
vulkan: supported DRM formats for sampling usage:
vulkan:   0x34325241
vulkan:   0x34325258
vulkan: physical device queue doesn't support presenting on our surface
vulkan_make_output failed
Violación de segmento (`core' generado)

this is my output in my kde over wayland, launched with this command:

└───╼  cat /usr/bin/startwayland 
#! /usr/bin/bash
MOZ_X11_EGL=1 \
/usr/lib/plasma-dbus-run-session-if-needed /usr/bin/startplasma-wayland

gamescope 3.11.48 and 3.11.48.r11.g2791466

can’t get gamescope to work with steam and will work only sometimes via gamescope – glxgears from terminal @amrits

Is there any error message ? Have you tried launching steam through terminal and then setting gamescope for the game, checking if terminal indicates an issue ? Have you tried setting gamescope to windowed or borderless, not just fullscreen ? Additionally which is the Desktop Environment/Distro which you use ? I haven’t had problems running it across - Cinnamon(though fullscreen doesn’t work there), Gnome and KDE(for Gnome & KDE I got much better results in wayland than x11)

Does it work if you launch gamescope with the -f arg?
I’ve never been able to get gamescope to work properly on Cinnamon, always random crashes, freezes etc.

This is a known bug with NVIDIA cards, and neither NVIDIA or Steam devs have took a real look at this issue…

1 Like

Hi, thanks for the reply.

Last time I tried on cinnamon with the -f arg still didn’t work, but windowed or borderless did indeed work.
On KDE Plasma gamescope has been running just fine, however I did notice gamescope running more consistent on a wayland session.
Unfortunately due to some nvidia and some not nvidia related wayland quirks, I’ve fallen back to xorg for the time being.

Same issue here on OpenSuse Leap 15.5 with Gnome DE and X11 plus Flatpak Steam and Gamescope. Nvidia driver: 535.113. Can’t do fullscreen with Gamescope, it just freezes the game and has to be force quit. Launching the game in windowed mode works, but is not ideal because the window is too small. This still hasn’t been fixed yet, I assume? Edit / Update: Works “ok” with Wayland, fullscreen works under Wayland, but I do notice performance issues (fps dips) when using Gamescope under Wayland in fullscreen.

Finally something new to bring here after months!

I’ve filed internal bug 4330963 to track investigation within NVIDIA.