545.29.02 ghosting/artifacting/stuttering on fullscreen when below monitor framerate

Hi! I have this issue on Wayland when fullscreen gaming (wayland) and the game’s fps are below the screen refresh rate. Doesn’t seem to be related to vrr, no changes with it active, disabled, turned off in the monitor itself…
For example, if the screen is set to 144 and the game stays at 80, there is very noticeable ghosting/tearing/artifacting (fullscreen and borderless) but it is fine if playing windowed.
If I set the screen at 60 frames, then there is no stutter/ghosting on fullscreen.
I tried to record a video, switching fullscreen/borderless and windowed, and it is noticeable, but is much worse on site, you can find it here: https://www.youtube.com/watch?v=Cum9w3NtQVA (look at the fence, for example)
This didn’t happen at all on 535.
It looks a bit like: 545.29.02 Wayland, synchronization issues with framerates below screen refresh rate but for me the framepacing on mangohud looks ok (not so what’s happening in the screen)
Operating System: EndeavourOS
KDE Plasma Version: 5.27.9
KDE Frameworks Version: 5.111.0
Qt Version: 5.15.11
Kernel Version: 6.5.9-zen2-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 5600X 6-Core Processor
Memory: 31,3 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3080/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: X570 AORUS PRO
System Version: -CF.
nvidia-bug-report.log.gz (1.0 MB)


Yep, I also have this issue, it is reproducible in all games and even videos played through vlc in fullscreen where it sometimes could just flicker, thought it was VRR since it has shown similar symptoms, but it is apparent that it’s also affecting the general wayland desktop experience, just reverted back to 535 and the issues previously mentioned are gone, hope that nvidia just releases a hot fix since the state of these new drivers are unacceptable.


I also have artifacts in all games, vertical black stripes, I had to roll back to the previous version.

I managed to fix this issue by unplugging/disabling all other monitors and only keeping one. Not ideal but it’s a workaround.

This can also be fixed by enabling tearing support if your compositor supports it

I have a single monitor setup with tearing enabled and I still encountered the issue.
Best workaround is just reverting the driver version.

This also started affecting native wayland applications(at least on KDE Plasma), so it isn’t limited to just xwayland anymore.
Perhaps it needs to be checked.

can someone check if it’s fixed in .06? I’m too lazy to downgrade again if it’s not lol

It hasn’t been resolved, but I feel like that something was changed and is gearing more towards explicit sync now(which unfortunately still is a bit of a long way to go).

1 Like

Just wanted to make a small update here, even when installing xorg-xwayland with explicit sync(which includes wayland-protocols explicit sync and xorgproto explicit sync patched in) - some apps still have flickering and as of 545 update, the main wayland desktop on KDE Plasma has this ghosting/out of order frames/ going forward/backwards as well as on native wayland apps.


As per 545.29.02 Wayland, synchronization issues with framerates below screen refresh rate using Xorg is a workaround

I’m seeing the same issue will provide some details below.

  • Issue present on driver version “545.29.06-7” (tested driver packages nvidia-open and nvidia-dkms)
  • Issue not present on driver version “535” (nvidia-dkms)

Steps to replicate the issue

  1. Open game “Against the Storm” via steam launcher
  2. Attempt to right-click and pan around the map

Description of issue

Flickering/jankiness of rendering consistent with what other people in this thread have described.
It looks like there is a delay in frames being rendered or frames are being rendered in the wrong order or something odd like that.

I tried to record a video of the issue but the issue is not clear in the recording / probably because the recording frame rate is much lower than the monitor refresh rate.

Environment setup

  • OS: Arch linux
  • Window manager: Hyprland (can also replicate the bug using Gnome on Wayland)
  • GPU: NVIDIA Corporation GA104 [GeForce RTX 3060 Ti Lite Hash Rate] (rev a1)
  • Nvidia driver version “545.29.06-7” (either nvidia-dkms or nvidia-open; both have this problem)
  • VRR on/off doesn’t matter - issue present either way
  • Monitors (see below)
    – Game running on monitor DP-2 which has 165Hz refresh rate
    – Game runs ~90fps according to Steam FPS overlay
$ hyprctl monitors all
Monitor DP-2 (ID 0):
        2560x1440@164.99899 at 0x0
        description: Acer Technologies XB273U TJ5SA0018521 (DP-2)
        make: Acer Technologies
        model: XB273U
        serial: TJ5SA0018521
        active workspace: 1 (1)
        special workspace: 0 ()
        reserved: 0 42 0 0
        scale: 1.00
        transform: 0
        focused: yes
        dpmsStatus: 1
        vrr: 1
        activelyTearing: false

Monitor DP-3 (ID 1):
        1920x1080@143.85500 at 2560x0
        description: Acer Technologies VG270 S 0x11324791 (DP-3)
        make: Acer Technologies
        model: VG270 S
        serial: 0x11324791
        active workspace: 9 (9)
        special workspace: 0 ()
        reserved: 0 40 0 0
        scale: 1.00
        transform: 0
        focused: no
        dpmsStatus: 1
        vrr: 0
        activelyTearing: false

Additional notes

  • Issue seems to only affect Wayland based desktops and was not present in X11
  • Issue is unaffected by toggling VRR on/off
  • Tried reverting to driver version 535 and this fixed the issue making me think the issue is in the 545 driver
  • Issue is present in other games too
1 Like

Any updates on if this is being looked into?
This is a particularly glaring issue for fighting games since the majority of them run at 60fps.

I also face this issue since the 545.29 driver update on Manjaro.

Nvidia Driver: 545.29.06
Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.113.0
Qt Version: 5.15.11
Kernel Version: 6.6.8-2-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 3800X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2

I could mitigate the problem by setting the refresh rate of the monitor down to the fps rate of the game, like in my Batman Arham Knight video example: https://www.youtube.com/watch?v=Y6WvvLK9QPI
It also seems that if you use a controller the problem doesn’t show up, like in my Baldur’s Gate 3 video.
When switched back to Mouse and Keyboard the artifacts and stutter show up again: https://www.youtube.com/watch?v=RI1aPoE9CgE

550.40.07 beta series is out, affected people might want to recheck if it is still there.

Here’s a heavily edited changelog because the current one is total mess with changelogs from at least the two previous driver releases and missing spaces in every other sentence.

I am unfortunately not seeing a direct reference to this bug being fixed there, the only thing about flickering is related to entire VRR displays, which may or may not be completely irrelevant, but it sure seems to be.

* Fixed an issue that sometimes caused Wayland applications to run at less than one frame per second on Maxwell, Volta, and Pascal series GPUs.
* Fixed a bug that caused an intermittent drop in desktop framerate.
* Fixed a bug that caused "Flip event timeout" messages to be printed to the system log when displays are hotplugged when nvidia-drm is loaded with the`fbdev=1` kernel module parameter.
* Fixed intermittent Xid errors on Horizon Zero Dawn, Metro Exodus, Forza Horizon 5, and Halo Infinite.
* Fixed a bug which prevented the "NoMaxPClkCheck" mode validation token from working on single-link TMDS (e.g. DVI, HDMI) outputs.
* Fixed a bug that allowed VRR displays to be driven below their minimum refresh rate, resulting in a blank or flickering image.
* Added an application profile to improve Kwin performance on hybrid GPU systems by setting OGL_DEDICATED_HW_STATE_PER_CONTEXT=ENABLE_ROBUST.
* Updated the build process for NVIDIA kernel modules to honor the INSTALL_MOD_DIR K build environment variable.
* Added support for R8, GR88 and YCbCr GBM formats.
* Optimized the X driver headless framerate limiter to more closely mimic upstream behavior and prevent it from activating in inconvenient situations. 
  * Added a new X config option "LimitFrameRateWhenHeadless" to disable the headless framerate limiter.
* Fixed a bug that prevented Gamescope from running when using the NVIDIAOpen GPU Kernel modules.
* Fixed a bug that prevented the installer package from being unpacked on systems where zstd is not installed, when /tmp is mounted noexec.
* Use transparent huge pages when available for the .text section. This is done through madvise() calls, and requires CONFIG_READ_ONLY_THP_FOR_FS.
1 Like

Gave it a try. Still broken. The exact same behavior on a 1080.
The system is: arch linux 6.7.1, driver 550.40.07, modeset=1 fbdev=1.
By the way fbdev=1 breaks some login managers.


same issue on gtx 1650 with

options nvidia NVreg_UsePageAttributeTable=1 NVreg_InitializeSystemMemoryAllocations=0 NVreg_DynamicPowerManagement=0x02
options nvidia_drm modeset=1 fbdev=1
blacklist iTCO_wdt
blacklist sp5100_tco

Same issue with a GTX 1080Ti on KDE Wayland, video below shows CS2 repeating frames both normally, and more so when the CPU is choked, and Rocket League having ‘Black Bars’ across the screen when limited to 30fps. My monitors refresh rate is 144hz. The 535 drivers work fine, even with the CPU under load.

Something interesting to note, the repeating frame issue in CS2 seems to at least be partially attached to mouse movement (you can kinda see it in the video). After editing, I went back to test, and with a choked CPU but a stationary mouse the problem was far less pronounced, the frames still jump backwards and there’s hitching, but it’s nowhere near as substantial. In the rocket league example, I was simply watching a replay and wasn’t using the mouse at all.

Nvidia Bug report output attached.

nvidia-bug-report.log.gz (1.5 MB)


I tried the 550 driver but, the same as yuraosipov2012 reported, it didn’t fix the issue.

I was able to fix/work around the issue by running the game using a custom build of wine 9.1.
To do this I built wine 9.1 with the --enable-wayland flag set, and then turned on the the wayland rendering engine (Wine - ArchWiki) before running the game.

I believe this aligns with what I’ve read in comments similar issues where the problems are caused by something related to XWayland (implicit vs explicit synchronization).

For me this was not a perfect solution because if I don’t launch the game through Steam the game runs without my save files so I’d lose all my game progress.
I can’t launch the game via Steam because it doesn’t use a version of wine having wayland enabled and encounters this NVIDIA driver / XWayland bug.

Yeah, same. The issue is still present on 550, even with wayland with explicit sync patches applied.

1 Like