545.29.02 Wayland, synchronization issues with framerates below screen refresh rate

Hi, I took a look at the new beta driver to see how it goes on Wayland side of things. A lot of issues that I previously had now seem fixed, so thanks for working on it!

One big problem that I noticed though is odd screen flicker/tearing that only happens when the framerate (of a game) is dipping below the screen refresh rate (60fps). I recorded a short footage showing that cp-wycinek

Apparently it doesn’t happen on other compositors (I tested Sway and the problem is not present there).

Is this already known problem expected to be fixed later, or maybe it’s some KDE specific issue? I can test this further and provide some debug info if it isn’t.
I’m on 3060Ti

EDIT: it actually also happens on Sway with HW cursor disabled and other patches (used sway-nvidia from AUR). It also sometimes happens on regular desktop/browser, not only games/fullscreen windows.

1 Like

Can confirm. Dead by Daylight, Darktide ( proton steam ), now unplayable because of that.
Hyprland ( wlroot based ).
env = __GL_VRR_ALLOWED, 1
Tried with this envs. With/without… same effect.
EDIT: Disabling VRR also not helping.
Tried Mangohud setting "vsync=1 ( Adaptive VSync (FIFO_RELAXED_KHR) ), but it makes games black/not starting at all.

Just got 545.29.02 update on ArcoLinux. Played Apex Legends in Wayland. Its unplayable. My screen is covering with black horizontal black bars. Flickering. Had to Snapshot rollback! If anyone knows how to fix, please share!

Use Xorg until Wayland supports explicit sync.

I also have a problem with 545. I got this spiked framerate line in both xorg and wayland after update. Also it reproduce (even worse) when I use my eGPU.

I think I have the same issue (your video is not available for me) or a very similar one. I posted it over here 545.29.02 ghosting/artifacting/stuttering on fullscreen when below monitor framerate
I downgraded to 535 and it all works fine.