545.29.02 ghosting/artifacting/stuttering on fullscreen when below monitor framerate

Gave it another try with 550.40.07-2 (from aur)
Kernel command in full: GRUB_CMDLINE_LINUX="rootfstype=xfs nvidia_drm.fbdev=0 nvidia-modeset.disable_vrr_mclk_switch=0 nvidia_drm.modeset=1"

Also tried it with: GRUB_CMDLINE_LINUX="rootfstype=xfs nvidia_drm.fbdev=0 nvidia-modeset.disable_vrr_mclk_switch=1 nvidia_drm.modeset=1" and with modeset before everything else (if it makes any difference).
My test is factorio steam, as it is native title and presents the issue immediately.

With all of the above the behavior is the same. Screen flickering black. Most noticeably when biters enter the scene. Tried turning off vsync in game and freesync in monitor settings. Nothing changed.
Turning on fbdev breaks my display manager (greetd) and it stops being displayed.
I’ve even tried flatpak and native steam. No changes.
Also tried purging my steam install completely (not really intended to) by deleting .var/app/com.valvesoftware.steam folder. Didn’t change anything.

tldr: No matter what I change, behavior still persists.
My setup info just in case:
Main display: 2560x1080@75hz connected with DP 1.2
Secondary: 1600x900@60hz connected with hdmi to dvi adapter (recognized as hdmi)
GPU: 1080
Wayland
Kernel: linux-zen 6.7.4 (regular kernel shows the same behavior)
If I can provide any more info, please let me know and I will gladly help. At the moment this issue is something I cannot deal with or live with, so I’m gonna have to rollback to 535 again.
On 535 everything is good.

This is a known issue with Xwayland applications and the NVIDIA driver, see xwayland glamor renders incorrectly on nvidia (#1317) · Issues · xorg / xserver · GitLab

The fix will rely on this patch for Xwayland Explicit GPU Synchronization for DRI3, Present, and Xwayland (!967) · Merge requests · xorg / xserver · GitLab which should be approved relatively soon. An NVIDIA driver update will also be required.

In the meantime I would recommend sticking with X11. Apologies for any frustration, we’re doing our best to drive the solution.

1 Like

Hi @amrits, thank you so much for your reply and acknowledgement of the issue. I would just like to ask, why did this issue never present itself for most people before 545 and 550? From what I am reading, it seems this has always been an issue, but, me and many others never experienced it until these latest driver releases.

Another thing - whatever made it like this should NEVER have been pushed to release drivers. Whatever you changed to cause this issue should not have stuck between multiple driver revisions, and should’ve been left until these pull requests were merged. I understand you said that the fixes will be approved relatively soon, but we have no idea when that is. People have waited months at this point for a working driver.

I will be sticking to version 535 drivers until this is all sorted out. Hopefully everything is resolved quickly now.

2 Likes

It’s two different bugs.

Bug with glamor on XWayland also affect driver 535, and it resolved with NVIDIA explicit-sync patches.

Bug from this topic not reproduced with driver 535, but reproduced with 545 and 550. This bug also affects on native Wayland windows too (e.g. any electron 28 window).