CS2 Stuck on Valve Logo on startup 545 beta branch

Argh, very sorry everyone, this won’t actually be fixed in the next 545 release. I was rushing to try and get the fix submitted last-minute, but I have just realized it contained an incredibly dumb mistake which I didn’t catch in my testing. Feels bad, man.

3 Likes

Scratch my last comment, I managed to sneak the correction in. So this should, in fact, be fixed in the upcoming 545 official release. Sorry for the confusion.

6 Likes

I still have this issue with 545.29.02 and wayland.

nvidia-bug-report.log.gz (2.4 MB)

Hmm, I just double-checked locally and I’m no longer seeing the hang. Note that the game does still linger for a while on the Valve logo while it compiles shaders, but eventually it shows the menu. How long did you wait before giving up?

Waited about 3 minutes or so. Under x11 dota and cs pretty much start instantly. I can try again and let it run for a while and report back but with 535 under wayland, this only ever takes a couple of seconds from the logo to mainmenu.

EDIT:
Also just from looking at CPU/GPU utilization, there is no shader compilation happining while the game hangs at the splash logo.

Oh, it looks like my fix got included in 545.29.03, but the version on our website is 545.29.02. So that explains why you’re still seeing the issue. Sorry about that, I’m not sure what went wrong.

Waited for about 10 minutes now, but it’s still stuck. Is there anything else I can provide?

Alright, nevermind then

I’ll check with our release team to try and figure out what happened. Maybe we can get the newer version (with the fix) posted. Otherwise I guess it will need to wait for the next cycle.

5 Likes

Any updates with 545.29.03 ?
Can’t wait to test it with Star Citizen + Gamescope. :-)

Will the newer driver version be updated also here ?
https://developer.download.nvidia.com/compute/cuda/repos/debian12/x86_64/
guide how to enable repo:

it says cuda - but actually nvidia-driver can also be installed without cuda from there…

Any updates on this? @ekurzinger

They’ve decided to do another release from the 545 branch which should be posted fairly soon. That release will contain a fix for the bug. Sorry about the delay.

4 Likes

how soon is fairly soon? I am also getting severe glitches in my other non-native steam games on wayland (baldur’s gate 3, quake champions, aliens fireteam, and cs2 using proton), will the bugfix fix those issues as well (it is some sort of screen tearing around the center of the screen). The other games work flawlessly in x11 using proton 7.xx. proton 8.xx and higher only works on wayland. i’m using a 3090 on an intel i-7-6950x, garuda linux, kde. i can sort of play baldur’s gate 3 on wayland using proton hotfix, but it is quite glitchy … on x11 it is far more glitchy.

The 545.29.06 release is now public and should contain a fix for the hang. The glitches are an unrelated issue blocked by https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/967

2 Likes

In 535 driver, games didn’t have out of order/glitching frames.
545 introduced this issue. I tested this patches. While it makes better, there is still games that have issues with glitching sadly.
My first thought that 545 enabled explicit sync on driver level, so that why we got flickering issues, but as you? ( i suppose ) mentioned in merge request, nvidia driver also don’t have explicit sync support. So i’m curious, what changed from 535 to 545 then, so some people have flickering issues atm? Just curious.
Mostly people report that this issue happens on Display Port.

I’ve tried to test if the other branch fixed my issues following bottom of this thread

https://www.reddit.com/r/linux_gaming/comments/182ga4y/how_to_apply_explicit_sync_patch_for_wayland_from/

The issues I’m having is strange flickering artifacts in some games and black textures and black screen in minecraft when on the new driver (using rtx 3080)

I was able to do a successful build of the m,odified wayland-protocols and then xorg-server, but it didn’t seem to solve the issues I had. This could be because I didn’t know what I was doing for sure.

This topic was specifically for CS2 bug which has been resolved in 545.29.06, there is a separate topic which was created for the broken presentation in 545 here: 545.29.02 ghosting/artifacting/stuttering on fullscreen when below monitor framerate - #9 by kodatarule

I have tried the 545 drivers lately, but I have not found solutions to my problems. I have not tried CS2, but Quake Champions was not running well, nor does it run well on 535, so as of now, I am stuck on 525 and I am willing to upgrade for the CS2 and better Wayland support. I run Ubuntu + Wayland on my GTX 1080Ti.

Here is a video showcasing the problems I had with the 545.29.02 drivers (a part of the video was also broken because of the config, by that I mean that I got 1 frame every minute out of the video): https://www.youtube.com/watch?v=3JkxqT-Ufl0

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.