980gtx: No support for 4k/60hz 4:2:0 (only 30hz)

On Windows 8.1, the drivers support full 4k 60hz at 4:2:0 sampling. However, Linux seems to be locked at 30hz at this sampling rate. It would mean a HUGE deal to me to get this working properly under Linux. Any chance of this happening?

My screen (Sony x850b) which only supports 4:2:0 sampling at the highest.

We’re working on it.

This makes my week honestly, as I wasn’t excited with the prospect of needing to buy a new screen. I know nvidia has a history of being opaque about future releases, but for the love of a dedicated fan, is it possible to know a timeframe or how many releases this is away?


This is great news! I was almost thinking about to turn Windows user because of this :)
I bought just while ago 40" 4K tv with 60hz(4:2:0) capability only for PC monitor use. I had to buy also new GPU GTX960 to replace my old GT9600. I fought couple hours to get drivers in place and picture on my new 4K.
I was so happy as the picture is better than I tought, lot of screen space etc. But then I noticed that videos and moving things jitter guite badly and I start to get diziness after few hours of monitor stearing. I’m waiting this 60hz 4:2:0 on a new driver very badly, before that I use my 4K screen only short terms and work mainly with laptop.

Erhm did you miss the newest beta release?

For me still no good. No way to catch 4k@60 using beta driver.

How are you trying it? If I understand correctly you might want to use xorg config setting: Option “ModeValidation” “NoEdidHDMI2Check”

I think you should make a bug report or at least show your current xorg logs.

Thanks tuke81, I set the beta drivers and now i can see 24 to 60Hz on Nvidia settings and when selecting 60Hz and apply, tv confirms that i have 3840x2160/60Hz. Every movement is a bit smoother and no screen flickering detected anymore.
Only one problem, it will not stay, after reboot it’s back to 30Hz every time and I need to go manually change it. Any idea how to set it permanently or automatically select 60Hz?
If i put all auto, it gives me 1080p. I have saved settings to xorg.conf. I even tried some compiz general dispaly setting refresh rate changes, no help…

Not sure about that, I think it’s more DE specific. With kde I can set default refresh rates from kdes krandr application and it keeps it over reboot.

But I’m not sure how compiz does it. If I understand correctly compiz wiki, you have to disable Detect Refresh Rate and set Refresh Rate manually from CCSM > General Options > Display Settings >.

Other way was editing file monitors.xml(at least was in the past), it should contain line with something.

cat ~/.config/monitors.xml

If non of them work you might need to try something more general i.e. make a startup script or make file called ~/.xprofile and add xrandr command to use resolution/refresh rate you wanted.

nano ~/.xprofile

and put this there and save

xrandr --output YOUR_OUTPUT --mode 3840x2160 --rate 60

Chech the right output with xrandr -q

Can you guys try 349.12, please?

ZOMG… the beta 349.12 now supports 4k/60z (4:2:0a)! HUGE THANK-YOU NVIDIA!

I’ve tested it, and my Sony 850b switches to the resolution without issue now. The driver is in beta so you will have to install it by hand or use SMXI to install.

Games seem to run fine, but I noticed that 60fps movies seem to have a slight frame stutter to them. I’ve tried disabling Sync To VBlank and Page Flipping without any effect. I’m wondering if the new 60hz support with sampling causes frame drops in the current beta driver?

I’ve attached my xorg (as a txt) as reference in case I’m missing something to improve video.
xorg.txt (2.04 KB)