Can't get 4k 60hz over HDMI 2.0

After much fighting back and forth with questionable specs, I now have everything set up with HDMI 2.0 comaptible devices and am trying to get my 2160p @ 60Hz. I’ve got an MSI GTX 950 I can see 3840x2160 59.9 show up now in xrandr, but when I try to set it to that resolution I get an error message.

xrandr --output HDMI-0 --mode 3840x2160 --rate 59.9

returns:

xrandr: Configure crtc 0 failed
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Value in failed request:  0x0
  Serial number of failed request:  53
  Current serial number in output stream:  53

Using nvidia-settings, I get:

Failed to set MetaMode (1) 'DPY-2: 3840x2160_60 +0+0' (Mode 3840x2160, id: -1) on X screen 0

Would you like to remove this MetaMode?

I’m using Ubuntu 15.04 with NVIDIA driver version 352.30. X Server version is 1.17.1. NV-Control version is 1.29.

Just Chiming in here.

I have a GTX 970 with a VIZIO M43-C1 4k 43" Monitor. Using HDMI-0 I can output to 60hz on Windows easily (whether or not it gets that as I think It’s a HDMI 1.0 cable is questionable but it runs fine.)

I also have tried

$ xrandr -q
Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 941mm x 529mm
   3840x2160     30.00*+  59.94    29.97    23.98  
   4096x2160     59.94    29.97    24.00    23.98  
   1920x1080    120.00   119.88    60.00    59.94    23.97    60.00  
   1280x720      60.00    59.94  
   720x480       59.94  
   640x480       59.94  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
$ xrandr --output HDMI-0 --mode 3840x2160 --rate 59.94
xrandr: Configure crtc 0 failed
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Value in failed request:  0x0
  Serial number of failed request:  47
  Current serial number in output stream:  47

I’m really unsure why I can’t get 60hz and why there is no hz dropdown in nvidia-settings as there is in the Windows version.

If anyone figures out how to do this I’ll be happily subscribed to this thread.

(I just got my second GTX 970 and we use Linux for work and gaming 98% of the month so it’s a pretty big deal to us to get this figured out.)

A. Is a DisplayPort 1.2 to HDMI adapter required to output 4k @ 60hz?
B. Do I also Need a HDMI 2.0 cable?
C. Is Windows nVidia Wrong that it’s outputting 60hz over my HDMI cable?

Out of curiosity, what refresh rate is it giving you on that display by default? 24hz?

Default is 30hz as indicated by the *+ in my first terminal code box.

I just tried setting to 59.4 on my new HDMI 2.0 cable to no avail. Both my EVGA GTX 970 and VIZIO M43-C1 are HDMI 2.0 and the Windows version works so I think it may be safe to say that it may be a nvidia linux driver issue.

Gonna reboot to confirm.

I’ve been pulling my hair out trying to discover the issue.

Since buying a HDMI 2.0 cable and confirming my EVGA GTX 970, and Vizio M43-C1 are both HDMI 2.0 capible I still can’t figure out why I can’t get 60hz.

I just updated to the 355.11 beta drive in Arch Linux

It seems the highest refresh rate that doesn’t give an error is 44hz in Linux.

xrandr --output HDMI-0 --mode 3840x2160 --rate 44.0

I really don’t understand why windows can do 60.0hz

(I confirmed via nvidia-settings that I can set a hz rate of 60hz @ 1080p however 120hz @ 1080p fails the same as 60hz @ 4k :)

I’ve confirmed that in both Windows nVidia Control Panel and on the Vizio TV’s System Information page that the PC and TV in fact are both operating at 4k @ 60hz.

Does this mean I have to abandon the blob to get 40 @ 60hz on Arch Linux? What a bummer that would be!

I think it’s pretty clear that the Nvidia Linux driver hasn’t implemented these sorts of high-bandwidth outputs yet… I wouldn’t tear your hair out testing different configs.

You seem to be correct, thanks for the input.

I specifically selected this monitor and card to double up and get 4k for programming at a DPI of 96 and a refresh rate I could game on at 4k (60hz)

Knowing the return date is coming close on my new GTX 970 and Vizio M43-C1 I seriously wonder if I should have bought a 390X :\ (also after leaning of the false advertising of the 970 being only 3.5GB)

I guess I can only switch to AMD or wait and hope nvidia delivers, hmm…

What does the xorg logs say(/var/log/Xorg.0.log)? Gtx970 has hdmi2.0 port and 4k@60Hz with marketed as hdmi2.0 tv:s have been supported on linux since 349.12 beta driver(in reality many of 4k TVs are just tweaked hmdi1.4 with yuv4:2:0 color space)…

You could try to add Option “ModeValidation” “HDMI-0: NoEdidHDMI2Check” to your xorg config file, if the problem is in TV’s EDID file.

Oh and if you really want help, please read this first:
https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

ps. r9-390x has no hdmi2.0 ports, so no 4k60Hz through hdmi.

Given the current state of AMD Linux drivers, you’d be waiting at least as long in that case – bit of an empty threat :)

It’s good for them to be aware of the issue though; hopefully it’s a simple fix.

Is this a tiled MST display? I think the Linux driver has some quirks with those still.

Thank you for the help - I just replaced my Vizio M43-C1 as it had a dead pixel and this time I didn’t connect it to the LAN - I just tested to see if I could get 60hz on nVidia Linux via HDMI-0 GTX 970 and sure enough it worked!

This leads me to hypothesize that VIZO for some reason in their newest firmware update did something to mess up 4k@60hz - what’s weirder though is that it works on Windows but not on Linux ? What gives.

I appologize for my deviation from forum etticate, I didn’t intend to document this far into my problem - however I thought this information would be imperative to other users experiencing similar problems on Linux.

If anyone is interested maybe the log will shed some light as to what differential there was

http://pastebin.com/j8Pugri8

Empty threat? Nah - more of a uneducated desperate hope to solve the problem as I percieved it at the time.

I have to admit the RadeonSI open source driver was temping though as it’s my understanding it integrates into AMDGPU & Mesa on Kernel 4.2 which is the version I’m running.

I don’t think it’s a tiled display as it only has 1 input.

Thanks for the response! Sorry if it seemed like we were pushing back a bit – I get a little frustrated when people complain about Linux not being pro-consumer; the whole “I guess I’ll take my money elsewhere!” mentality doesn’t really work too well for open source, and this seems to be happening more and more often lately now that Valve is (mostly doing a great job of) pushing Linux as a gaming platform. This is supposed to be a “devtalk” forum after all :)

RadeonSI is finally starting to come along well, which is great news for AMD users since Catalyst/fglrx (their equivalent closed binary driver) has been moving closer and closer to “unmaintained” territory (it’s even more CPU-bound than their famously CPU-bound Windows driver, and it breaks on a lot of newer OpenGL extensions). As happy as I am about the Mesa stack making such great progress recently – for Intel graphics, performance is about as good as Windows, and it’s open source so it works out of the box, even if most people with Intel graphics aren’t that interested in gaming performance – I think there’s at least another year to go before AMD open source drivers perform basically as well as users expect (not to keep comparing to Windows, but since that’s what all of the benchmarks &c. focus on, it would be appropriate to say “Windows parity”).

ElectricPrism, thanks for jumping in on my thread. Apparently subscribing didn’t work as I’d hoped and I haven’t received any emails notifying me of updates. I thought I’d check just in case, and was pleasantly surprised.

Could you let me know what the firmware version you have on your screen is? I use Netflix on the TV, so I had mine on the network, but I’d like to know if maybe that’s the issue. I’ll contact Vizio support I guess. I figured it was Linux and/or Nvidia, not the TV, but unfortunately, I don’t have any other HDMI 2.0 devices with which to test.