Android L update to Jetson-TK1

We have an update to use Android L on Jetson-TK1 here,

Original popular thread on Android for Jetson-TK1 is here, https://devtalk.nvidia.com/default/topic/767885/embedded-systems/android-on-jetson-tk1/16/

I had no problems in building that on my Debian Stable. Just make sure you have the dependencies installed.

The source tree took 27GB after the repo sync and 51GB after building everything. And it took 4.6 hours to build on my 3-core AMD with 8GB of memory.

This works great! The only downside is it is still Android 5.0. Any plan to upgrade to 5.1 or even Marshmallow in the future? Or is this a one time deal and we are on our own?

For others who might be interested in running Android on Jetson-tk1, I have success getting project ara’s Android 5.1 running on Jetson. The only caveat is project ara’s build has no HDMI sound output. You will need to fix up the HAL in order to get sound for HDMI.

will this build run xbmc, and youtube?

I’m guessing that this Android build does not include Google Play or Youtube app. Kodi (XBMC) most likely can be installed e.g. using the adb.

Kodi runs nicely on the Linux for Tegra as well though.

The kodi does works great on linux. I was able to install google playstore on this build and i could install kodi and youtube on this.

I already build the Android but I can’t connect to the network…
anyone can help

Hi windowsxp811203,
Can you provide some further information that what’s the failure? Is interface(ex. eth0, wlan0) up? Or DHCP failed?

Thank you for sharing this release. Does anyone know if it has SATA support (specifically for SSD additional storage)?

windowsxp811203 and glo, I believe I have the same issue. (I’ve not done too much troubleshooting yet, for root access is priority for me.)

I have been able to connect via Ethernet, but not with WiFi (I’m using an Intel Dual Band Wireless-AC 7260 WiFi Bluetooth Half Mini Card, and get no WiFi or BT).

Also, can anyone offer a tip on how to get root access with this Lollipop installation? Thanks in advance if anyone has figured this out.

So I was able to build and flash this image to my Jetson board. Ethernet is working fine, will try wifi when my card shows up, but I also wanted to know about how to get root access. I have tried several different versions of rooting meant for actual shield tablets but without success.

hello, imiforan:
If you can flash the device, just change the adbd service with root, or build an eng version, to gain root access.

br
ChenJian

Hello. Thanks for the build.

Was NOT able to flash it to jestson TK1 Pro. Is it supported?

I am in the progress of creating an aosp android tv build for the jetson and I am curious how hard would it be to use Nvidia sources and build a TV build for the jetson tk1? I like the tablet build but in my opinion a TV build is more suited for this type device ie sheild tv foster_e

Shouldnt be that hard to change some mk files for tv characteristics. permissions, overlays and atv mk files.

Any tips on how to flash this on sdcard or sata hdd? I successfully compiled it but have no idea how to put it on sdcard. I guess the HowToFlash guide on guthub is for flashing internal emmc…?

I have not worked with Android doing this, but some of the L4T details on flash card might be useful to know. eMMC is mmcblk0p1, while a flash card would be mmcblk1p1. However, this may mislead you because you’re interested in the root file system, while the boot loader is something separate and often talked about as the same thing. There are sometimes selections to name rootfs and also to name boot loader locations…they’re usually the same but they don’t have to be. Under the flash script the location refers to both boot loader and rootfs. Don’t change boot loader, just change rootfs.

In a normal TK1 flash you can use mmcblk0p1, yet boot to the SD card. Naming mmcblk1p1 would put everything on flash card, including boot loader (removing SD would make the system useless)…you might be fine under u-boot to simply add an entry to extlinux.conf and picking that boot entry (either via default setting or serial console menu) in order to leave boot loader default and load the new rootfs (SD card would be a choice, not a requirement). Look in extlinux.conf…see that “root=” argument? That’s the eMMC boot loader marking which rootfs to hand off to. Change it from mmcblk0p1 to mmcblk1p1 and the original boot loader functions to load SD card for root instead. If this is an alternate entry, you even have the original system in place as rescue or whatever you want it for. See the LABEL and MENU LABEL? This is to support multiple boot options in the serial console if you want boot time choices which are not hard coded. If the support files for android are in the eMMC (/boot), such as any firmware and kernel, then you are all set to boot to android without removing the old o/s. You basically just need to know what is required in the boot entry to run android as the boot loader hands off to it.

I’m sorry for late reply, I was very busy past few weeks. Anyway, I have right now bootloader booting sdcard by default and if I unplug it, L4T boots up. So since I have a compiled Lollipop and a system ready to boot from the sdcard, how do I prepare the sdcard?

Thanks a lot!

What do you mean prepare the sd card? Are you asking about partitioning or formatting? Or data copy? You can probably use the L4T bootloader/mkgpt or Linux gdisk to create gpt partitions, and I’m going to guess format via mkfs.ext4. For copy probably just as root cp -adpR from source to destination.

This should help you:

The file structure looks like this:

The / root/init files are in /root of build out directory building android.

and your fstab should look like this:

Look through the jedroid sources for more info in sdcard boot.

Right now I am working on SATA boot with no luck…

Checkout my sources for building an Android TV jetson build. No hdmi audio yet but I do have bluetooth and dual band wifi with the intel 7260 a custom wifi.c for wpa and bluez for bluetooth support:

So I was able to build the L for my tk1 but have not been able to figure out how to get the play store on it. I tried downloading framework services and play store apk but they just crash when installed. Any ideas?