AssertionError:Torch not compiled with CUDA enabled :trt_pose

I follow the developer community’s example “TRT_POSE”. I’m using python3.8, and when I run the example I get an error like the attached photo.

My Jetson specs are: Jetpack 5.1.1 [L4T 35.3.1]
Ubuntu 20.04 focal

CUDA : 11. 4. 315
cuDNN : 8. 6. 0. 1666
TensorRT : 8. 5. 2. 2
VPI : 2. 2. 7
Vulkan : 1. 3. 204
OpenCV : 4. 5. 4 - with CUDA : NO

This is the site I used as reference to run the example. : NVIDIA Jetson and Raspberry Pi: Xavier NX - NVIDIA AI IOT - Human Pose estimation using TensorRT

I need your help. thank you.


Please follow the below instructions to install PyTorch and TorchVision with CUDA support:


Thank you for your advice. However, I installed it via the link you provided. I have installed pytorch2.1.0. Torch Vision 0.16.1 has been installed. I keep getting the same error after that, maybe I installed it incorrectly?


Do you have multiple PyTorch or TorchVision installed?
Could you verify if the package used in python3.8 is the CUDA prebuilt (with __version__)?


Output of torch and torchvision in Python3.8. Is there anything else you need?


Could you also verify the CUDA support for PyTorch under Python3?
In case there is some compatibility issue from CUDA.

$ python3
>>> import torch
>>> torch.cuda.is_available()


hi, I brought the output result you said
jetpack version = 5.1.2 [L4T 35.4.1] CUDA version = 11.4.315
Screenshot from 2023-12-12 09-40-45

reinstalled under the same conditions. the output of the code you presented is True. still, when I did sudo python3 install --plugins, it showed up that torch was missing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.