Automatic disconnection of USB camera from Jetson Xavier NX

We have built an Intelligent Video Analytics solution on top of Jetson Xavier NX. The edge module comprises of 2 cameras (Visual & IR), touch screen and Jetson NX. Both the cameras are connected through USB to the Jetson. The system is deployed to production at various locations.

In few of the deployments, we face the issue of one of the camera (IR camera) getting disconnected from the Jetson automatically with out any external trigger such as power failure or human actions. After careful analysis, we suspect the following reasons. We would like to get guidance from the respective NVIDIA Jetson teams to resolve the issue.

Reason 1 - the dmesg logs show the following error “disabled by hub (EMI?), re-enabling…”. We have a touch screen installed along with the Jetson. Given the erratic nature of the issue, we suspect it to be Electro Magnetic interference from the touch screen but we were not able to recreate the issue in our lab setup.

Reason 2 - Following this thread “Xavier Power consumption information (Solved)”, we did a power consumption analysis and we noticed that Power In is less than Power Out by 7.4 W.

Reason 3 - USB sub-system bug in the version of JetPack used. We are using JetPack 4.6.

I’ve attached the logs screenshot for reference. Kindly help us identify the root cause at the earliest as this solution is deployed in production.

image (3)
image (2)

Raj Prasanna

It may be triggered by instable power supply. Could you try to connect to a USB hub with external power supply and then connect to the device? The system can be more stable if there is external power supply to the USb devices.

Hi DaneLLL, thanks for the recommendation. We tried with an USB hub but it did not solve the problem. Is there a way to identify the root cause?

Do you use hub like this that it can connect to an adapter to have external power supply?

Please try to upgrade to firmware 60.13 and check if it helps this use-case:
Jetson/L4T/r32.7.x patches -

[USB] New version of USB firmware: 60.13

And the latest Jetpack 4 release is 4.6.2. If possible, we would suggest upgrade from 4.6 to 4.6.2.

The external usb hubs here are just for verification on Xavier NX to avoid the 2A limitation. Which is mentioned in Jetson_Xavier_NX_DevKit_Carrier_Board_Specification_v1.0.pdf below.

2.1 USB Ports
The carrier board supports two USB Connectors. One is a USB 2.0 Micro B connector (J5) supporting Device mode only (including USB Recovery). There are two, dual stacked USB 3.0 Type A connectors (J6 and J7). Each connector supports Host mode only. A single load switch supplies VBUS to all four USB 3.0 ports and is limited to 2A of output current.

If you have confirmed the maximum current is not an issue on your custom board, and upgrading to 4.6.2 + 60.13 does not resolve the issue, we would need your help to try to reproduce the issue on Xavier NX developer kit. So that we can set up to reproduce the issue and check further.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.