USB 3 camera (ZED camera) is connecting and disconnecting!

Hi
I wired my ZED stereocamera with xavier. But I see it is connecting and disconnecting regularly in around 1-2 sec of interval.

I am watching lsusb by ‘watch -n 1 lsusb -t’. Below are the 3 instances.


In all 3 instances, USB3 cable is always plugged in.
I think it’s not camera problem because I watched the camera connected with another PC and it is connected well continuous.

And also a junk file (uvcdynctrl-udev.log) is also getting generated with time, which grows upto 13GB. (Snap attached below)
usberror

Hi,
Do you connect to type-A port on Xavier devkit? Please share dmesg and release version($ head -1 /etc/nv_tegra_release) for reference.

nvidia@jetson:~$ head -1 /etc/nv_tegra_release
# R31 (release), REVISION: 1.0, GCID: 13194883, BOARD: t186ref, EABI: aarch64, DATE: Wed Oct 31 22:26:16 UTC 2018

dmesg
https://www.codepile.net/pile/ZgAbPqnV

@jai.prakash
Are you using Usb-A port of the devkit or USB-c port?

Are you using usb hub? powered usb-hub? unpowered usb-hub?
powered usb-hub connected to usb-A port of the devkit? Unpowered usb hub connected to Usb-A port of the devkit? Powered hub conencted to USB-C port of the devkit? Unpowered hub connected to usb-c port? Usb-c to usb-A adapter? else?

Sorry, I didn’t mention.

I use exactly this
image

does the issue persist if you use usb A port? did you try both usb-c ports with the adapter or only one of the two? do you have powered or unpowered usb hub to test with?
what is your zed camera? zed? zed mini? zed2?
what sdk stereolabs version do you use? 3.2 ? else
?

USB-A, I dont know why but right know it is only supporting USB2.0

I tried both USB-C ports but same output.
I tried unpowered USB-C hub, same output.

I don’t have powered USB-C hub.

ZED camera, not mini, not zed2.
Stereolab sdk, I can check today morning. Probably I am using 1 year old version.

Can you suggest me any recommended Powered USB hub, so that I can try that too.

do you have powered usb-A 3.0 hub?
I would get the camera connected to Linux/ Windows PC to upgrade the firmware
try upgrading sdk version & camera firmware

Right now, I don’t have powered one.
But, I can buy one.

Today morning, I will upgrade the firmware and sdk.

typically, it would work without the hub at all;
does the camera work at Host PC?
at Windows PC?

Camera works well on host linux pc.

did you try executing at Jetson

sudo nvpmodel -m0
sudo jetson_clocks

in order to force the max power/performance mode? does it impact the usb connectivity issue?

Not yet.
This is new to me. I would try this too in morning.

I searched but I am not sure. Can you tell me how does a powered USB hub looks like.

Hi,
r31.1 is developer preview and not a stable release. Please upgrade to later release such as r32.4.3.