USB3 connection is detected as USB2 sometimes

I made a thread a month ago, but I decided to make a new one since the information is pretty outdated. Since then we have reboot our jetson and installed the latest jetpack version. The USB cameras are connected to the USB3 HUB.

For context we have a Jetson Xavier NX (Jetpack 4.4.1 [L4T 32.4.4]) connected with 4 cameras, 2 mipi and 2 USB, all cameras are powered externally by a power source, so I don’t think it’s an energy issue.
USB camera model: https://www.alliedvision.com/en/products/embedded-vision-cameras/detail/Alvium%201800%20U/-501m%20NIR.html
MIPI camera model: https://www.alliedvision.com/en/products/embedded-vision-cameras/detail/Alvium%201800%20C/-158.html

Here’s the real problem, with all the cameras connected we discovered that one of the USB cameras always comes up as USB3 and the other one as USB2, even if they are connected to a USB3 port. Knowing this we ran some tests that basically consisted in unplugging all other cameras and only leave plugged in one of the 2 USB cameras. To our surprise even with only 1 camera plugged in, the camera is sometimes detected as USB3, but it can also be detected as USB2, no matter the port. This does happens for both cameras. It is really inconsistent.

Has anyone experienced something similar?

Hi,
We have done compliance test for Xavier NX module + devkit, so the signal quality(eye diagram) should be good. We will try to reproduce it with the USB3 cameras we have. So the first camera can be enumerated as USB3 and the second camera is always enumerated As USB2? IS it with failure rate? Or happens everytime?

we are experiencing exactly same issue. Our camera with 30fps@6Mpx can sometimes downgrade to USB 2.0 speed. more details here: NX dev board USB 3.0 downgraded to 2.0 speed

On Jetson Nano, I’ve had this situation before.
I used USB 3.0 hub (S-LINK SL-U307W 4 PORT USB 3.0 HUB) with USB camera and HDD. USB camera worked well but HDD did not work. I searched this issue tens of sites. Then, I found a comment, which is about extra power for USB 3.0 hub, in a sales site. I’ve plugged 9V power to hub then it worked.

Does your hub support extra power-in slot?

Hi Dane, we did some quick tests and if the 2 USB cams are already plugged in, after rebooting our jetson, then 20 times out of 20 the camera 1 is enumerated as USB3 and the camera 2 as USB2. IF the 2 cams are already plugged in then I can say that it happens everytime.
Like i said the strange stuff happens when only plugging 1 camera, since sometimes is detected as USB3 or USB2. In this case I don’t have a rate.