Jetson TX2 with ZED camera

Try to use ZED camera on TX2, ZED is already updated firmware to latest, ZED SDK installed.
When opening ZED explorer, it keeps warning me with USB 3.0 device message, I mounted ZED on full size USB port.
Any one had successful experience?

Hi kevin8093,

What’s the warning message?
If you searched in “Jetson TX2” board of the forum, you can see some people succeeds in using it on TX2 DevKit.
Maybe you can contact them to get help.

The Msg is “check that the ZED is running in USB3.0”, thanks.

You can check with “lsusb -v”.

I did check the lsusb -v, the TX2 device seems to be OK, as when I connect a mass storage, it is working fine at 5000M, but when I plug ZED, it always working under 480M as USB 2.0 device.

@kevin8093: are you using TX2 DevKit carrier board?

Today, I try to flash TX2 to Jetpack 3.2 as recommended by ZED support, but still there is no luck.

What does “lsusb -t” show?

Are you using a USB3-able cable with ZED ? Your mass storage cable seems to be able to handle USB3.
No hub between ZED and Jetson full-size USB connector ?

Found https://support.stereolabs.com/hc/en-us/articles/206984359-USB-ports-not-providing-enough-power. You may try to plug in an externally powered hub.

Update on this topic:

I have the ZED camera working fine without hub (at least for 10 minutes) on TX2 with JetPack-3.2.
Installed the SDK from https://download.stereolabs.com/zedsdk/2.3/tegrax2_jp32.

The ZED may require to be the only device on the full size USB3 port for having full bandwidth.

Side note: I had previously updated ZED camera firmware from the SDK 2.2.1 on host.

Hello, I’m having a similar issue.

ZED explorer is working fine (720P 60Hz to 2K 15Hz is ok)
but when I run ZEDfu there is a warning saying
“ERROR ZED seems to be running in USB2. Cannot activate mapping”

ZED camera firmware from ZED SDK 2.4 (Windows)
Jetson TX2 with JetPack-3.2

ZED is connected direct to full-size USB connector and
lsusb -t shows

/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-tegra/3p, 5000M
|__ Port 1: Dev 2, If 0, Class=Video, Driver=uvcvideo, 5000M
|__ Port 1: Dev 2, If 1, Class=Video, Driver=uvcvideo, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-tegra/4p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
|__ Port 1: Dev 4, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
|__ Port 2: Dev 5, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M

Any one had succeed fixing this issue?

I see the problem with v2.4.0 RC3, but it seems to work fine with SDK 2.3.
Note however that my ZED camera firmware was updated with SDK 2.2.1 on host, I haven’t tried upgrading from SDK 2.4.

I have a similar problem with 1523 firmware…this firmware seems to fix some USB3 issues, but others still exist. I asked Stereo Labs about it, but have not received a reply yet.

One thing to be sure to do is to run directly off the USB3 port with no HUB or intervening hardware. Once no other device is on that port odds of working goes up.

Thank you for the advice
I tried downgrading to 1142 firmware but still the same problem
and downgrading to 922 firmware ZEDfu crash.

My ZED camera has 1142 firmware and with SDK 2.3 ZEDfu works fine on my TX2 with R28.2.
Have you installed SDK2.3 from the link above ?
Are you running L4T R28.2 ?

[s]I installed JetPack 3.2
and using ZED_SDK_Linux_JTX2_v2.3.3_JP3.2.run

$ cat /etc/nv_tegra_release
gives me

R28 (release), REVISION: 1.0

does it means L4T R28.1?[/s]

I used the utility below to check and it gives me

L4T 28.1.0 [JetPack 3.1]
Board: t186ref
Ubuntu: 16.04 LST
Kernel Version: 4.4.38-tegra
CUDA 9.0.252

will try from begin…

yes, it does

clean install and it is working now
thanks for all.

now zed seems to manage the firmwrade upgrade under linux;

However, there emerged a different question:
Presuming I am installing zed sdk to HostPC that has cuda 9.2, and the sdk seems to require 9.1 and then I am installing cuda 9.1, but I do not install the display driver and only install the toolkit and do not install the cuda symbolic link executable under the generic /usr/local/cuda,

and as a result of that I am getting sdk to throw errors… I also have only usb 2.0 ports

what could be the cause of errors?
Update:
Installation of 9.1 and adding it to path resolved the complaint from Zed regarding 9.1 requirement unsatisfied, but Zed app still doesn’t appear to run in usb 2.0 mode