jetson TX1 low bandwidth using 2 ZED Stereo Cameras

I connected 2 ZED Stereo Cameras on jetson TX1 using PCI express with 4 lanes, having 2 USB 3.0 ports. I am using sample code from ZED for using multiple ZED Cameras https://github.com/adujardin/zed-multi-input
and i receive low bandwidth error for the second camera. I tried connecting just 1 camera ( with both cameras) and it worked fine, meaning it is not due to cameras. I tried connecting both cameras to all USB 3.0 ports, and for all combinations i receive the same error low bandwidth, also tried connecting 1 camera to all USB 3.0 ports and it worked fine meaning all USB 3.0 ports are fine. I tried using 2 ZED cameras on my Desktop PC and it was running fine.

Can you please tell me why do i get low bandwidth error when using 2 cameras at the same time?

I’ve seen this too, but the StereoLabs people said they have new firmware coming out in the next few days which will probably help with this. The firmware version the camera was released with (version 922 on mine) has maybe twice the frame loss as the firmware available under firmware released in the 2.3.3 SDK (firmware version 1142).

If you go here, and then click on “Developer/Downloads” you’ll see a date at the top of the “What’s New”:
https://support.stereolabs.com/hc/en-us

Under version 2.3.3 the date shows as “2018-01-18”. I don’t know the exact date, but from what I was told the next release has to be very soon. Watch for that date to change.

Note that I did not give you the URL directly to the current release because that URL will probably remain unchanged when a new release comes out…the next release should show from the “Downloads” though.

One problem I saw was that I had to use Windows to do the firmware install. Normally this isn’t a problem, but the software refused to install until it detected CUDA 9.1…and if I just put the runtime components of 9.1 in the software still didn’t run…so I had to put the full development setup there before the install was allowed. From there ZED Explorer has an option to update firmware. My firmware was found here (I used Windows 7):

C:\Program Files (x86)\ZED SDK\firmware\ZED\

…the actual file under 2.3.3 is:

zed_fw_v1142_spi.bin

My understanding is that the program which installs firmware can run without CUDA, but unfortunately I found the program won’t allow install without CUDA. I still haven’t found a way to get it to run on Fedora (x86_64 PC) with CUDA9 and 9.1 because it is tied to outdated versions of various files (including libGLEW and libzstd). The same program runs on all Jetsons, but is unable to install firmware even if you copy the firmware file to the Jetson…you will have to do any updates specifically from Windows. You could put the 1142 firmware release in now, or just wait a few days for the next release.

Thank you for your reply. I also had a problem with installing ZED SDK with cuda 9.1
I am still using ZED SDK with cuda 9.0 on ubuntu 17.04 zesty.

When updating firmware the ZED will require running on Windows. I don’t see an update yet, but I was told it is a matter of days before the next firmware release. Right now it seems to be version 2.3.3, so presumably you can upgrade firmware in 2.3.4 soon. I did ask if there is any ability to upgrade firmware from Linux (Jetson or PC) and the answer was “no”.