ZED Camera Error -- ZED Explorer --

Hello ,

I’m using Jetson TX1 along with ZED Camera.
Configured the tx1 usb port to work as 3.0

Depth Viewer is working alone
giving me a warning msg that tells me " Your Camera Firmware need to be updated through ZED Explorer"

when i try to open ZED Explorer i’m getting this error

ZED Explorer : ChangeResolution
ZED Explorer : changeFPS
ZED Explorer : changeFPS
ZED Explorer : Failed to setup device
Segmentation fault

It only pop-up and close immediately

Update the firmware on a Windows PC and try again. Also, you’ve installed the Jetpack correct? The ZED requires CUDA to be installed.

Hi Skanzi,

since ZED has a problem with Jetpack 2.2 and the SDK v1.0.0 (Jetpack 2.2 came out after v1.0.0), StereoLabs decided to disable the Firmware update from Jetson TX1 in the revised SDK v1.0.0c for ARM, just to avoid a corruption of the firmware on the ZED.

To be able to use the ZED with the new SDK with the Jetson TX1 you need to update the FW of the ZED using a PC with Linux or Windows.

I’m having a similar issue but updating the firmware on Windows did not fix my error.

I have a Jetson TX1 with L4T R24.1. The output of $head -n 1 /etc/nv_tegra_release is:

R24 (release), REVISION: 1.0, GCID: 7164062, BOARD: t210ref, EABI: hard

I have Cuda V7.0.74. The output of nvcc --version is:
Cuda Compilation tools, release 7.0, V7.0.74

I’m trying to run the ZED_ROS_WRAPPER launch file and I get the error:

ZED Firmware is not up-to-date with current ZED ZDK.

VGA mode will be not consistent

You have to update the firmware with the latest version (v1142) using ZED Explorer

I then plugged the ZED into a windows machine, opened up ZED explorer… hit settings… firmware. 1142 was listed in the box already. I hit update, navigated to the 1142 bin file. It gave me a prompt that it succeeded. Then I plugged back into the TX1, tried ZED.launch again and got the same errors.

Now the camera zed perfectly works at jetPack 2.3 64 bit with the new version of SDK ZED 1.1.1, at me also without problems ROS kinetic was set and in it earned zed ros wrapper as with RVIz and with rtabmap_ros. For operation it is necessary to set Cuda V8 (judging by responses it still possibly only with jetpak 2.3) and OpenCV from jetpak 2.3. In such combination the camera ZED normally works.

I second that: I switched to JP2.3 64b and to using ZED SDK V 1.1.1. over the weekend.

One thing probably worth to mention: In my case things didn’t work right away after installing the ZED driver. The ZED Explorer was freezing every other frame, and the ZED Depth Viewer just froze up. It wasn’t until after I rebooted the JTX1 that everything started working smoothly.