Auxiliary monitor not detected Ubuntu 20.04, driver 440

Hi folks!

I have a problem with dual monitor setup on my laptop. Basically additional monitor is not detected when using NVIDIA drivers.With Nouveau selected it is detected but I only see something that I can describe as visual noise + regular working mouse pointer (like I can move the mouse on that screen).

During Ubuntu installation the monitor was displaying everything properly, and there were no issues, however after the installation process, it is not detected anymore. The issue still persists after a second attempt at the installation with Ubuntu image redownloaded.

I tried both 440 and 435 drivers, same result. I also tried multiple different monitors (different manufacturers and resolutions).

I also tried removing any package with nvidia in its name, with autoremove afterwards and redownloaded drivers via Software & Updates, still no luck.

I am absolutely certain that HDMI port, cable and auxiliary monitors work since I’m dual booting and with Windows there are no issues, but as luck would have it I need the second monitor on Ubuntu rather than on Win10.

Here are the specs: HDMI connection, laptop ASUS TUF FX505DT-AL086, Ryzen 5 3550H, Vega 8 + GTX 1650, 16GB RAM, 970 EVO 500GB (Ubuntu), ADATA SU800 (Win10), separate SSDs for OSes, both installed in UEFI mode, default greeter and DE, no packages modifying those have been installed, Windows fast startup is disabled.

Additionally, I have no idea if that’s relevant, when booting Ubuntu without AC brick I sometimes can’t get to greeter screen, like everything freezes and the only way is to reconnect mains power and do a hard reboot.

And here’s the bug report

I’d be very grateful for any help with the issue, cheers!

1 Like

Please see this:

Thank you! Worked like a charm and solved my issue, even nVidia Settings are not empty anymore.

I would add to the solution: boot with the auxiliary screen turned on, change settings to single display (use Built-In display as primary), Apply, now change screens to mode you want.

I panicked a little when my built-in display was displaying just violet background and it turned out greeter was on the aux monitor which was not on :) Before the change mouse was restricted to auxiliary monitor as well.

Again, thank you!

Small follow if I may: greeter is being displayed on auxiliary monitor if it’s connected, but comes back to built in-display if auxiliary’s disconnected.

Any way of forcing it to always display on built-in? It’s set up as primary in settings.

You can copy the monitors.xml to gdm:
cd ~/.config
sudo cp monitors.xml /var/lib/gdm/.config/

1 Like

Thank you, worked!

p.s. 20.04 has /var/lib/gdm3/.config/ filepath


sorry for bothering again but it seems that after the update something went wrong with drivers again.

After issuing ‘sudo apt update’ and ‘sudo apt upgrade’ today I lost drivers.

What I tried doing:

  1. I did 'sudo apt remove ’ for all packages that I found with ‘apt list --installed | grep nvidia’
  2. reboot
  3. I tried installing 440 drivers from Software & Updates but it gives me one of the following (interchangibly)

Screenshot from 2021-01-07 17-23-46

Screenshot from 2021-01-07 17-43-30

  1. Tried removing all nvidia packages again and installing 435

‘nvidia-smi’ gives me the following “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

I believe that might be related to today’s update, I’d be grateful for any help

Bug report:
nvidia-bug-report.log.gz (160.7 KB)

You previously had a 5.4 kernel, so the driver 440 worked. Now you got upgraded to a 5.8 kernel so you’ll need a newer driver, like 455. Should be available from Software&Updates. If not, add the graphics drivers ppa.

1 Like

Thank you for the prompt reply, Software & Updates has only 440 and 435. Before I add the ppa just want to make sure it’s correct, would that be this one?
sudo add-apt-repository ppa:graphics-drivers/ppa

1 Like

Yes, that’s it.

Thank you, had some problems and ended up with ‘sudo apt purge’ of all nvidia packages then installed 455, trick for aux monitor worked and it’s all good again.

Much obliged :)