Secondary Display monitor is not detected by Nvidia drivers


Initially, I had no issue while connecting the monitor with my pc(Nvidia). Later, I’ve connected my monitor with another pc(AMD) and now connected it back to my first pc(Nvidia) couldn’t recognize the monitor(i see the unknown display in settings).

Nvidia drivers do not recognize my secondary monitor (Benq GW2480) on Ubuntu20.04 and Windows 10. I see an unknown display with a low resolution (1600 x 900), although my monitor supports 1920x1080. I attempted to install the following drivers:

  • NVIDIA driver metapackage from nvidia-driver-470 (proprietary, tested)
  • NVIDIA Server Driver metapackage from nvidia-driver-470-server (proprietary)
  • NVIDIA Server Driver metapackage from nvidia-driver-418-server (proprietary)
  • NVIDIA Server Driver metapackage from nvidia-driver-460-server (proprietary)
  • NVIDIA driver metapackage from nvidia-driver-460 (proprietary)
  • NVIDIA driver metapackage from nvidia-driver-390 (proprietary)
  • NVIDIA Server Driver metapackage from nvidia-driver-450-server (proprietary)

I installed Nouveau display drivers to see whether the problem was with the Nvidia driver, and the monitor was identified correctly with a 1920x1080 resolution but when I set the single display to monitor my pc runs extremely slow.

  • X.Org X server – Nouveau display driver from xserver-xorg-video-nouveau (open source)

My observations after trying many approaches such as:

  • Uninstalling, reinstalling, and updating drivers
  • Unplugging and re-plugging the HDMI cable
  • Factory resetting both Ubuntu 20.04 and Windows 10
  • Factory resetting the monitor
  • Changing the resolution manually in the Nvidia x server setting the display vision is so blurring and lagging
  • In windows, I had the same issue recognizing the monitor.

I even tried the approach mentioned in this comment but no luck.


  • Laptop: Dell G3 3579
  • Monitor: Benq GW2480
  • Processor: Intel i7-8750H
  • Operating System: Ubuntu 20.04.02 / Windows 10 (Dual boot)
  • Graphic card: Nvidia GTX 1050 TI

I’m attaching the bug report here. (Generated by this command sudo
nvidia-bug-report.log.gz (384.9 KB)

I’d be very grateful for any help with the issue, cheers!


it seems like i have the exact same problem. Have you already solved the issue?
Would help a lot to hear back from you. Thanks!

Hi @joho11,

I’ve tried even by changing my motherboard even though the issue remains the same no luck.

The answer from w-sky to the following question just helped me solve the problem:

Hope it works for you to!