Clean Ubuntu 23.10 install, Unable to change resolution or recognize second monitor


I have been trying to debug this issue where I can’t recognize my second display or change the resolution of the one which is plugged in. The system seems stuck in software rendering mode even though the GPU is detected and the drivers are installed.
I’ve tried 525, 535, 545 driver versions and none have worked. From other threads, I have been using the proprietary and not the open drivers.

Running nvidia-smi yields No devices were found
sudo lshw -c video does show the RTX4060 card and that it is using the Nvidia drivers.
System details report indicates its in software rendering mode
Tried adding nvidia, nvidia-drm, and nvidia-modset to /etc/modules which had no impact.
Tried adding GRUB_CMDLINE_LINUX=“pci=realloc” and sudo update-grub but no change.

Reverting to the old GPU, everything works fine but as soon as I install the RTX 4060 it boots up in the above stated low resolution, single monitor, software rendering mode. Swapping back to the old card things instantly work again.

535 driver bug report:
nvidia-bug-report-535.log.gz (555.3 KB)
545 driver bug report:
nvidia-bug-report-545.log.gz (277.5 KB)

# System Details Report

## Report details
- **Date generated:**                              2023-12-22 18:51:02

## Hardware Information:
- **Hardware Model:**                              MSI MS-7A37
- **Memory:**                                      64.0 GiB
- **Processor:**                                   AMD Ryzen™ 7 1700 × 16
- **Graphics:**                                    Software Rendering
- **Disk Capacity:**                               13.0 TB

## Software Information:
- **Firmware Version:**                            1.10
- **OS Name:**                                     Ubuntu 23.10
- **OS Build:**                                    (null)
- **OS Type:**                                     64-bit
- **GNOME Version:**                               45.1
- **Windowing System:**                            X11
- **Kernel Version:**                              Linux 6.5.0-14-generic

An update and resolution for this,
I was able to resolve the issue by updating the firmware on my motherboard. Probably should have checked that initially. But upon updating things began working fine with the new card.

1 Like

Thank you so much for updating this thread with your resolution @jesse.feinman! That is very much appreciated!

Over the holidays quite a few posts piled up, so sorry we did not get to yours yet.

Yet another parameter to check for in case there are Display issues with Ubuntu!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.