Geforce RTX30 mobile series does not recognize second monitor in Ubuntu 20.04

Hello,

in my laptop (MSI GP66 Leopard), which is equipped with a RTX3060, when I try to use an external monitor using the HDMI output, it is not recognized. Apparently, Ubuntu is using v460 drivers, and I’m pretty sure the secure boot is disabled. In Windows 10, the second monitor works perfectly.

Any ideas about how to solve it.

Many thanks

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Please, find attached the report.nvidia-bug-report.log.gz (101.4 KB)

Thank you very much for the support

See:
https://forums.developer.nvidia.com/t/ubuntu-20-04-driver-version-460-not-loaded/177334/2?u=generix

Hi

In file /etc/default/grub, I modified GRUB_CMDLINE_LINUX option to GRUB_CMDLINE_LINUX=“pci=realloc”
The second monitor is still not detected.

Thanks

did you run
sudo update-grub
afterwards?
please create a new nvidia-bug-report.log

Yes, I did run sudo update-grub and reboot.

Please, find attached the new report.

nvidia-bug-report.log.gz (99.7 KB)

Thanks

The driver seems to be blacklisted currently, please run
sudo prime-select nvidia

After running that command, I got “Info: the nvidia profile is already set”

Please post the output of

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/lib/modprobe.d/blacklist-nvidia.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-drm
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-modeset
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia off
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia-drm off
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia-modeset off

Please delete
/lib/modprobe.d/blacklist-nvidia.conf
then run
sudo update-initramfs -u
and reboot.

It works now =D

Thank you very much for your help