GeForce RTX 3060 not working with Ubuntu 20.04 (Focal Fossa)

I’ve been trying for a while now to install the Nvidia drivers in my laptop, but even though it seems to be installed the nvidia commands doesn’t work at all nor the HDMI displays works with an external screen (via HDMI).

The command:

nvidia-smi

gives the following output:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

And the:

nvidia-settings

gives the following output, even thoug,it opens the Nvidia X Server Settings :

ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

I don’t have much experience with ubuntu, but I’ve managed to follow almost everything I found to install them going through:

  1. Install using “Software & updates” → “Additional Drivers” and selecting the one is recommended by the ubuntu-drivers devices .
  2. Install using sudo apt install nvidia-driver-470 and also sudo ubuntu-drivers autoinstall
  3. Downloading the latest version for ubuntu from the Nvidia official page (last release september 20 if I’m not wrong)

Nothing has solved the issue and I can’t change to the Nvidia graphic card (in “Settings” → “About” → “Graphics” appears the intel card “Mesa Intel® UHD Graphics (CML GT2)”) nor use the nvidia commands

My laptop specs are the following:

  • Laptop: MSI GF65 Thin 10UE
  • CPU: Intel Core i5-10500H Processor
  • GPU: GeForce RTX3060/6GB GDDR6
  • OS: Ubuntu 20.04.3 LTS
    And using:
uname -s -r

I get:

Linux 5.11.0-36-generic

I will appreciate so much any kind of advice or help because I’m totally lost here, I don’t know what else to do… :/

PS. I tried installing the 18.04 ubuntu version and it didn’t work it neither

THANK YOU A LOT IN ADVANCE!!

Don’t use the .run file installer.
If you installed the driver this way, use the --uninstall switch to uninstall it.

Then run sudo apt install --reinstall nvidia-driver-470 and post the output here.
Then sudo prime-select nvidia. If it says already set, switch back to intel and then to nvidia again.
Reboot.
If it does not work, run nvidia-bug-report.sh as root and post the resulting file here.

Hi!!! Thank you for your answer!!

Did everything as you said, but couldn’t make it work still…

I attach the file with the file!!
Again very thankfull for your help!!

nvidia-bug-report.log.gz (1.2 MB)

[ 0.425680] pci_bus 0000:00: Some PCI device resources are unassigned, try booting with pci=realloc

First check your BIOS, look for 4G Decoding, or large BAR support and enable, if disabled.
If it was disabled, check for that above message (in dmesg), if it still appears, try booting with pci=realloc.

Your kern.log and dmesg output are full of these messages:

sep 27 18:53:22 alexiot kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 511
sep 27 18:53:22 alexiot kernel: NVRM: request_mem_region failed for 0M @ 0x0. This can
NVRM: occur when a driver such as rivatv is loaded and claims
NVRM: ownership of the device’s registers.
sep 27 18:53:22 alexiot kernel: NVRM: The NVIDIA probe routine failed for 1 device(s).

Also show the output of grep -r -E "nouveau|nvidiafb|nvidia" /etc/modprobe.d/

nouveau and nvidiafb should be blacklisted.

Hi Mart!!!

Just checked the 4G Decoding (Above 4G…) in the BIOS menu, and it was already enabled.

Using the grep -r -E "nouveau|nvidiafb|nvidia" /etc/modprobe.d/ I got the following output:

/etc/modprobe.d/blacklist-nvidia-nouveau.conf:blacklist nouveau
/etc/modprobe.d/blacklist-nvidia-nouveau.conf:options nouveau modeset=0
/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb

I think it means that those are already blacklisted, right?

Thank you for the help and the patience!!

Sorry Mart!!!

Tried the pci=realloc also looking from one of your answers to other posts to know how to do it and it works flawlessly!!

Appreciate a lot your help!! :D