Ubuntu 20.04 Second Monitor (Usually) Not Working

I have a fresh install of Ubuntu 20.04 on my Acer Aspire V15 Nitro laptop (which has a Geforce GTX 960M). I am running nvidia-460 drivers (recommended). For the most part, I can’t get a second (HDMI) monitor to function. Sometimes, however, it works fine.

I had a similar but lesser problem on my previous 18.04 install with nvidia drivers. In that case, the monitor was usually blank at startup, but if I unplugged it from the hdmi port and replugged it in, it usually worked fine. Sometimes it wouldn’t, and sometimes it wouldn’t display after waking the laptop, requiring a restart.

With the fresh install of 20.04, the second monitor displayed fine for the first few hours and several restarts and then simply stopped after a reboot. I thought maybe it was one of the gnome tweak extensions I had just installed, but I undid them all and the problem persists. Sometimes the second monitor will show the boot screen or even the gnome login, but then it goes blank. Replugging it into the port no longer seems to work. However, sometimes it starts working after I wake the laptop from sleep (in these instances it takes over as the main display, showing the launcher and top bar). A few times I’ve also had issues with my main laptop display being blank after logging in or waking too.

I’m fairly certain it’s not the monitor or cable – I’ve tried two different monitors/cables and the issue’s been the same. Both monitors work fine with my windows laptop. I’m using an hdmi > display port adaptor for one monitor, but I don’t think that matters.

Things I’ve tried with no luck:

  • lightdm (the second monitor briefly worked when I reverted to gdm3, until the next reboot)
  • adding nomodeset to grub
  • removing quiet splash from grub
  • disabling safe boot
  • nouveau drivers
  • other nvidia drivers (450, 390)
  • lowering the screen resolution
  • a bunch of other random config tweaks people have suggested in various posts online, all of which I reverted after they did nothing

Would really appreciate some help, I’ve spent hours and hours on this already.

I ran nvidia-bug-report.sh as root, I’ve attached the bug log:nvidia-bug-report.log.gz (390.8 KB)

Please see this:
https://forums.developer.nvidia.com/t/ubuntu-18-04-3-blank-screen-at-startup-with-430-drivers-and-gtx-960/107501/2
leads to tearing, though.

I changed modeset to 0 in /lib/modprobe.d/nvidia-kms.conf, updated initramsfs, and rebooted, but the problem persists (tried both monitors).

(I’m assuming downgrading from 460 to the 440 drivers mentioned in that post wouldn’t matter.)

Any other suggestions?

Please post the output of

sudo cat /sys/module/nvidia_drm/parameters/modeset

with modeset=0 and create a new nvidia-bug-report.log.

Output:

$sudo cat /sys/module/nvidia_drm/parameters/modeset:
N

Here’s the new bug log:nvidia-bug-report.log.gz (382.7 KB)

Please post the output of
xrandr --verbose
while on desktop.

Output attached as a text file: xrandroutput.txt (24.0 KB)

Ok, all your external outputs are connected to the intel igpu, the nvidia gpu has none. You can revert the modeset setting back to 1, the nvidia driver doesn’t have anything to do with the issue.
Did you have a monitor connected when you created the bug-report.log and the xrandr output?

Yes, both times.

Ok, here’s the problem:

[    4.007184] i915 0000:00:02.0: HDMI-A-1: EDID is invalid:

the intel driver can’t properly communicate with your monitor.
Since you already tried different cables/monitors, I guess the connector is breaking.
You might also want to try upgrading your bios.

Ah, so the actual hdmi port itself is failing? Lovely.

Will look into the bios upgrade.

Thanks for the super-quick help!