Geforce GTX870M Used To Power Two Monitors, Now (Post-OS-Update) Second One Doesn't Work

I’m a Linux (Mint) user. In Linux Mint 18 my laptop (powered by a GTX870M + Intel onboard graphics) was able to output to both of my monitors. I believe that I was using proprietary NVidia drivers, but I don’t remember for sure, or what version I used.

When I installed Linux Mint 20, monitor #2 stopped working. The laptop screen and monitor #1 (attached via old school analog VGA cable) works fine, just not monitor #2 (attached via an HDMI cable).

I used the graphics PPA and tried installing both versions 390,and 418 of the NVidia of the drivers, plus several in-between versions. In-between those attempts I used “apt-get purge nvidia” to wipe things. 418 wouldn’t even boot (black screen), while 390 worked without a second monitor. I also tried installing 418 (the recommended version for the card from the NVIDIA site) manually using a downloaded .run file, but it didn’t help.

I tried using both Bumblebee and Prime, but neither helped. Interestingly, I thought perhaps one monitor was controlled by one graphics card and one by the other, but whether I did “prime-select intel” or “prime-select nvidia” it had no effect: I could always see monitor #1 and not #2.

Also I should note that throughout every attempt I’ve never been able to make the Nvidia settings program work. At best it shows just the PRIME tab, with no other tabs, and in many cases it shows nothing at all (just an empty gray box).

I’m currently running the open source Nouveau driver. Using it I can actually see my second monitor in the Displays app … but if I try to enable it using that app, I just see a black screen, with my (functional but useless) mouse cursor and nothing else. This happens even if I disable the other monitor first.

Playing around with xrandr I see:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
1920x1080 60.02*+ 60.01 59.97 59.96 59.93
(LOTS of resolutions)
VGA-1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 597mm x 336mm
1920x1080 60.00*+
(A FEW resolutions)
DP-1-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 connected (normal left inverted right x axis y axis)
1920x1080 74.97 + 59.96 60.00 50.00 59.94 59.93
(LOTS of resolutions)

I assume eDP-1 is my laptop monitor, VGA-1 my working monitor #1, so the fact that HDMI-1-1, presumably my not-working monitor, is showing up seems good … but if I try to use xrandr to enable the monitor, eg. with:

xrandr --output HDMI-1-1 --mode 1920x1080

it crashes things (my mouse keeps working but I can’t click on anything).

I can’t actually provide a bug report for my current (Nouveau) setup, and when I tried to reinstall the 390 drivers (to get the bug report script) I couldn’t get the system to come up (even with nomodeset). I have no idea why, as the 390 drivers worked before. So, what I did was boot into recovery mode with the 390 drivers, run the script, and I’ve included that (probably totally useless) report below. I realize that’s sub-optimal, but since for some reason I can’t get proprietary drivers to work anymore I can’t get a proper report (but would be happy to run any other diagnostics to provide any other reports).

I would appreciate any guidance whatsoever. I will reinstall my entire operating system if I have to, use any PPA, any drivers, install them through package management or manually, use Bumblebee, Nvidia-Prime, Optimus Prime … WHATEVER. All I want is to be able to use both my monitors like I used to be able to.

*** BUG REPORT ***


Start of NVIDIA bug report log file. Please include this file, along
with a detailed description of your problem, when reporting a graphics
driver bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to ‘linux-bugs@nvidia.com’.

nvidia-bug-report.sh Version: 27505042

Date: Tue 28 Jul 2020 06:04:42 PM PDT
uname: Linux jeremy-Laptop 5.4.0-42-generic #46-Ubuntu SMP Fri Jul 10 00:24:02 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
command line flags:

Just wanted to mention that I added a bounty on the Stack Exchange question I made for this issue, so if anyone here uses Stack Exchange … free points :) https://unix.stackexchange.com/questions/600777/linux-mint-20-laptop-with-nvidia-card-cant-get-second-monitor-to-work

And putting Stack Exchange aside, I’d just like to reiterate that I would appreciate any help or assistance whatsoever, even the kind that’s “you’re an idiot and you’re doing it all wrong, and you have to do this long and complicated diagnostic task and report back”.