Problem after install 510 driver - Ubuntu 20.04 - GTX 1660

Hello, my name is Felipe and my english are not so good, apologize for that.

I tryed to do the log but i didn’t understood how to create it, beacouse my nvidia x-server are blank

I’m not sure what is happend but I tryed to update my system. After that my drivers are not working properly. My second monitor dont show image and the first monitor are the scale strange

I have tryed doing this steps:

  1. purge packages
    sudo apt-get remove --purge ‘^nvidia-.*’
  2. install the drivers back (open-source Nouveau)
    sudo apt-get install ubuntu-desktop
  3. sudo reboot

After doing that my second monitor show image and the scale was correctly. But was using Nouveau driver and this driver sometimes get stuck when I’am using zoom. So I tryed to install the last driver from nvidia.

I did this steps:

  1. search the drivers list
    apt search nvidia-driver
  2. update the system
    sudo apt update/upgrade
  3. Installing the last test driver
    sudo apt install nvidia-driver-510
  4. sudo reboot

After doing that my second monitor dont show image and the first monitor are the scale strange.

What should I to do?

Thanks so much,
Felipe.

can anyone can help me please? =)

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

1 Like

Hello, I was sending you one private menssage to ask if you can help me hehe

Thanks to explain how to do the bug report. I did and the result was:

lipe@Lipe-L:~$ nvidia-bug-report.sh

Command ‘nvidia-bug-report.sh’ not found, but can be installed with:

sudo apt install nvidia-utils-435 # version 435.21-0ubuntu7, or
sudo apt install nvidia-utils-440 # version 440.82+really.440.64-0ubuntu6
sudo apt install nvidia-340 # version 340.108-0ubuntu5.20.04.2
sudo apt install nvidia-utils-390 # version 390.144-0ubuntu0.20.04.1
sudo apt install nvidia-utils-450-server # version 450.172.01-0ubuntu0.20.04.1
sudo apt install nvidia-utils-470 # version 470.103.01-0ubuntu0.20.04.1
sudo apt install nvidia-utils-470-server # version 470.103.01-0ubuntu0.20.04.1
sudo apt install nvidia-utils-510 # version 510.47.03-0ubuntu0.20.04.1
sudo apt install nvidia-utils-418-server # version 418.226.00-0ubuntu0.20.04.2

Should i run sudo apt install nvidia-utils-510 ?

It should have been installed with the driver. Please try reinstalling the driver using Software&Updates application, if that doesn’t help, try installing the single package.

1 Like

Just to be sure, i should click in the driver 510- proprietary, tested?

To be safe, use the 470 driver first.

2 Likes

Hi, how can I run the nvidia-bug-report.sh on the root?

image

another point, when I was restarting the pc show one error:

run
sudo nvidia-bug-report.sh
this will create a file nvidia-bug-report.log.gz in your home directory which you can attach to your post.

1 Like

Oh thanks, i’m new in linux, i forget the sudo hehe

Here are the log
nvidia-bug-report.log (728.1 KB)
nvidia-bug-report.log.gz (112.5 KB)

Looks like you’re running a kernel that wasn’t built for Ubuntu 20.04 so the nvidia driver doesn’t build. Please switch back to the correct ubuntu kernel in grub menu, then create a new log.

1 Like

To choose the karnel correct i should to press Shift on the grub page? witch kernel is the correct for ubuntu, i’m searching in google but i’m not sure if that is correct. Sorry about that

I changed to 5.13.0-27-generic was 5.16, that was correctly?

5.13.0-27-generic should be correct, though there probably came out some updates since.

1 Like

hello, I’m not sure if this is open but I’m having the exact same issue installing version 510. I suspected my problem was the same in that I was using the wrong kernel on my machine but after changing to 5.13.0-27, it still doesn’t work. nvidia-smi still shows the driver is not installed or running. Any help on this would be appreciated

install 460.83 driver…it solves your problem

I have encountered the same problem. I am on a desktop, it boots into a laptop mode is the problem. it will not let you change the modes either. i see on the nvidia downloads they have specific drivers for notebook or desktop for the geforce gtx 1650 which is what i have. but, i cannot figure out how i am going to remove this one currently without damaging my 470 driver that is currently working ok. if i go to use apt it wants to remove all nvidia drivers not just the 1 i want. then i have to figure out how to install the driver i downloaded from them manually from there.