Ubuntu 22.04 nvidia driver installation failure (515.65.01)

I want to install nvidia driver on my Ubuntu 22.04. I tried different methods and failed.
First method:

sudo ubuntu-drivers autoinstall
sudo reboot


NVIDIA-SMI has failed because it couldn‘t communicate...

Sencond method:

sudo apt install nvidia-driver-515
sudo reboot


NVIDIA-SMI has failed because it couldn‘t communicate...

Third method:

sudo gedit /etc/modprobe.d/blacklist.conf
blacklist nouveau
options nouveau modeset=0
sudo update-initramfs -u
sudo service gdm3 stop
sudo chmod a+x NVIDIA-Linux-x86_64-515.65.01.run
sudo sh NVIDIA-Linux-x86_64-515.65.01.run

By trying this, nvidia-smi was running smoothly but I couldn’t restart gdm3. I rebooted Ubuntu, neither GUI nor tty could be entered. Only when I uninstall the driver, can I enter GUI and tty.
I want to install nvidia driver and at the same time I don’t want to lose my GUI and tty. What should I do next?

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I have the same problem. I left on a business trip Sunday, and today (Friday) I turned on my machine and am locked in 1024x768. I have a Dell T7910, Ubuntu 22.04, an EVGA 2080Ti, a Dell U3421WE.

If I use
sudo ./nvidia-bug-report.sh
I get a “command not found”

When I first started the computer today the driver shown on “Software and Updates” was 515-proprietary. I tried to change the driver to th 520 open source but I don’t think it’s loading. sudo dmesg yields:
[ 15.894476] NET: Registered PF_ALG protocol family
[ 17.039871] NVRM: Open nvidia.ko is only ready for use on Data Center GPUs.
[ 17.039874] NVRM: To force use of Open nvidia.ko on other GPUs, see the
[ 17.039874] NVRM: ‘OpenRmEnableUnsupportedGpus’ kernel module parameter described
[ 17.039875] NVRM: in the README.
[ 17.476113] NVRM: GPU 0000:03:00.0: RmInitAdapter failed! (0x63:0x0:1900)
[ 17.477391] NVRM: GPU 0000:03:00.0: rm_init_adapter failed, device minor number 0
[ 17.477642] [drm:nv_drm_load [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000300] Failed to allocate NvKmsKapiDevice
[ 17.477908] [drm:nv_drm_probe_devices [nvidia_drm]] ERROR [nvidia-drm] [GPU ID 0x00000300] Failed to register device
[ 17.477964] BUG: kernel NULL pointer dereference, address: 0000000000000040
[ 17.477995] #PF: supervisor read access in kernel mode
[ 17.478015] #PF: error_code(0x0000) - not-present page

The only change from last week to today was that the computer was off for five days. I did do an update and upgrade after trying various things. Didn’t not help.

Any insight? The nvidia card is virtually unusable. It’s not just that I don’t have good graphics - I can’t do my job.

Thanks in advance.

Ah! I ran
sudo /usr/bin/nvidia-bug-report.sh

log file is attched
nvidia-bug-report.log (2.2 MB)

Please switch back to the proprietary instead of -open driver version in Software&Updates.

Ok, the graphics have been restored. Was the corrective action to switch from version 515 to version 520, and then back again? Anyway, this seemed to fix it. Thanks.

In software&Updates, there should now be two variants of the driver, one with “-open” in its name, the other without.