GeForce GTX 1650 issue with Ubuntu 20.04

Hello guys! Ubuntu stuck on loading (on “Acer” logo) after NVIDIA drivers installed. Was trying lots of different methods to resolve it, but they didn’t work for me. So need your help.

I have brand new Acer Nitro 5 with Nvidia GeForce GTX 1650 in it. Tried to set up drivers version: 460 (also 465 and previously some older versions).

I’m trying to install Ubuntu alonside with Windows 10. (under Windows all works perfectly)

Initially I’m abble to install Ubuntu 20 only with “nomodeset”. Whitout it installation process stuck in the middle. But v 21 installs wihtout any issues.

Here my bug report
nvidia-bug-report.log (1.6 MB)

Thanks in advance!

The ryzen 5000 gpu in your notebook needs a newer kernel and firmware files. Please install Ubuntu 21.04, works ootb.

@generix Thanks. I did as you said.
I installed Ubuntu 21.04 from the scratch. Chose recommended Nvidia version of drivers (460), then made a reboot. And finally all worked well. I plugged in 2d monitor and it worked as well. And all looked good, until I boot Windows and then back to Ubuntu :( Now I see black screen with blinking cursor and nothing happens.

Here a fresh report
nvidia-bug-report.log (1.7 MB)

Thanks for helping

I’ve relatively recently got a new machine and I have Ubuntu 20.04 with the gtx 1650. I also experiences a black screen. It had a cursor and it didn’t blink though. This was at the login screen, but I just couldn’t see what I knew should be there.

This problem seemed to sort itself out after a couple of weeks (using a 2nd monitor let me see my log in screen), but the latest drivers seem to cause loads of issues other than this for me. Such as burst of awfully low frame rates and screen tearing.

I’m on the 460 drivers and the moment, but even when going back to 450, the same problems are still there along with a few more. My PC was actually fine for the first month I used it, and I think I will have been on some drivers prior to 450. I didn’t really look around at the additional drivers here as I’d just left it doing it’s own update for many years with my previous nvidia card and I never had any problems. I think I could do with trying to go to 445 or 440 (if I remember right) and they may have been what I used when everything was stable. I’ve seen someone else say on an nvidia forum that the older versions are much more stable and it would be better to go back to them. I’ve even seen loads of errors mentioned with 465.

I just have no idea how to go backwards