Ubuntu 20.04 block on startup screen after I installed nvidia drivers

nvidia-bug-report.log.gz (223.3 KB)

lspci | grep -i nvidia
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)


inxi -Fxz
Graphics:  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
       Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK driver: N/A bus ID: 01:00.0 
       Display: x11 server: X.Org 1.20.9 driver: nvidia resolution: 1920x1080~60Hz 
       OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.6 direct render: Yes

The problem:
I installed nvidia-driver-460 from GUI with “Software & Updates” from my ubuntu 20.04 pc (which is indeed in dual boot with windows 10).

During the installation, I typed a “legacy boot” password.

Then after install, I rebooted, MOC key screen appeared, I chosed enroll key, select the key 0 (which was the only one), typed my password, and It was done.

And then, after multiple hard reboots, it was impossible to launch ubuntu, the startup screen (with my Azus motherboard s logo at center and white ubuntu icon at the bottom) will freeze and kind of load continuously.

What has been done:
After I saw the bug,
I relaunched in recovery mode ubuntu with root terminal,
checked prime-select query, it was “nvidia”,
checked inxi -Fxz, and It shown “driver: nvidia” instead of “driver: N/A”,
so I thought nvidia drivers were well installed but graphic version won’t launch.

I then launched the nvidia bug report tool and made a bug report which is the one uploaded here.

I switched back to nouveau using prime-select intel, reboot normally, and I was able to get my os working back without any problems (though without nvidia drivers).

What can the problem be ?
Thanks.

Had similar issue, installing the 450 driver solved it for me, 460 and 465, didnt work

Unfortunately, installing the 450 driver did not change anything, I still have the exact same bug !

I experienced the same issue. Linux 460 Driver, Kubuntu 20.04 RTX 3070 not booting Both using kubuntu and manjaro .

After searching other post with similar issues, i found that high display monitors and displayport seems to be the problem.

Are you using displayport? If yes can you try to connect the monitor trough hdmi (I know not graphics nowadays have a hdmi output)

Unfortunately, I’m on a laptop which means I can’t change the hardware connection of the graphic card, It is really annoying at the moment, isn’t there other solutions ? Thanks.

That I tried no. If you look around in this forum y might find something. Some people had luck with a corgi manual configuration.

What does “corgi manual configuration” means ?
It means that I should download the drivers by myself with nvidia instalelr instead of using “Software & Updates” GUI from ubuntu ?
And I didn’t really find something on this forum, maybe I might search a lot more but this is really annoying, I switched from fedora to ubuntu to have my graphic drivers, and It still won’t work :/
Thanks whatsoever

Sorry the typo. “xorg.conf” manual configuration

I don’t really know how to do that properly + it should be working.

Like I literally switch to ubuntu for this easyness of installing driver, and I find here that it is infact completly false.

I tried install almost every single drivers I could and It won’t work, or when it work it won’t launch, as illustrated in my post.

Thanks for your help whatsoever

If it is the same bug i experienced , it is showing up in multiple distribution. Including arch and manjaro.

Yes doing a manual configurating of xorg is not ideal. Check this post and others like it. Maybe it can help you.

Even though I was able to launch my pc in tty mode, and nvidia-smi was showing up (with latest 465 driver) and everything’s were ok, I wasn’t able to launch gui with the driver installed.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1"

setting this didn’t change anything
as well as removing the # from # WaylandEnable=false

nor did the xorg conf of the topic you quoted worked (and with this xorg config, even with intel selected my pc won’t launch)

I’m out of solution, it is certainly a problem with automatic xorg config that is in fact not really good but Idk :/