Black screen after installing Nvidia driver in Ubuntu 20.04 LTS

Hello

I have an EVGA Nvidia GeForce GTX 1080Ti installed on a a Mac Pro 5,1 running Ubuntu Server 20.04 LTS. I installed the 460.32 driver after purging previous installations. Unfortunately, the system boots to a black screen.

The driver seems to be successfully installed:

$ nvidia-smi

±----------------------------------------------------------------------------+
| NVIDIA-SMI 460.32.03 Driver Version: 460.32.03 CUDA Version: 11.2 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
|===============================+======================+======================|
| 0 GeForce GTX 108… On | 00000000:05:00.0 Off | N/A |
| 28% 32C P8 8W / 250W | 2MiB / 11178MiB | 0% E. Process |
| | | N/A |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
|=============================================================================|
| No running processes found |
±----------------------------------------------------------------------------+

I followed the indications of other posts in the sense that there’s no /etc/X11/xorg.conf (didn’t have to delete if because it never was)

$ cat etc/X11/xorg.conf
cat: etc/X11/xorg.conf: No such file or directory

Grub includes the following:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nvidia-drm.modeset=1”
GRUB_CMDLINE_LINUX=“"

I have not blacklisted nouveau as recommended in some post (in fact, I had and didn’t work, so I removed the blacklisting)

There are in fact two GPUs, but the GeForce 1080Ti is the one selected:

$ lspci | grep ’ VGA ’ | cut -d" " -f 1 | xargs -i lspci -v -s {}
05:00.0 VGA compatible controller: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev a1) (prog-if 00 [VGA controller])
Subsystem: eVga.com. Corp. GP102 [GeForce GTX 1080 Ti]
Physical Slot: 1
Flags: bus master, fast devsel, latency 0, IRQ 66
Memory at a4000000 (32-bit, non-prefetchable) [size=16M]
Memory at 80000000 (64-bit, prefetchable) [size=256M]
Memory at 90000000 (64-bit, prefetchable) [size=32M]
I/O ports at 4000 [size=128]
Expansion ROM at a5000000 [virtual] [disabled] [size=512K]
Capabilities:
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

06:00.0 VGA compatible controller: NVIDIA Corporation G96C [GeForce 9500 GT] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Apple Inc. G96C [GeForce 9500 GT]
Physical Slot: 2
Flags: fast devsel
Memory at a2000000 (32-bit, non-prefetchable) [size=16M]
Memory at 98000000 (64-bit, prefetchable) [size=128M]
Memory at a0000000 (64-bit, non-prefetchable) [size=32M]
I/O ports at 3000 [disabled] [size=128]
Expansion ROM at a3000000 [disabled] [size=512K]
Capabilities:
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

$ prime-select query
nvidia

$ sudo lshw -c video
*-display
description: VGA compatible controller
product: GP102 [GeForce GTX 1080 Ti]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:05:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:66 memory:a4000000-a4ffffff memory:80000000-8fffffff memory:90000000-91ffffff ioport:4000(size=128) memory:a5000000-a507ffff
*-display UNCLAIMED
description: VGA compatible controller
product: G96C [GeForce 9500 GT]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:06:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:a2000000-a2ffffff memory:98000000-9fffffff memory:a0000000-a1ffffff ioport:3000(size=128) memory:a3000000-a307ffff

The monitor is connected to the HDMI port in the card and it works fine when booting into OS 10.12 (which has the corresponding Nvidia driver installed).

I’m attaching the nvidia-bug-report.nvidia-bug-report.log.gz (265.7 KB)

Same results if I install the 460.67 driver by the way.

Your advice will be much appreciated.

There’S an old GT9000 built in, which is keeping the driver from loading since it’s incompatible. Previously the nvidia driver had the documented option NVreg_AssignGpus but that’s gone, instead there’s now NVreg_ExcludedGpus but without documentation. Please try to use it, setting the kernel parameter

nvidia.NVreg_ExcludedGpus="0:06:00.0"

Edit: typo, excluded, not exclude

Like this?

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1 nvidia.NVreg_ExcludedGpus=“0:06:00.0”

I ran
$ sudo update-grub
and rebooted, but still the same

Yes, but like said, the docs are missing for that parameter so I don’t know how to correctly use it.
Please create a new nvidia-bug-report.log with that parameter set. If it doesn’t work at all, a udev rule could be used.

See attached
nvidia-bug-report.log.gz (266.3 KB)

I’m not quite sure what you mean by the udev rule, but if you point me into the right direction I’ll try to find out

The kernel driver seems to ignore it anyway, only the xorg driver stumbles upon it.
Please create /etc/X11/xorg.conf with only contents

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:5:0:0"
    Option         "AllowEmptyInitialConfiguration"
EndSection

I restored the kernel to
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nvidia-drm.modeset=1”

Create the xorg.conf as you said…

and IT WORKS PERFECTLY!

You have no idea the amount of time I spent googling the problem and trying the different solutions
Thank you so much for your help!!!