NVIDIA driver 440.59 doesnt work/HDMI not appearing/NVIDIA X Server Settings opens a blank square + Ubuntu 19.10

I am currently running Asus FX505DD (Ryzen 5 3550H + 1050 3GB Max-Q)
Seems like the driver is not working (correctly?)
I went from Ubuntu 18.04 to 19.10 expecting it to start working, but no luck.
I tried download drivers using ppa and “Additional Drivers”
At best I was ending up with black screen.

The graphics card is not appearing in Settings > Details too

Settings > Details:

Ubuntu 19.10
Device name : tomdery-fx505DD
Memory : 7,6GiB
Processor : AMD Ryzen 5 3550H with radeon vega mobile gfx x 8
Graphics : AMD Raven
GNOME : 3.34.2
OS type : 64-bit
Disk : 250.1GB (don't know why it is showing up as a full disc, because its a 165GB/82GB partition)
$ uname -a
Linux tomdery-FX505DD 5.3.0-29-generic #31-Ubuntu SMP Fri Jan 17 17:27:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
$ nvidia-smi
Tue Feb 11 21:35:05 2020       
| NVIDIA-SMI 440.59       Driver Version: 440.59       CUDA Version: 10.2     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 1050    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   39C    P0    N/A /  N/A |      0MiB /  3020MiB |      0%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|  No running processes found                                                 |
$ prime-select query
$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.1/0000:01:00.0 ==
modalias : pci:v000010DEd00001C91sv00001043sd000018F1bc03sc00i00
vendor   : NVIDIA Corporation
driver   : nvidia-driver-435 - distro non-free
driver   : nvidia-driver-440 - third-party free recommended
driver   : nvidia-driver-430 - third-party free
driver   : xserver-xorg-video-nouveau - distro free builtin
$ dmesg | grep -i nvidia
[    2.917756] nvidia: module license 'NVIDIA' taints kernel.
[    2.948852] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[    2.950059] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[    2.950960] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[    3.050903] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  440.59  Thu Jan 30 01:00:41 UTC 2020
[    3.100511] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  440.59  Thu Jan 30 00:59:18 UTC 2020
[    3.424579] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    3.424581] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
[    3.528870] nvidia-uvm: Loaded the UVM driver, major device number 234.
[    3.559163] audit: type=1400 audit(1581445640.860:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=774 comm="apparmor_parser"
[    3.559168] audit: type=1400 audit(1581445640.860:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=774 comm="apparmor_parser"
[    4.238409] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input15
$ inxi -Fxzd
  Host: tomdery-FX505DD Kernel: 5.3.0-29-generic x86_64 bits: 64 
  compiler: gcc v: 9.2.1 Desktop: Gnome 3.34.1 
  Distro: Ubuntu 19.10 (Eoan Ermine) 
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DD_FX505DD v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX505DD v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX505DD.310 date: 12/24/2019 
  ID-1: BAT0 charge: 29.3 Wh condition: 40.4/48.2 Wh (84%) model: FX50442 
  status: Discharging 
  Topology: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33540 
  Speed: 1240 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1363 2: 1315 
  3: 1252 4: 1276 5: 1333 6: 1323 7: 1337 8: 1246 
  Device-1: NVIDIA GP107M [GeForce GTX 1050 3 GB Max-Q] vendor: ASUSTeK 
  driver: nvidia v: 440.59 bus ID: 01:00.0 
  Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 04:00.0 
  Display: x11 server: X.Org 1.20.5 driver: ati,fbdev 
  unloaded: modesetting,nouveau,nvidia,radeon,vesa 
  resolution: 1920x1080~120Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.33.0 5.3.0-29-generic LLVM 9.0.0) 
  v: 4.5 Mesa 19.2.8 direct render: Yes 
  Device-1: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 04:00.6 
  Sound Server: ALSA v: k5.3.0-29-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: rtl8821ce v: v5. 
  port: d000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
  Local Storage: total: 232.89 GiB used: 10.08 GiB (4.3%) 
  ID-1: /dev/sda vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB 
  temp: 45 C 
  Message: No Optical or Floppy data was found. 
  ID-1: / size: 76.40 GiB used: 10.04 GiB (13.1%) fs: ext4 dev: /dev/sda5 
  System Temperatures: cpu: 45.6 C mobo: N/A gpu: amdgpu temp: 45 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 337 Uptime: 46m Memory: 7.28 GiB used: 2.48 GiB (34.1%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.2.1 Shell: bash v: 5.0.3 
  inxi: 3.0.36

nvidia-bug-report.log.gz (404 KB)

I also have the same problem, I have installed linux mint first and then arch linux giving both the same problem.
The free driver causes the system to freeze and the proprietary driver only detects an output, or the built-in or hdmi screen (in that case the laptop screen is lit in black with a _).

I am really sorry to have acquired this laptop for its graphics card, whose support for Linux should have improved.

– En Español —

yo tambien tengo el mismo problema, he instalado primero linux mint y despues arch linux dando ambos el mismo problema.
El driver libre provoca que el sistema se quede congelado y el driver propietario solo detecta una salida, o la pantalla incorporada o hdmi (en ese caso la pantalla de la portatil queda encendida en negro con un _).

Realmente estoy muy arrepentido de haber adquirido esta portatil por su tarjeta gráfica, cuyo soporte para linux debió haber mejorado.

If I do something with /lib/modprobe.d/nvidia-kms.conf, for example

# This file was generated by nvidia-prime
# Set value to 1 to enable modesetting
# options nvidia-drm modeset=1

switch to :

# This file was generated by nvidia-prime
# Set value to 1 to enable modesetting
options nvidia-drm modeset=1

or vice versa, I get a signal to my monitor for a split second (sadly it turns off and on too fast for it to get any view, but one time I got ubuntu login screen)

Don’t know if it will help.

I have the same issue, there is not workaround to this issue i guess.

Is not possible to use dual monitor with this laptop, under linux.

xrandr --listproviders only shows eDP screen .

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

nvidia-bug-report.log.log (306.4 KB)
Thats kinda odd. Renamed it to .log
Thanks for your reply.

Looking forward to hear from you.

Please see this for an AMD/Nvidia combo:
nvidia-xconfig doesnt do what i want it to, nor does nvidia-settings - NVIDIA Developer Forums

I got the same issue, also I’ve tried installing nvidia proprietary drivers,and is not possible to get signal video on the second display, even more is not listed by xrander even the drivers appear to be working properly

Does anyone has found a workaround for this issue?
Bellow the related data

lshw -c video
description: VGA compatible controller
product: GP107M [GeForce GTX 1050 3 GB Max-Q]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:81 memory:f6000000-f6ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:f000(size=128) memory:f7000000-f707ffff
description: VGA compatible controller
product: Picasso
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:05:00.0
version: c2
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: driver=amdgpu latency=0
resources: irq:24 memory:e0000000-efffffff memory:f0000000-f01fffff ioport:d000(size=256) memory:f7500000-f757ffff

**xrandr --listproviders** 
Providers: number : 1
Provider 0: id: 0x54 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 1 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0


| NVIDIA-SMI 440.82 Driver Version: 440.82 CUDA Version: 10.2 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce GTX 1050 On | 00000000:01:00.0 Off | N/A |
| N/A 36C P8 N/A / N/A | 1MiB / 3020MiB | 0% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| No running processes found |

sudo dkms status
bbswitch, 0.8, 5.6.0-2parrot1-amd64, x86_64: installed
broadcom-sta,, 5.5.0-1parrot1-amd64, x86_64: installed
broadcom-sta,, 5.6.0-2parrot1-amd64, x86_64: installed
nvidia-current, 440.82, 5.6.0-2parrot1-amd64, x86_64: installed
realtek-rtl88xxau,, 5.5.0-1parrot1-amd64, x86_64: installed
realtek-rtl88xxau,, 5.6.0-2parrot1-amd64, x86_64: installed
virtualbox-guest, 6.1.8, 5.5.0-1parrot1-amd64, x86_64: installed
virtualbox-guest, 6.1.8, 5.6.0-2parrot1-amd64, x86_64: installed

**uname -a **
Linux parrot 5.6.0-2parrot1-amd64 #1 SMP Debian 5.6.14-2parrot1 (2020-05-23) x86_64 GNU/Linux

** systemctl status nvidia-persistenced.service **
● nvidia-persistenced.service - NVIDIA Persistence Daemon
Loaded: loaded (/lib/systemd/system/nvidia-persistenced.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2020-06-04 19:53:45 -03; 1 day 22h ago
Main PID: 761 (nvidia-persiste)
Tasks: 1 (limit: 26285)
Memory: 31.0M
CGroup: /system.slice/nvidia-persistenced.service
└─761 /usr/bin/nvidia-persistenced --user nvpd

Jun 04 19:53:44 parrot systemd[1]: Starting NVIDIA Persistence Daemon…
Jun 04 19:53:44 parrot nvidia-persistenced[761]: Started (761)
Jun 04 19:53:45 parrot systemd[1]: Started NVIDIA Persistence Daemon.

**sudo lspci | grep -i “VGA” **
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 3 GB Max-Q] (rev a1)
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c2)

nvidia-bug-report.log (1.9 MB)

Please uninstall bumblebee, then follow the instructions in the linked post.